Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 23-02-2019 00:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Re-,

kingsokar a écrit :


dpkg --no-act --force-remove-reinstreq --remove python-samba

dpkg: un problème de dépendance empêche la suppression de python-samba :
 samba-common-bin dépend de python-samba.
 samba dépend de python-samba ; cependant :
  Le paquet python-samba doit être supprimé.

dpkg: erreur de traitement du paquet python-samba (--remove) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 python-samba


Maintenant on connaît les dépendances inverses. Deux options, ignorer ou désinstaller les paquets :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --remove python-samba

ou

dpkg --no-act --force-remove-reinstreq --remove samba samba-common-bin python-samba


Montrera ce qui va encore casser, ou pas... Le cas de python-dnspython sera peut-être plus simple.

Dernière modification par èfpé (23-02-2019 00:54:42)

Hors ligne

#27 23-02-2019 01:30:41

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Voilà les retours :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --remove python-samba

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --remove python-samba
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 111425 fichiers et répertoires déjà installés.)
Supprimerait ou purgerait python-samba (2:4.5.12+dfsg-2+deb9u4) ...

 



dpkg --no-act --force-remove-reinstreq --remove samba samba-common-bin python-samba :

dpkg --no-act --force-remove-reinstreq --remove samba samba-common-bin python-samba
dpkg: un problème de dépendance empêche la suppression de samba :
 openmediavault dépend de samba ; cependant :
  Le paquet samba doit être supprimé.

dpkg: erreur de traitement du paquet samba (--remove) :
 problème de dépendance - suppression ignorée
dpkg: un problème de dépendance empêche la suppression de samba-common-bin :
 openmediavault dépend de samba-common-bin ; cependant :
  Le paquet samba-common-bin doit être supprimé.
 samba dépend de samba-common-bin (= 2:4.5.16+dfsg-1) ; cependant :
  Le paquet samba-common-bin doit être supprimé.

dpkg: erreur de traitement du paquet samba-common-bin (--remove) :
 problème de dépendance - suppression ignorée
dpkg: un problème de dépendance empêche la suppression de python-samba :
 samba-common-bin dépend de python-samba.
 samba dépend de python-samba ; cependant :
  Le paquet python-samba doit être supprimé.

dpkg: erreur de traitement du paquet python-samba (--remove) :
 problème de dépendance - suppression ignorée
Des erreurs ont été rencontrées pendant l'exécution :
 samba
 samba-common-bin
 python-samba
 

Dernière modification par kingsokar (23-02-2019 01:31:54)

Hors ligne

#28 23-02-2019 02:24:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bon{soir|ne nuit|jour},

kingsokar a écrit :


dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --remove python-samba

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --remove python-samba
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 111425 fichiers et répertoires déjà installés.)
Supprimerait ou purgerait python-samba (2:4.5.12+dfsg-2+deb9u4) ...


Bon j'avais oublié cet openmediavault, un détail... bref purger en ignorant serait bien le plus simple :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-samba


L'arbre des dépendances va encore morfler, mais ce sera réparable... idem pour python-dnspython :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba --purge python-dnspython


Si quelqu'un s'oppose à cette manip qu'il parle maintenant ou se taise à jamais ! Bonne chance, ...

Dernière modification par èfpé (24-02-2019 08:24:42)

Hors ligne

#29 23-02-2019 08:18:29

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Salut kingsokar,

Afin de nous permettre de vous communiquer les meilleurs réponses, ou d'entendre au mieux tes interventions, il est bon de renseigner de manière permanente sous ton avatar ou ton pseudo la configuration du (des) PC que tu utilises.
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#30 23-02-2019 14:06:22

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Merci smolski, j'ai renseigné ces éléments wink.

Concernant les commandes de èfpé :
dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-samba renvoie :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-samba
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 111425 fichiers et répertoires déjà installés.)
Supprimerait ou purgerait python-samba (2:4.5.12+dfsg-2+deb9u4) ...
 



dpkg --no-act --force-remove-reinstreq --ignore-depends=samba --purge python-dnspython renvoie :

dpkg --no-act --force-remove-reinstreq --ignore-depends=samba --purge python-dnspython
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 111425 fichiers et répertoires déjà installés.)
Supprimerait ou purgerait python-dnspython (1.15.0-1) ...
 



J'y pense, j'ai aussi une sauvegarde journalière de la partition système réalisée grâce au plugin de open media vault en utilisant la méthode "dd", il y aura peut être possibilité d'utiliser ça si jamais rien ne fonctionne mais je ne sais pas comment restaurer une telle sauvegarde pour l'instant.

Dernière modification par kingsokar (23-02-2019 14:07:09)

Hors ligne

#31 23-02-2019 20:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Re-,

kingsokar a écrit :

J'y pense, j'ai aussi une sauvegarde journalière de la partition système réalisée grâce au plugin de open media vault en utilisant la méthode "dd", il y aura peut être possibilité d'utiliser ça si jamais rien ne fonctionne mais je ne sais pas comment restaurer une telle sauvegarde pour l'instant.


Nous n'en sommes pas encore là, d'ailleurs ce serait ballot d'envoyer du lourd avant d'avoir essayé :

dpkg --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-dnspython python-samba


apt-get check

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 samba : Dépend: python-dnspython mais il n'est pas installé
         Dépend: python-samba mais il n'est pas installé
 samba-common-bin : Dépend: python-samba mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).


apt --fix-broken install

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
The following additional packages will be installed:
  python-dnspython python-samba
Paquets suggérés :
  python-gpgme
Les NOUVEAUX paquets suivants seront installés :
  python-dnspython python-samba
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 464 ko dans les archives.
Après cette opération, 9 958 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 python-dnspython all 1.15.0-1+deb9u1 [102 kB]
Réception de:2 http://ftp.fr.debian.org/debian stretch/main amd64 python-samba amd64 2:4.5.16+dfsg-1 [1 362 kB]
1 464 ko réceptionnés en 1s (743 ko/s)    
Sélection du paquet python-dnspython précédemment désélectionné.
(Lecture de la base de données... 111103 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-dnspython_1.15.0-1+deb9u1_all.deb ...
Dépaquetage de python-dnspython (1.15.0-1+deb9u1) ...
Sélection du paquet python-samba précédemment désélectionné.
Préparation du dépaquetage de .../python-samba_2%3a4.5.16+dfsg-1_amd64.deb ...
Dépaquetage de python-samba (2:4.5.16+dfsg-1) ...
Paramétrage de python-dnspython (1.15.0-1+deb9u1) ...
Paramétrage de python-samba (2:4.5.16+dfsg-1) ...
 


Ça passe sur une Debian un petit peu cassée mais pas trop... toi tu devras sans doute reconfigurer.

Hors ligne

#32 23-02-2019 20:58:05

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

dpkg --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-dnspython python-samba renvoie :

dpkg --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-dnspython python-samba                     dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
(Lecture de la base de données... 111425 fichiers et répertoires déjà installés.)
Suppression de python-dnspython (1.15.0-1) ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet python-dnspython (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: avertissement: problème contourné par utilisation de --force :
dpkg: avertissement: Le paquet est dans un état incohérent; vous devriez
 le réinstaller avant d'essayer de le supprimer.
Suppression de python-samba (2:4.5.12+dfsg-2+deb9u4) ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet python-samba (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 python-dnspython
 python-samba
 



apt-get check renvoie :

apt-get check
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



Enfin, apt --fix-broken install renvoie :

apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
The following additional packages will be installed:
  python-dnspython python-samba
Paquets suggérés :
  python-gpgme
Les paquets suivants seront mis à jour :
  python-dnspython python-samba
2 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 1 464 ko dans les archives.
Après cette opération, 4 096 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://deb.debian.org/debian stretch/main amd64 python-dnspython all 1.15.0-1+deb9u1 [102 kB]
Réception de:2 http://deb.debian.org/debian stretch/main amd64 python-samba amd64 2:4.5.16+dfsg-1 [1 362 kB]
1 464 ko réceptionnés en 0s (9 992 ko/s)
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 111426 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python-dnspython_1.15.0-1+deb9u1_all.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-dnspython_1.15.0-1+deb9u1_all.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Préparation du dépaquetage de .../python-samba_2%3a4.5.16+dfsg-1_amd64.deb ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: avertissement: le sous-processus ancien script pre-removal a retourné une erreur de sortie d'état 1
dpkg: tentative d'exécution du script du nouveau paquet à la place...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/python-samba_2%3a4.5.16+dfsg-1_amd64.deb (--unpack) :
 le sous-processus nouveau script pre-removal a retourné une erreur de sortie d'état 1
Traceback (most recent call last):
  File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
  File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error while cleaning up:
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-dnspython_1.15.0-1+deb9u1_all.deb
 /var/cache/apt/archives/python-samba_2%3a4.5.16+dfsg-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hors ligne

#33 23-02-2019 21:44:42

èfpé
Membre
Inscription : 10-07-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Re-,

kingsokar a écrit :


dpkg --force-remove-reinstreq --ignore-depends=samba,samba-common-bin --purge python-dnspython python-samba

...
Suppression de python-dnspython (1.15.0-1) ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet python-dnspython (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
...
Suppression de python-samba (2:4.5.12+dfsg-2+deb9u4) ...
  File "/usr/bin/pyclean", line 63
    except (IOError, OSError), e:
                             ^
SyntaxError: invalid syntax
dpkg: erreur de traitement du paquet python-samba (--purge) :
 le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1
...


Bref c'est reparti comme en 40 #1 quoi... À part tripatouiller les fichiers 'prerm', je ne vois pas trop.

sed -i '2a\exit 0' /var/lib/dpkg/info/python-dnspython.prerm

sed -i '2a\exit 0' /var/lib/dpkg/info/python-samba.prerm


Si le script Python /usr/bin/pyclean (fourni par le paquet python-minimal) était moisi cela se saurait !

Dernière modification par èfpé (24-02-2019 08:44:42)

Hors ligne

#34 24-02-2019 10:13:28

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour smile
post #21 la commande apt-cache policy ne passe pas en user. Ça indique peut-être un système plus malade ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#35 24-02-2019 12:14:44

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Je n'avais pas indiqué dans le post #21, mais lorsqu'exécutée en tant que simple user, apt-cache policy renvoie :

apt-cache policy
E: Ouverture du fichier de configuration /etc/apt/apt.conf.d/99openmediavault-proxy - ifstream::ifstream (13: Permission non accordée)
 

Hors ligne

#36 24-02-2019 12:37:54

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

La commande suivante te donne tous les paquets qui ne sont pas en version "stable". Essaye-la :

apt --installed list | grep -v '/stable'

Dernière modification par Beta-Pictoris (24-02-2019 12:38:45)

En ligne

#37 24-02-2019 14:37:16

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour Beta-Pictoris,

Voilà ce que la commande apt --installed list | grep -v '/stable' renvoie :

apt --installed list | grep -v '/stable'

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

En train de lister…
containerd.io/now 1.2.2-3 amd64  [installé, local]
docker-ce/now 5:18.09.2~3-0~debian-stretch amd64  [installé, local]
docker-ce-cli/now 5:18.09.2~3-0~debian-stretch amd64  [installé, local]
duplicati/now 2.0.3.3-1 all  [installé, local]
libjs-extjs6/now 6.2.0.981-2 all  [installé, local]
linux-compiler-gcc-6-x86/stretch-backports,now 4.19.16-1~bpo9+1 amd64  [installé, automatique]
linux-headers-4.19.0-0.bpo.1-amd64/now 4.19.12-1~bpo9+1 amd64  [installé, local]
linux-headers-4.19.0-0.bpo.1-common/now 4.19.12-1~bpo9+1 all  [installé, local]
linux-headers-4.19.0-0.bpo.2-amd64/stretch-backports,now 4.19.16-1~bpo9+1 amd64  [installé, automatique]
linux-headers-4.19.0-0.bpo.2-common/stretch-backports,now 4.19.16-1~bpo9+1 all  [installé, automatique]
linux-headers-amd64/stretch-backports,now 4.19+102~bpo9+1 amd64  [installé, automatique]
linux-image-4.19.0-0.bpo.1-amd64/now 4.19.12-1~bpo9+1 amd64  [installé, local]
linux-image-4.19.0-0.bpo.2-amd64/stretch-backports,now 4.19.16-1~bpo9+1 amd64  [installé, automatique]
linux-image-amd64/stretch-backports,now 4.19+102~bpo9+1 amd64  [installé]
linux-kbuild-4.19/stretch-backports,now 4.19.16-1~bpo9+1 amd64  [installé, automatique]
omvextras-common/now 4.0.1 all  [installé, local]
omvextras-netrc/now 3.0.1 all  [installé, local]
openmediavault/now 4.1.19-1 all  [installé, local]
openmediavault-backup/now 4.0.5 all  [installé, local]
openmediavault-clamav/now 4.1.9 all  [installé, local]
openmediavault-docker-gui/now 4.1.3 all  [installé, local]
openmediavault-duplicati/now 4.0 all  [installé, local]
openmediavault-fail2ban/now 4.0.1 all  [installé, local]
openmediavault-keyring/now 1.0 all  [installé, local]
openmediavault-locate/now 3.4 all  [installé, local]
openmediavault-omvextrasorg/now 4.1.15 all  [installé, local]
openmediavault-openvpn/now 4.0.3 all  [installé, local]
openmediavault-plexmediaserver/now 3.8.2 all  [installé, local]
openmediavault-remotemount/now 4.0.5 all  [installé, local]
openmediavault-resetperms/now 3.3 all  [installé, local]
openmediavault-rsnapshot/now 4.2.1 all  [installé, local]
openmediavault-shellinabox/now 3.4 all  [installé, local]
openmediavault-snapraid/now 3.7.3 all  [installé, local]
openmediavault-urbackup-server/now 3.1 all  [installé, local]
openmediavault-virtualbox/now 4.1.1 all  [installé, local]
php-pam/now 1.0.3-1 amd64  [installé, local]
phpvirtualbox/now 5.2-1 all  [installé, local]
plexmediaserver/now 1.14.1.5488-cc260c476 amd64  [installé, local]
python-dnspython/now 1.15.0-1 all [installed,upgradable to: 1.15.0-1+deb9u1]
python3-chardet/stretch-backports,now 3.0.4-1~bpo9+1 all  [installé, automatique]
python3-idna/stretch-backports,now 2.6-1~bpo9+1 all  [installé]
python3-requests/stretch-backports,now 2.20.0-2~bpo9+1 all  [installé, automatique]
python3-urllib3/stretch-backports,now 1.24-1~bpo9+1 all  [installé, automatique]
snapraid/now 11.3-1 amd64  [installé, local]
urbackup-server/now 2.3.7.0-1 amd64  [installé, local]
virtualbox/stretch-backports,now 5.2.24-dfsg-4~bpo9+1 amd64  [installé, automatique]
virtualbox-dkms/stretch-backports,now 5.2.24-dfsg-4~bpo9+1 all  [installé, automatique]
virtualbox-ext-pack-installer/now 5.2.18 all  [installé, local]

Hors ligne

#38 24-02-2019 15:26:50

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Pour pouvoir faire tes mises à jour, tu dois d'abord repasser un certain nombre de paquets en "stable".
Par exemple, si c'est python qui pose problème :

apt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable


Ça marchera à condition que ces versions de paquets ne soient pas obligatoires pour d'autre programmes. Si, c'est le cas tu devrais désactiver tous tes dépôts non stable et repasser tous tes paquets en stable.

Dernière modification par Beta-Pictoris (24-02-2019 15:29:03)

En ligne

#39 24-02-2019 15:37:44

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Pour compléter ma réponse au dessus, tu peux créer une liste de paquets avec le suffixe "/stable" à partir de la liste des paquets non stable :

apt --installed list | awk -F/ '!/stable/ && NR>1 {print $1"/stable"}' > liste


Ensuite, éditer cette liste pour supprimer les paquets qui n'existent pas dans le dépôt stable. Tu devras, aussi, désinstaller ces paquets s'ils gênent la réinstallation des paquets stable.

Puis faire une simulation de réinstallation des paquets en stable de la liste :

 apt -s install $(cat liste)

En ligne

#40 25-02-2019 00:04:13

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir,

Voilà quelques résultats :

apt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable
renvoie :

pt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Version choisie « 1.15.0-1+deb9u1 » (Debian:9.8/stable [all]) pour « python-dnspython »
Version choisie « 2.3.0-2 » (Debian:9.8/stable [all]) pour « python3-chardet »
Version choisie « 2.2-1 » (Debian:9.8/stable [all]) pour « python3-idna »
Version choisie « 2.12.4-1 » (Debian:9.8/stable [all]) pour « python3-requests »
Version choisie « 1.19.1-1 » (Debian:9.8/stable [all]) pour « python3-urllib3 »
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).



Je n'ai pas bien compris la suite de tes indications par contre. apt --installed list | awk -F/ '!/stable/ && NR>1 {print $1"/stable"}' > liste a bien crée une liste (en tout cas nano liste m'en a renvoyé une):

containerd.io/stable
docker-ce/stable
docker-ce-cli/stable
duplicati/stable
libjs-extjs6/stable
linux-compiler-gcc-6-x86/stable
linux-headers-4.19.0-0.bpo.1-amd64/stable
linux-headers-4.19.0-0.bpo.1-common/stable
linux-headers-4.19.0-0.bpo.2-amd64/stable
linux-headers-4.19.0-0.bpo.2-common/stable
linux-headers-amd64/stable
linux-image-4.19.0-0.bpo.1-amd64/stable
linux-image-4.19.0-0.bpo.2-amd64/stable
linux-image-amd64/stable
linux-kbuild-4.19/stable
omvextras-common/stable
omvextras-netrc/stable
openmediavault/stable
openmediavault-backup/stable
openmediavault-clamav/stable
openmediavault-docker-gui/stable
openmediavault-duplicati/stable
openmediavault-fail2ban/stable
openmediavault-keyring/stable
openmediavault-locate/stable
openmediavault-omvextrasorg/stable
openmediavault-openvpn/stable
openmediavault-plexmediaserver/stable
openmediavault-remotemount/stable
openmediavault-resetperms/stable
openmediavault-rsnapshot/stable
openmediavault-shellinabox/stable
openmediavault-snapraid/stable
openmediavault-urbackup-server/stable
openmediavault-virtualbox/stable
php-pam/stable
phpvirtualbox/stable
plexmediaserver/stable
python-dnspython/stable
python3-chardet/stable
python3-idna/stable
python3-requests/stable
python3-urllib3/stable
snapraid/stable
urbackup-server/stable
virtualbox/stable
virtualbox-dkms/stable
virtualbox-ext-pack-installer/stable
 



Ne voyant rien indiquant "unstable", j'ai tenté ta dernière commande :

apt -s install $(cat liste)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: La version « stable » de « containerd.io » est introuvable
E: La version « stable » de « docker-ce » est introuvable
E: La version « stable » de « docker-ce-cli » est introuvable
E: La version « stable » de « duplicati » est introuvable
E: La version « stable » de « libjs-extjs6 » est introuvable
E: La version « stable » de « linux-headers-4.19.0-0.bpo.1-amd64 » est introuvable
E: La version « stable » de « linux-headers-4.19.0-0.bpo.1-common » est introuvable
E: La version « stable » de « linux-headers-4.19.0-0.bpo.2-amd64 » est introuvable
E: La version « stable » de « linux-headers-4.19.0-0.bpo.2-common » est introuvable
E: La version « stable » de « linux-image-4.19.0-0.bpo.1-amd64 » est introuvable
E: La version « stable » de « linux-image-4.19.0-0.bpo.2-amd64 » est introuvable
E: La version « stable » de « linux-kbuild-4.19 » est introuvable
E: La version « stable » de « omvextras-common » est introuvable
E: La version « stable » de « omvextras-netrc » est introuvable
E: La version « stable » de « openmediavault » est introuvable
E: La version « stable » de « openmediavault-backup » est introuvable
E: La version « stable » de « openmediavault-clamav » est introuvable
E: La version « stable » de « openmediavault-docker-gui » est introuvable
E: La version « stable » de « openmediavault-duplicati » est introuvable
E: La version « stable » de « openmediavault-fail2ban » est introuvable
E: La version « stable » de « openmediavault-keyring » est introuvable
E: La version « stable » de « openmediavault-locate » est introuvable
E: La version « stable » de « openmediavault-omvextrasorg » est introuvable
E: La version « stable » de « openmediavault-openvpn » est introuvable
E: La version « stable » de « openmediavault-plexmediaserver » est introuvable
E: La version « stable » de « openmediavault-remotemount » est introuvable
E: La version « stable » de « openmediavault-resetperms » est introuvable
E: La version « stable » de « openmediavault-rsnapshot » est introuvable
E: La version « stable » de « openmediavault-shellinabox » est introuvable
E: La version « stable » de « openmediavault-snapraid » est introuvable
E: La version « stable » de « openmediavault-urbackup-server » est introuvable
E: La version « stable » de « openmediavault-virtualbox » est introuvable
E: La version « stable » de « php-pam » est introuvable
E: La version « stable » de « phpvirtualbox » est introuvable
E: La version « stable » de « plexmediaserver » est introuvable
E: La version « stable » de « snapraid » est introuvable
E: La version « stable » de « urbackup-server » est introuvable
E: La version « stable » de « virtualbox » est introuvable
E: La version « stable » de « virtualbox-dkms » est introuvable
E: La version « stable » de « virtualbox-ext-pack-installer » est introuvable

Hors ligne

#41 25-02-2019 00:52:08

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Simule une désinstallation du paquet python-samba pour voir si ça ne pose pas trop de problème :

apt -s remove python-samba


Tu pourras ensuite désinstaller ce paquet avant de lancer la commande suivante :

apt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable

En ligne

#42 25-02-2019 19:46:52

kingsokar
Membre
Distrib. : Debian GNU/Linux 9.8 (stretch)
Noyau : Linux 4.19.0-0.bpo.2-amd64
(G)UI : Aucun
Inscription : 19-02-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonsoir Beta-Pictoris,

Comme je m'y attendais un peu vu que tout ce qui touche à la suppression ou installation de paquets déconne, la commande apt -s remove python-samba renvoie :

apt -s remove python-samba
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 samba : Dépend: python-samba mais ne sera pas installé
 samba-common-bin : Dépend: python-samba mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



La deuxième commande, apt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable renvoie elle :

apt install python-dnspython/stable python3-chardet/stable python3-idna/stable python3-requests/stable python3-urllib3/stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Version choisie « 1.15.0-1+deb9u1 » (Debian:9.8/stable [all]) pour « python-dnspython »
Version choisie « 2.3.0-2 » (Debian:9.8/stable [all]) pour « python3-chardet »
Version choisie « 2.2-1 » (Debian:9.8/stable [all]) pour « python3-idna »
Version choisie « 2.12.4-1 » (Debian:9.8/stable [all]) pour « python3-requests »
Version choisie « 1.19.1-1 » (Debian:9.8/stable [all]) pour « python3-urllib3 »
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 python-samba : Dépend: libwbclient0 (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
                Dépend: samba-libs (= 2:4.5.12+dfsg-2+deb9u4) mais 2:4.5.16+dfsg-1 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 

Hors ligne

#43 25-02-2019 20:27:15

Beta-Pictoris
Membre
Lieu : Angers
Distrib. : Buster
Inscription : 12-08-2015

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Que donne ? :

apt policy


Que donne ?

apt autoremove


Que donne ?

dpkg -l python\* \*samba\*


Que donne ?

dpkg -r python-samba

Dernière modification par Beta-Pictoris (25-02-2019 23:34:33)

En ligne

#44 22-05-2019 21:25:07

Aznyouth
Membre
Inscription : 22-05-2019

Re : Mise à jour impossible (dépendances python-samba non satisfaites)

Bonjour!

Désolé de remonte ce topic, mais j'ai le même soucis...
Je suis aussi sous openmediavault.

Quelqu'un pourrait me dire les démarche nécessaire a faire?

Merci d'avance

Hors ligne

Pied de page des forums