Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-12-2018 11:26:16

yuksel
Membre
Lieu : Toulouse
Distrib. : Debian 10
Noyau : Linux 4.9.0-4-amd64
(G)UI : Xfce
Inscription : 04-08-2015

NAS avec Openmediavault Raspberry Pi

Bonjour,

Voulant héberger mes données et celles de ma compagne chez nous, j'ai décidé de mettre en place un NAS avec un raspberry sur lequel j'ai installé la distribution serveur basée sur débian : Openmediavault (OMV)

J'ai branché au "cul" du raspberry un disque dur externe USB sur lequel j'ai crée des partages de fichiers avec Samba.

Jusque là, tout marche bien en local mais je veux approfondir la chose et pouvoir accéder à mes données depuis l'extérieur. Pour cela j'ouvre des ports et je réussis à faire ce que je voulais.

Et me voila super content du résultat avec accès à mes données depuis l'extérieur...cet excès de plaisir me pousse à approfondir et paf : j'installe même un serveur PLEX pour accéder à mes vidéos depuis n'importe où !

Je suis aux anges ! en une semaine, moi le débutant, j'arrive à un résultat pas trop mal.....mais...et oui il y a un mais.....: depuis maintenant 3 jours, sans avoir modifié quoique ce soit aussi bien au niveau de ma Freebox qu'au niveau de la distribution Openmediavault ben je n'ai plus accès à mes données depuis l'extérieur.....snif

La seule chose que j'ai faite est de mettre à jour la distribution OMV : le souci viendrait de cette mise à jour m'ayant foutu le bazar quelque part ?

Bilan : depuis 3 jours, tout marche impeccable en local mais depuis l'extérieur, je n'ai plus accès à mes données.

Une âme charitable pour me filer un coup de main ?

...Car je n'ai vraiment pas envie de tout re installer dans un premier temps !

Merci par avance !!!!!!

Hors ligne

#2 06-12-2018 15:21:10

empanada
Membre
Distrib. : Debian 9 (Stretch)
Noyau : 4.9.0-7-amd64
(G)UI : LXDE
Inscription : 19-09-2018

Re : NAS avec Openmediavault Raspberry Pi

Il faut des informations plus précises: le(s) logiciel(s) utilisé(s), messages d'erreur, logs... On a rien de concret.

"blues are the roots and the other musics are the fruits" . Willie Dixon

Hors ligne

#3 06-12-2018 15:49:55

yuksel
Membre
Lieu : Toulouse
Distrib. : Debian 10
Noyau : Linux 4.9.0-4-amd64
(G)UI : Xfce
Inscription : 04-08-2015

Re : NAS avec Openmediavault Raspberry Pi

empanada a écrit :

Il faut des informations plus précises: le(s) logiciel(s) utilisé(s), messages d'erreur, logs... On a rien de concret.



Bonjour, j'utilise sur mon Iphone l'application File Explorer pour accéder à mes dossiers sur le NAS. Voici une capture d'écran depuis mon Iphone :

1544104019.jpg

Hors ligne

#4 06-02-2019 17:58:24

relaxmax
Membre
Inscription : 20-02-2018

Re : NAS avec Openmediavault Raspberry Pi

Il me semble que le problème vient tout simplement d'une adresse IP non fixe, qui aurait changé et donc rendu le NAS inaccessible depuis l'ancienne IP… pouvez-vous nous donner plus d'informations mais sans donner l'adresse IP en question par sécurité…

PS : j'aimerais connaître vos débits en lecture/écriture d'un fichier sur votre NAS. Avez-vous fait des tests dans ce sens ?

Hors ligne

#5 06-02-2019 22:09:47

Freemaster
Membre
Lieu : Nord
Distrib. : Debian amd64
Inscription : 31-07-2018
Site Web

Re : NAS avec Openmediavault Raspberry Pi

protocol smb ouvert sur le net ? sans vpn ?

Hors ligne

#6 06-02-2019 22:42:21

yole1
Membre
Distrib. : Debian9
(G)UI : Cinnamon
Inscription : 08-08-2017

Re : NAS avec Openmediavault Raspberry Pi

Revoir la configuration de tes règles de port forwarding? en fixant l'IP source par adressage MAC dans un premier temps il semble...

Dernière modification par yole1 (06-02-2019 22:43:19)

Hors ligne

#7 06-02-2019 23:00:31

root@rkn
Adhérent(e)
Lieu : Grenoble
Distrib. : Debian 10 Apache2 HTTPS HTTP/2 BROTLI REDIS
Noyau : PROD: 4.19.37-5 (2019-06-19) x86_64
(G)UI : headless - aucun
Inscription : 24-02-2018
Site Web

Re : NAS avec Openmediavault Raspberry Pi

Bonjour.

Utilisateur d'un NAS/debian/nextcloud sur free, je peux t'aider.

La première chose a vérifier, c''est de savoir si tu a une IPV4/6 full stack !!!
Cela se fait via ton espace client free, gestion de ma freebox, Afficher mon adresse IP et "les caractéristiques de ma ligne".

Il est FORTEMENT recommandé d'avoir une ip fixe fullstack, autrement tu auras deux problèmes majeur:
- rotation et partage de l'ip entre plusieurs utilisateurs.
- certaines plages de ports etant reservé a certains utilisateur ( fullstack = 1-65535, non-fullstack = utilisateur1 45210 à 55210, utilisateur2 55211 à 56209, utilisateur3 .....)
voir l'article suivant pour comprehension: https://lafibre.info/free-la-fibre/cgn- … #msg546740
depuis cet article, il semblerait qu'il y a plus de partages. la plage de partage vas de 1024 à 65535. divisé par 4, la plage fait donc des plages de 16000 ports. si ta plage est la première, tu auras les ports 1025 à 17025. En cas de nouveaux partage, par exemple 4 de plus, ta plage sera réduite de  1025 à 8062 ...
De plus, les ports inférieurs à 1024 ne sont pas routables. 

Pour info, cette demande d'IP full stack prends moins de 2 heures....et un reboot freebox.

Deuxièmement, vérifier que ton "serveur" soit reconnus pas la box en ayant un baux fixe pour son IP.

Troisièmement, vérifier que la plage des ports redirigé n'ait pas été remise a zéro, ce qui peut arriver.

Pourrais tu specifier ton type de freebox, v5-v6-v7

Vérifie ces points, et reviens.

Dernière modification par root@rkn (06-02-2019 23:09:53)


- If it works, dont update it.
- You don't know how, just do it, you will learn.
- Test, re-stest, test again, and maybe it will work.
- https://nextcloud.rkn.ovh/index.php/s/3yp93A7oNMPexcp

Hors ligne

#8 11-07-2019 10:33:51

yuksel
Membre
Lieu : Toulouse
Distrib. : Debian 10
Noyau : Linux 4.9.0-4-amd64
(G)UI : Xfce
Inscription : 04-08-2015

Re : NAS avec Openmediavault Raspberry Pi

Bonjour,

Merci pour ta réponse ! Finalement, j'ai tout re installé et cela marche nickel !!

Par contre, j'aimerai bien me lancer dans l'installation de Nextcloud sur mon Raspberry 3.

Je suis toujours chez Free je précise avec une freebox revolution. J'avais tenté l'installation de Nexcloud mais je galérais au niveau du nom de domaine car j'en avais acheté un chez OVH mais j'en avais également un d'activé avec la freebox donc je pense que le fait d'en avoir deux me mettait le bazar car je ne maitrisais pas du tout la gestion des domaines. Au final, j'avais abandonné l'idée d'installer Nextcloud et j'avais poursuivi l'installation de Openmediavault sauf qu’apparemment, comme j'utilise samba pour accéder à mes données, ça n'a pas l'air sécurisé du tout...peut-être utiliser un VPN et notamment celui que fournit la Freebox mais je n'y comprends rien....

Bref, si tu peux m'éclairer un peu concernant l'installation de Nextcloud sur mon Raspberry, la gestion du nom de domaine et l’utilisation du VPN de chez Free.

Merci par avance !

Dernière modification par yuksel (11-07-2019 11:22:00)

Hors ligne

Pied de page des forums