Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-08-2019 07:04:07

asecos
Membre
Distrib. : GNU/Linux Debian 9
Noyau : Linux 4.9.0-8
(G)UI : Gnome
Inscription : 02-08-2019

Commandes non reconnues en root sous Buster

Bonjour à tous,

J’ai installé hier soir Debian 10 sur une partition de test de mon portable. (j’étais sous Deb9 depuis pas mal de temps sur ma partition courante)

Passé les galères des firmwares non reconnus j’ai pu me lancer dans l’installation de tous mes logiciels et outils favoris et à la personnalisation de mon bureau.

J’ai été vite freiné dans mes hardeurs au moment d’ajouter mon utilisateur, crée lors de l’installation, dans le groupe sudo.

En effet après être passé en root via “su”, le bash ne reconnaissait pas les commandes “adduser” ou “useradd” !!! Alors que lorsque j’étais loggé en utilisateur je les voyais très bien ainsi que les manpages mais bien sur par l’autorisation de m’en servir.

Pas mal de recherches plus tard (sur le web), j’essaye de faire directement “./sbin/adduser monuser sudo” et là enfin ça fonctionne. ( bon normal j’ai lancé directement l’executable me direz vous)

Avez vous une idée de la source du problème ? un paramètre système/chemin mal configuré durant l’install ? une nouvelle sécurité de Deb10 (j’ai lu qu’elle avait fortement progressé)? Car si à chaque fois que j’ai une manip qui requiert “su” il ne reconnait pas les commandes de base, je vais être bien embêté !!!

Bon sinon j’ouvrirai aussi un autre post concernant dconf/gnome car je n’ai pas retrouvé non plus tous les paramètres que j’avais l’habitude de personnalisé…

Dernière modification par asecos (02-08-2019 07:04:25)

Hors ligne

#2 02-08-2019 07:09:09

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Commandes non reconnues en root sous Buster

asecos a écrit :

En effet après être passé en root via “su”,


Il faut utiliser su avec l'option qui te dirige directement vers le /home/root, soit :

su -


Le tuto de su :
https://debian-facile.org/doc:systeme:su#connexion-root wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 02-08-2019 07:10:49

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch et buster amd64
Noyau : d'olive
(G)UI : env i3-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Commandes non reconnues en root sous Buster

comme le dit si bien Esméralda, su  voir su -l big_smile

ls sont arrivés. Ils avaient la Bible et nous, nous avions la terre.
Ils nous ont dit : - Fermez les yeux et priez.
Et quand nous avons ouvert les yeux, ils avaient la terre et nous, nous avions la Bible".

Hors ligne

#4 02-08-2019 07:22:31

asecos
Membre
Distrib. : GNU/Linux Debian 9
Noyau : Linux 4.9.0-8
(G)UI : Gnome
Inscription : 02-08-2019

Re : Commandes non reconnues en root sous Buster

Je suis pas à la maison pour vérifier, mais j'ai à proximité un PC avec Deb9 et sur celui-ci un "su"simple fonctionne !

Et si je fais un

env | grep -i path

j'obtiens le même PATH dans les deux cas.

J'essayerai sur mon portable Deb10 ce midi pour voir la différence.

Sur mes install en Deb9 un simple su me permet d'avoir accès à toutes les commandes, vous pensez que j'avais fait quelques choses de particulier pour avoir ce résultat ?

Dernière modification par asecos (02-08-2019 07:27:05)

Hors ligne

#5 02-08-2019 07:25:14

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch et buster amd64
Noyau : d'olive
(G)UI : env i3-clavier bépo
Inscription : 28-03-2012
Site Web

Re : Commandes non reconnues en root sous Buster

fais un  su -l pour passer en root et refait ta commande woohoo.gif

ls sont arrivés. Ils avaient la Bible et nous, nous avions la terre.
Ils nous ont dit : - Fermez les yeux et priez.
Et quand nous avons ouvert les yeux, ils avaient la terre et nous, nous avions la Bible".

Hors ligne

#6 02-08-2019 07:28:33

asecos
Membre
Distrib. : GNU/Linux Debian 9
Noyau : Linux 4.9.0-8
(G)UI : Gnome
Inscription : 02-08-2019

Re : Commandes non reconnues en root sous Buster

lagrenouille a écrit :

fais un  su -l pour passer en root et refait ta commande https://debian-facile.org/img/smilies/xtras/woohoo.gif



je suis persuadé que cela va fonctionner, ce que je ne comprends pas du coup c'est pourquoi sur mes autres PC je n'ai jamais eu à faire autre chose qu'un simple "su", et j'aime comprendre big_smile

Hors ligne

#7 02-08-2019 07:35:04

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Commandes non reconnues en root sous Buster

Comme l'indique le tuto (que je viens de modifier pour le mettre plus clairement), le positionnement dans le système est aussi important selon que tu veuilles intervenir sur tout le système et donc depuis la session root en superadministrateur ou seulement depuis la session user en superadministrateur mais seulement depuis le /home/user dans l'arborescence du système.

C'est une simple question de positionnement, si depuis la session user sous superadministrateur tu te rediriges dans le /home/root, tu auras l'équivalent d'un su -.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 02-08-2019 07:56:32

asecos
Membre
Distrib. : GNU/Linux Debian 9
Noyau : Linux 4.9.0-8
(G)UI : Gnome
Inscription : 02-08-2019

Re : Commandes non reconnues en root sous Buster

non dans ma session su  sans option je suis bien redirigé en /home/user

c'est la seul différence que je vois sur mon install Debian 9.

Sur ma Debian 9 que je fasse "su" ou "su -" par contre lorsque je fais un "env | grep -i path j'ai toujours :/sbin qui apparait...

J'ai du cassé une sécurité à un moment sur cette vieille install. mais je retrouve pas quoi.

En tout cas merci, je saurai comment faire proprement à l'avenir wink

Hors ligne

#9 02-08-2019 09:53:48

bendia
Chadministrateur
Distrib. : Buster, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Commandes non reconnues en root sous Buster

@smolski, je ne suis pas certain de comprendre ce que tu dis, ou plutôt ce que je comprends ne me semble pas juste. Tu peux passer des commandes de n'importe quel chemin, c'est l'intérêt de la variable $PATH.

Sur Debian 9, un simple su mettait /sbin dans cette variable, mais plus sous Debian 10 où il fut faire su - ou su -l pour obtenir ce comportement, afin de coller au mieux aux normes POSIX (merci @enicar pour l'explication, ici ou sur IRC je ne sais plus wink ).

Il y a d'autres variables d'environnement (genre $HOME) qui sont initialisées différemment, d'où la modification du chemin, mais ça n'est pas la cause.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

#10 02-08-2019 10:10:08

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Commandes non reconnues en root sous Buster

Ah ben voilà, je retardais d'un train !
Je te m'en vas mettre ça au tuto, merci des détails bendia. smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 02-08-2019 10:36:20

asecos
Membre
Distrib. : GNU/Linux Debian 9
Noyau : Linux 4.9.0-8
(G)UI : Gnome
Inscription : 02-08-2019

Re : Commandes non reconnues en root sous Buster

bendia a écrit :

@smolski, je ne suis pas certain de comprendre ce que tu dis, ou plutôt ce que je comprends ne me semble pas juste. Tu peux passer des commandes de n'importe quel chemin, c'est l'intérêt de la variable $PATH.

Sur Debian 9, un simple su mettait /sbin dans cette variable, mais plus sous Debian 10 où il fut faire su - ou su -l pour obtenir ce comportement, afin de coller au mieux aux normes POSIX (merci @enicar pour l'explication, ici ou sur IRC je ne sais plus wink ).

Il y a d'autres variables d'environnement (genre $HOME) qui sont initialisées différemment, d'où la modification du chemin, mais ça n'est pas la cause.




ahhh et bien voilà la réponse, c'est bien ce que j'imaginais, c'est le fait d'être passé de Deb9 à DEb10 qui fait que ma manip ne fonctionne plus sans le "-" derrière su.

Sur d'autres forums, ils me disaient que ça avait toujours été le cas et que j'avais du cassé une sécurité de mon Deb9 !!

Hors ligne

#12 02-08-2019 11:03:20

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Commandes non reconnues en root sous Buster

@asecos,

Moi aussi je me suis fait pieger, de plus n'étant plus 100% debian mais avec d'autres machines sur des opensuse, et bien j'ai pas compris pourquoi. En faite la réponse est ici (c'estma demande dans ce forum):
https://debian-facile.org/viewtopic.php?id=24760

Parce qu'avant le « su » seul n'aurait jamais du se comporter comme
« su -l », mais c'était le cas. En quelque sorte le « su » d'avant ne
respecter pas la norme posix, alors que maintenant, il la respecte.





a+

Dernière modification par seb95 (02-08-2019 11:04:26)

Hors ligne

#13 02-08-2019 11:19:52

bendia
Chadministrateur
Distrib. : Buster, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Commandes non reconnues en root sous Buster

asecos a écrit :

Sur d'autres forums, ils me disaient que ça avait toujours été le cas et que j'avais du cassé une sécurité de mon Deb9 !!

Non, mais comme expliqué dans le fil de seb95, Debian était une des rares distributions (si ce n'est la seule ?) à ne pas respecter la norme POSIX à ce sujet jusqu'à la version 9.

Je vais essayer d'épingler les discussions à ce sujet en précisant les titres au besoin smile


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

Hors ligne

Pied de page des forums