Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-10-2019 13:38:49

Kryzo
Membre
Distrib. : Archlinux, Debian
Inscription : 24-10-2017

[RÉSOLU] Imprimante Epson XP-435

Bonjour,

Comme dit dans le titre, j'essaie d'installer cette imprimante.
Je télécharge donc les pilotes fournis sur le site constructeur ici http://download.ebz.epson.net/dsc/searc … archModule
Avant de faire un dpkg -i pour installer, on me demande d'installer le paquet lsb. Dans mes dépôts, j'ai lsb-base et lsb-release.
J'installe les 2, puis tente un dpkg -i paquet-epson.deb (ce n'est pas le vrai nom, je ne suis pas sur la machine pour coller la commande exact, mais peu importe)
dpkg me renvoie que lsb > 3.2 est toujours manquant.

Une idée de où je peux trouver ce paquet ? le pc est sur debian 10 buster.
J'ai les dépôts de base + ajout du non-free.

Merci d'avance.

Dernière modification par Kryzo (16-10-2019 15:24:33)

Hors ligne

#2 07-10-2019 14:34:25

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : [RÉSOLU] Imprimante Epson XP-435

bonjour Kryzo ,  big_smile

pour l'imprimante , je laisse  plus calé que moi répondre .

pour lsb , as tu pensé à ceci : ?

apt install --reinstall lsb

Hors ligne

#3 07-10-2019 14:44:33

leonlemouton
Adhérent(e)
Distrib. : Buster
(G)UI : Mate ∨ LXQt
Inscription : 14-08-2012

Re : [RÉSOLU] Imprimante Epson XP-435

Salut,

Et avec cette commande :

apt-get install --install-recommends task-print-server



Source :
https://www.debian-fr.org/t/dependance- … ster/79862

Bon courage.
:-)

Dernière modification par leonlemouton (07-10-2019 14:48:46)


Leonlemouton
°(")°

Hors ligne

#4 07-10-2019 14:48:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] Imprimante Epson XP-435

Bonjour Kryzo,

Kryzo a écrit :

Une idée de où je peux trouver ce paquet [lsb] ?


Dans le dépôt principal de la distribution Debian 8 (ce paquet binaire n'existe plus depuis Debian 9).

Deux possibilités : (1), reconstruire le paquet Epson, ou (2), installer le paquet printer-driver-escpr.

apt install printer-driver-escpr


Le paquet printer-driver-escpr du dépôt buster est en version 1.6.33, tu vérifies la prise en charge :

/usr/sbin/lpinfo --make-and-model "435 Series" -m

escpr:0/cups/model/epson-inkjet-printer-escpr/Epson-XP-432_435_Series-epson-escpr-en.ppd EPSON XP-432 435 Series , Epson Inkjet Printer Driver (ESC/P-R) for Linux


Donc cela devrait être bon... pour la partie impression. Pour la partie scanner, avec SANE c'est mort.

Dernière modification par èfpé (07-10-2019 15:18:42)

Hors ligne

#5 07-10-2019 16:21:14

bonyred
Membre
Distrib. : Debian bulleseye - 11
Noyau : 5.10.0-8-amd64
(G)UI : mate sur le portable et gnome sur ma tour
Inscription : 15-05-2015

Re : [RÉSOLU] Imprimante Epson XP-435

bonjour

As-tu essayé de passer par le système de configuration d'imprimantes?

system-config-printer



Pour le scanner peut-être par là.

http://support.epson.net/linux/en/imagescanv3.php

A plus.

Hors ligne

#6 08-10-2019 20:39:49

Kryzo
Membre
Distrib. : Archlinux, Debian
Inscription : 24-10-2017

Re : [RÉSOLU] Imprimante Epson XP-435

Bonsoir,

J'ai finalement opté pour la solution proposée par èfpé et elle a tout de suite été détecté connecté en filaire.
J'ignorai qu'un paquet tout fait existait, c'est bien pratique.
Pour le scanner, j'ai installé l'utilitaire d'epson mais pas encore testé.

Merci à tous pour vos réponses. smile

Hors ligne

#7 16-10-2019 15:19:10

Kryzo
Membre
Distrib. : Archlinux, Debian
Inscription : 24-10-2017

Re : [RÉSOLU] Imprimante Epson XP-435

Petit retour pour le scanner, l'installation de l'outil d'epson imagescan s'est déroulé avec succès.
Cependant, le logiciel n'enregistrait pas le document numérisé: un fichier apparaît mais disparaît aussitôt le processus terminé.
Après avoir vérifier les fichiers de conf dans /etc/sane.d/, les epson*.conf, dll.conf, dans /lib/udev/60-libsane et /etc/imagescan/ et quelques ajouts/modifs, pas d'amélioration.

Puis je suis tombé sur un thread sur askubuntu qui disait que dû à un bug non corrigé, le logiciel ne fonctionnait correctement qu'avec la variable de langage en_US.utf-8.

J'ai donc édité /usr/share/applications/imagescan.desktop et modifié la ligne comme suit:

Exec=env LANG=en_US.UTF-8 imagescan


Et ça fonctionne.
Par contre, leur logiciel ne conserve pas les paramètres de qualité, formats, lieu de sauvegarde...

Sinon pour ceux que ça intéresse, ça fonctionne avec

scanimage -L



Voilà et je peux passer en résolu. smile

Dernière modification par Kryzo (16-10-2019 15:29:42)

Hors ligne

#8 18-10-2019 17:28:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RÉSOLU] Imprimante Epson XP-435

Bonjour Kryzo,

Kryzo a écrit :

Et ça fonctionne.


Merci pour le partage de l'astuce (inspirée de cette réponse – j'imagine), qui peut intéresser lucarno.

Hors ligne

Pied de page des forums