Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-10-2020 11:09:32

jpt
Membre
Distrib. : Debian 10.6
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Aptitude <> Synaptic : 1 paquet kc pour l'un, tout ok pour l'autre

Bonjour,

je ne suis pas du tout spécialiste de ces outils, mais comme je suis en cours de préparation d'une nouvelle machine (et que j'aimerais qu'elle soit tip-top), je suis bien obligé de me documenter sur les mises à jour et donc sur les outils pour les mener à bien -- oui je sais, c'est le sujet cauchemar, si j'en crois les posts ici et partout ailleurs sur le web, chose que je trouve dramatique car la robustesse du système fini dépend de la qualité des outils utilisés pour le construire.

Et en l'espèce c'est grave la misère (pour moi) quand je vois (sur la vieille machine) qu'en y lançant aptitude cet outil me trouve 1 paquet cassé quand Synaptic n'en trouve aucun : lequel a raison ?

Pour les curieux, ça concerne libmagick++-dev, qui dépend de libmagick++5 (=8:6.7.7.10-5+deb7u4) et aptitude me propose d'abandonner l'installation de ce paquet -dev ou de réinstaller libmagick++5 à une version antérieure (deb7u20 -> deb7u4).

À mon avis le bug est dans le camp des dév's de magick, qui ont dû foirer leur versioning, mais le plus dément c'est que ce paquet n'est pas installé ! Alors, de quoi se mêle aptitude ? Outil pas fiable ?

Merci pour les retours,

PS : il y a beaucoup de gras, hein, et c'est dommage mais c'est lié à l'absence du bouton "code inline" qui permet une mise en forme au look "code" (police monospace) sans aller à la ligne.

Dernière modification par jpt (08-10-2020 11:37:40)


Ryzen3 3200G - Gigabyte B450M

Hors ligne

Pied de page des forums