Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2021 18:51:04

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

[RESOLU] Bug carte audio HDA Intel PCH puce Realtek ALC274

Bonjour les ami(e)s smile

Suite à ce problème : https://debian-facile.org/viewtopic.php?id=29812

Comme vous le voyez à chaque nouveau démarrage je lancer une video ou une musique et taper ces commandes pour avoir du son :

/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_MASK 0x04
/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DIRECTION 0x04
/usr/bin/hda-verb /dev/snd/hwC0D0 0x01 SET_GPIO_DATA 0x04



Je suis déjà content que cela fonctionne mais ne serai-t-il pas mieux de faire une correction directement dans le paquet (noyau?) qui gère cette carte ?

Sinon le cas échéant je pensais passer par un script qui serai lancé au démarrage.

Dernière modification par Slyfox (02-05-2021 20:36:29)

Hors ligne

#2 27-04-2021 22:09:28

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Bug carte audio HDA Intel PCH puce Realtek ALC274

Bonjour
sinon pour dépanner une clé usb audio qui fonctionne sous debian  ?

ps: l'audio numérique est gérer par le chipset intel, le realtek ALC274 est la pour fournir les sorties/entrée analogique

déjà en 2017 =>  https://www.phoronix.com/scan.php?page= … 15-285-289

Dernière modification par robert2a (27-04-2021 22:15:26)

Hors ligne

#3 01-05-2021 18:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : [RESOLU] Bug carte audio HDA Intel PCH puce Realtek ALC274

Bonjour,

Slyfox a écrit :

Je suis déjà content que cela fonctionne mais ne serait-il pas mieux de faire une correction directement dans le paquet (noyau ?) qui gère cette carte ?


As-tu tenté certains paramètres (par ex. : model=alc274-dell-aio ?) pour le module snd_hda_intel ?
Le plus simple est sans doute de créer un fichier bidouille.conf dans le répertoire /etc/modprobe.d/ :

nano /etc/modprobe.d/alc274.conf

options snd_hda_intel model=alc274-dell-aio


Puis redémarrer. La doc liste d'autres valeurs, relatives à "HP" et "GPIO", mais je ne peux rien tester.

Dernière modification par èfpé (03-05-2021 18:04:42)

Hors ligne

#4 01-05-2021 21:27:09

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

Re : [RESOLU] Bug carte audio HDA Intel PCH puce Realtek ALC274

Salut èfpé smile

Il faut que je vérifie... c'est quel fichier qu'il faut éventuellement éditer ?

NB
Pour ce problème j'ai ouvert une discussion ici: https://debian-facile.org/viewtopic.php?id=29812 je te propose de continuer là-bas...
Cette discussion est plus pour savoir comment signaler un bug, merci de ton aide. smile

Dernière modification par Slyfox (01-05-2021 21:39:43)

Hors ligne

#5 02-05-2021 19:32:57

Slyfox
Membre
Distrib. : Debian Sid
Noyau : Linux 5.10.0-6-amd64
(G)UI : Mate 1.24.1
Inscription : 15-12-2013

Re : [RESOLU] Bug carte audio HDA Intel PCH puce Realtek ALC274

@ èfpé

Merci pour l'astuce ! ça marche ! cool

Pour info ce problème a déjà été signalé par une autre personne... reste à attendre un futur correctif.

https://sourceforge.net/p/alsa/mailman/ … sg37270671

Dernière modification par Slyfox (02-05-2021 20:48:36)

Hors ligne

Pied de page des forums