Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-06-2021 10:39:42

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

[Solutionné] Lecteur PDF Evince fonctionne très mal

Bonjour,

indépendamment de mon problème de pages non affichées, je constate, en essayant justement de le cerner en générant des fichiers .odt avec de moins en moins de pages puis export pdf et affichage, que mon lecteur Evince fourni avec la distro devient fou, dans le sens où, avec mon dernier fichier et seulement 3 pages, les 2 premières ne s'affichent toujours pas, ok c'est mon problème de base et on pourrait penser que c'est lié à LO, mais la 3ᵉ, je l'ai à gauche dans le panneau des miniatures et je n'en ai quasiment rien à droite dans la grande zone des pages : juste à peine les derniers 5 mm de l'image et sa légende, mais tout ce qui est au-dessus, soit trois autres images et leurs légendes, rien...

Et ce n'est pas tout : le bandeau supérieur qui contient les boutons, menus et autres bricoles, disparaît ! Il est intégralement vide et les choses qui s'y trouvent ne réapparaîssent qu'en passant la souris dessus, et si la souris s'en va sur les zones d'affichage dessous, hop, il redevient vide !

Et ce n'est pas fini : quand je réussis à le rendre présent, ben... il est inactif : je peux cliquer partout, il ne se passe rien -- sauf sur les 3 boutons classiques à l'extrême droite (réduire plein écran fermer) qui restent opérationnels, tous les autres ne répondent pas, pire, en les cliquant ça me vide le panneau.

Gag : pour vous trouver la version d'Evince, puisque le menu ne fonctionne plus je lance Synaptic, qui vient s'afficher par-dessus le lecteur, je note 3.30.2-3, je ferme Synaptic qui donc découvre le lecteur et là, la page 3 est entière ! Mais ça ne dure pas, hein, faut pas rêver : suffit de balader la souris et paf, ça merdouille et ça s'efface.

Qu'est-ce que je peux faire ?
Merci,

PS : un dernier mot -- pour en avoir le cœur net, si tant est que ce soit possible, j'ai récupéré un fichier de test sur archeonavale.org/pdf/cordeliere/test.pdf (je pense que ce ne sont pas des rigolos), et là le lecteur fonctionne normalement ; alors j'en ai pris un autre, ailleurs, avec une image, et là aussi ça fonctionne. Conclusion, ce sont les fichiers générés par LO (essai ce matin avec une 7.0.0.3 en AppImage) qui le mettent en vrac ?
C'est vraiment l'horreur, l'informatique, et au plus le temps passe et au moins ça s'arrange, on dirait. roll sad

Dernière modification par jpt (06-06-2021 16:15:06)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#2 05-06-2021 11:01:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Debian Alain a écrit :

tu as quoi comme config ?

inxi -Fr

à installer

Déjà présent, tongue
Config, la même qu'il y aura un an dans 10 jours :

System:    Host: debox64 Kernel: 5.7.10 x86_64 bits: 64 Console: tty 0 Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop Mobo: Gigabyte model: B450M S2H v: x.x serial: N/A UEFI [Legacy]: American Megatrends v: F51
           date: 07/29/2020
CPU:       Topology: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP L2 cache: 2048 KiB
           Speed: 1256 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 1258 2: 1281 3: 1257 4: 1257
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel
           Display: tty server: X.org 1.20.4 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa tty: 146x73
           Message: Advanced graphics data unavailable in console for root.
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.7.10
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:ec:db:d5
Drives:    Local Storage: total: 3.86 TiB used: 526.32 GiB (13.3%)
           ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
           ID-2: /dev/sdb vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
           ID-3: /dev/sdc vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
Partition: ID-1: / size: 191.25 GiB used: 38.97 GiB (20.4%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 28.25 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 40.2 C mobo: N/A
           Fan Speeds (RPM): N/A
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb https://deb.debian.org/debian/ buster main contrib non-free
           2: deb-src https://deb.debian.org/debian/ buster main contrib non-free
           3: deb https://deb.debian.org/debian/ buster-updates main contrib non-free
           4: deb-src https://deb.debian.org/debian/ buster-updates main contrib non-free
           5: deb http://security.debian.org/debian-security/ buster/updates main contrib non-free
           6: deb-src http://security.debian.org/debian-security/ buster/updates main contrib non-free
           7: deb https://deb.debian.org/debian/ buster-backports main contrib non-free
           8: deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian/ buster contrib
Info:      Processes: 178 Uptime: 2h 32m Memory: 13.69 GiB used: 1.53 GiB (11.2%) Init: systemd runlevel: 5 Shell: bash
           inxi: 3.0.32


Anecdote : ton inxi a l'air de se prendre les pieds dans le tapis, au niveau des partitions : il manque les infos de sdb et sdc.

Et le fait d'appeler les drives ET les partitions du même nom c'est franchement pas une bonne idée

Dernière modification par jpt (05-06-2021 11:19:34)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#3 05-06-2021 11:38:20

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Bonjour,
Et si tu indiquais précisément le contenu des 3 pages qui semblent poser problème dans la conversion avec libreoffice ?

Hors ligne

#4 05-06-2021 12:32:42

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Bonjour jpt smile

Utilises-tu vraiment LXDE ?  Donne-nous s'il te plaît :

echo $DESKTOP_SESSION




Parce que le projet n'a plus l'air de vraiment tenir la route, regarde le statut des composants logiciels la liste des obsolètes, abandonnés, ceux en suspens...

https://wiki.lxde.org/en/Status_of_LXDE_Components


Wikipédia classe LXDE dans les environnements de bureau au stade arrêté :

https://fr.wikipedia.org/wiki/Environne … AAt%C3%A9s


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

En ligne

#5 05-06-2021 12:37:02

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

chalu a écrit :

Et si tu indiquais précisément le contenu des 3 pages qui semblent poser problème dans la conversion avec libreoffice ?

Les 3 pages sont du A5 vertical :
- la première contient une image de 12 x 9,75 cm (h x l) et 4 lignes de texte : 1ʳᵉ ligne en 26 points, 2ᵉ en 10 points, 3ᵉ et 4ᵉ en 21 points ;
- la deuxième contient deux images de 7,15 x 9,30 cm bien centrées gauche-droite et bien réparties de haut en bas, chacune suivie de sa légende en 10 points ;
- la troisième est un peu plus sophistiquée : un titre en chapeau en 26 points, dessous un tableau de deux colonnes avec à gauche une image 7,89 x 6,60 suivie de sa légende en 10 points et à droite une image carrée de 4,28 cm de côté alignée en bas et suivie de sa légende. Puis il y a un saut de ligne après ce tableau, suivi d'un second tableau sur le même principe sauf que l'image carrée est en haut à gauche et la grande rectangulaire dans la colonne de droite.

Rien de particulier, il m'est arrivé de faire plus compliqué (tableaux dans tableaux par ex.), et le seul problème que j'ai rencontré avec mon vieux LO 3.5, c'est qu'il gère mal l'export pdf des tirets longs 2013 et 2014 (– —), leur bout droit se retrouve dans le caractère qui le suit, malgré l'espace de séparation : une horreur visuelle, roll
D'où mon passage en Windows 7, qui gère bien cet aspect, sans me faire disparaître de contenu de pages. Et j'ai découvert plus tard qu'une machine virtuelle Wheezy 32 bits / Lo 5.4.3.2 fonctionne bien également (sauf que ça rame à mort, mais bon, ça permet d'aller se préparer un kfé, cool)

Et je précise que la première page décrite ici se retrouve dans l'objet fini suivie d'une page à peu près identique, il n'y a que l'image et les textes qui changent mais le principe est identique, sauf qu'elle est bien affichée, tout comme la seconde décrite ici qui a des sœurs ici et là, parfaitement correctes. Ces disparitions sont pour moi un mystère total, mais ça, on devrait le discuter dans l'autre sujet.

Dernière modification par jpt (05-06-2021 12:37:55)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#6 05-06-2021 12:49:28

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

--gilles-- a écrit :

Utilises-tu vraiment LXDE ?

Oui tout à fait, c'est l'environnement que je préfère (je ne supporte pas mousepad et sa manière ridicule de gérer la numérotation des lignes, ainsi que le fait que certains paramètres [numérotation des lignes mais aussi retour autom. à la ligne, type de curseur et son clignotement] sautent sans raison).

--gilles-- a écrit :

Donne-nous s'il te plaît :

echo $DESKTOP_SESSION

C'est vide !
scratchhead.gif

Maintenant, mon environnement vient d'une distro downloadée chez Debian il y a un peu plus d'un an et backportée à l'automne avec l'aide de Debian Alain (merci à toi, camarade cool) pour faire correctement fonctionner mon GPU.

Quant au classement, j'ai regardé ton premier lien, il est question de pcmanfm en version 0.5 et le mien annonce 1.3.1.

Dernière modification par jpt (05-06-2021 12:50:31)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#7 05-06-2021 13:20:00

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Ah oui ! Tu utilises LXDE et backportée ! C'est courageux ! Cela doit te donner beaucoup de plaisir visuel et intellectuel comme contrepartie au fait que cela doit devenir difficile à exploiter. smile


Mais il te faudra régulièrement ré-évaluer les bénéfices et les risque d'un tel choix, moi aussi, je m'étais acharné sur vieil ordi pour le faire fonctionner smile, mais à la fin j'ai été obligé de jeter l'éponge, le temps à y passer était devenu tel que ma bonne humeur et ma santé se dégradaient. sad

Mousepad, mais c'est dérivé de XFCE :

https://community.linuxmint.com/software/view/mousepad

N'envisages-tu donc que les environnements de bureau légers ?

Que penses-tu de LXQT ?

Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

En ligne

#8 05-06-2021 13:38:29

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

--gilles-- a écrit :

Ah oui ! Tu utilises LXDE et backportée ! C'est courageux ! Cela doit te donner beaucoup de plaisir visuel et intellectuel comme contrepartie au fait que cela doit devenir difficile à exploiter. smile

Allons bon ! Mais s'il ne faut pas le faire, pourquoi est-ce que ça peut se downloader et s'installer ?

--gilles-- a écrit :

Mais il te faudra régulièrement ré-évaluer les bénéfices et les risque d'un tel choix, moi aussi, je m'étais acharné sur vieil ordi pour le faire fonctionner smile, mais à la fin j'ai été obligé de jeter l'éponge, le temps à y passer était devenu tel que ma bonne humeur et ma santé se dégradaient. sad

Mais moi, la machine est neuve (enfin presque, elle aura bientôt un an, mais elle ne fait rien à part me causer des soucis…)

--gilles-- a écrit :

Mousepad, mais c'est dérivé de XFCE :

https://community.linuxmint.com/software/view/mousepad

Oui, et donc ? Ça ne l'empêche pas, pour moi, d'être pénible à l'utilisation.

--gilles-- a écrit :

N'envisages-tu donc que les environnements de bureau légers ?

Que penses-tu de LXQT ?

Ben oui, tout ce qui est fioritures et gadgets me lasse vite, au quotidien -- c'est vrai qu'à une époque ça m'a amusé les fenêtres Knoppix qui se ferment en tremblotant puis se dissolvant en fumée ou en petits bouts de papier, mais ça va un moment, et je n'ai pas de temps à perdre à attendre que la fenêtre soit fermée.

Dans un de tes deux liens j'ai vu une liste du bureaux tous plus beaux les uns que les autres mais ce genre de critère est pour moi parfaitement ridicule : c'est celui qui met la plus belle image qui gagne le pompon ? Ri-di-cu-le !
Bref, je vais jeter un œil en machine virtuelle à ta LXQT que j'ai remarquée, et il y aura aussi Deepin, mais déjà des questions surviennent : Deepin, je vais me faire espionner, non ? Et LXQT, ça va être pérenne et fiable sur le long terme ?
Ah, que de soucis… wink


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#9 05-06-2021 23:30:35

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Est-ce que la version qui fonctionne bien sous Windows pour exporter les 3 pages est la même que sur ta Debian ?
Quel est le format des images ?

Hors ligne

#10 06-06-2021 09:59:41

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Bonjour,

chalu a écrit :

Est-ce que la version qui fonctionne bien sous Windows pour exporter les 3 pages est la même que sur ta Debian ?

Dans 7, Lo = 6.3.6.2.

chalu a écrit :

Quel est le format des images ?

Je ne comprends pas la question (c'est du png tout bête généré par The Gimp en partant de photos) et de toute façon, ça n'a plus d'importance, lire la suite :

Ce matin j'ai eu une idée géniale : recopier les .pdf générés dans la nouvelle machine et auxquels il manque l'affichage du contenu de certaines pages, vers la vieille machine et là, surprise !, tout est correct.

Le problème maintenant, c'est que synaptic ne me propose pas d'évolution d'Evince. Quelqu'un connaît un autre et bon lecteur de pdf's ?

EDIT : je viens de tester mupdf, c'est parfait sauf que cet outil ne permet pas d'imprimer, dommage. Il y aurait bien xpdf, mais il faut que je teste sa manière d'imprimer : de mémoire, dans l'ancienne machine il utilise /dev/lpx, je ne sais pas du tout si ça pourrait le faire avec mon driver bidouillé, qui fonctionne très bien avec cups.

Driver bidouillé qui me permet de faire fonctionner une WinPrinter Canon dans le monde du libre plutôt que de la mettre à la benne.

Dernière modification par jpt (06-06-2021 10:28:46)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#11 06-06-2021 11:11:22

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.1
Noyau : 5.10.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Il y a Atril

--
Jc E

Hors ligne

#12 06-06-2021 11:34:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

jce76350 a écrit :

Il y a Atril

que je viens de tester de ce pas, et qui n'affiche pas ce que les autres lecteurs n'affichent pas…

C'est vraiment un truc de guedin, cette histoire.

Et le pire, c'est que cet atril est mal désinstallable : je suis en train de pourrir mon système... :

E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Impossible de verrouiller le répertoire de téléchargement

"mal" parce que ça l'a désinstallé quand même après avoir désinstallé ses dépendances -- bien m'en a pris de faire une copie d'écran de ce qu'il devait installer.
Et il n'y a rien de cassé, ouf !

Une autre idée de lecteur non basé sur poppler ? Car je suppose que cette histoire de non-affichage vient de là, puisque mupdf ne l'utilise pas et affiche correctement.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#13 06-06-2021 12:17:37

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

Hello
je serais toi je réinstallerais une Debian propre
parce que la visiblement ta une belle Frankendebian
ou alors tu jettes ton ordi par la fenêtre, mais c'est pas bon pour la planète lol

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 06-06-2021 12:24:59

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

salut

curieux cette histoire, je dis ça car je numérise des documents anciens de puis longtemps, et je fais des pdf, soit avec des images convertis soit à partir d'odt, mais la plupart du temps avec mon scanner...
j'en suis à peu prés à 4000 pdf, que je lis avec Atrill, mais avant j'utilisais Evince.
Lors de montages à partir d'un traitement de texte, parfois et suivant la taille et le format des images, j'ai eu des surprises, si l'image ne trouve pas sa place dans une page, il la mets dans la page en dessous, ce qui est assez rare, et parfois chiant à rattraper..
convertir ou redimensionner les images, et les remplacer...
mais jamais de la faute du lecteur pdf...
Je me suis aussi retrouvé avec des pages blanches, il y a longtemps, dans ce cas, je les vire avec pdftk....

Hors ligne

#15 06-06-2021 12:39:42

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [Solutionné] Lecteur PDF Evince fonctionne très mal

lagrenouille a écrit :

Je me suis aussi retrouvé avec des pages blanches, il y a longtemps, dans ce cas, je les vire avec pdftk....

Ce ne sont pas des pages blanches en surnombre (qui peuvent venir d'un saut de page malencontreux), ce sont des pages vidées de leur contenu.

lagrenouille a écrit :

si l'image ne trouve pas sa place dans une page, il la met dans la page en dessous, ce qui est assez rare, et parfois chiant à rattraper.

J'ai connu aussi (qui n'a pas connu ça ?), mais maintenant je maîtrise.

Croutons a écrit :

je serais toi je réinstallerais une Debian propre

J'attends la 11.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

Pied de page des forums