Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-06-2021 21:58:05

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

[RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello,
Petit souci avec gnome-maps, quand je lance l’application elle ne s’ouvre plus.
Le lancement dans un terminal ne renvoi aucun message d’erreur.
Par contre j’ai ce message intercepté dans le sylog :

org.gnome.Maps[8362]: JS ERROR: TypeError: source is undefined#
012_createTileSource@resource:///org/gnome/Maps/js/mapSource.js:91:9#
012_createCachedSource@resource:///org/gnome/Maps/js/mapSource.js:106:39#
012createAerialSource@resource:///org/gnome/Maps/js/mapSource.js:138:12#
012setMapType@resource:///org/gnome/Maps/js/mapView.js:409:54#
012_init@resource:///org/gnome/Maps/js/mapView.js:155:14#
012_init@resource:///org/gnome/Maps/js/mainWindow.js:99:25#
012_createWindow@resource:///org/gnome/Maps/js/application.js:281:28#
012vfunc_activate@resource:///org/gnome/Maps/js/application.js:300:14#
012main@resource:///org/gnome/Maps/js/main.js:57:24#
012run@resource:///org/gnome/gjs/modules/script/package.js:222:19#
012start@resource:///org/gnome/gjs/modules/script/package.js:206:8#
012@/usr/share/gnome-maps/org.gnome.Maps:2:17



J’ai du mal à comprendre le gnomien. Help !

Note j’ai réinstallé le paquet sans succès

Dernière modification par Philou92 (10-10-2021 21:28:34)


Tousse antique Ovide !

Hors ligne

#2 16-06-2021 21:20:21

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonjour ou bonsoir smile

Les applications Gnome sont très sensibles à la connexion réseau, est-il 100 % correct ?

gnome-control-center -v network




Chez moi le syslog :


less /var/log/syslog | grep Map

Jun 16 20:29:38 machine dbus-daemon[2140]: [session uid=1001 pid=2140] Activating service name='org.gnome.Maps' requested by ':1.20' (uid=1001 pid=2218 comm="/usr/bin/gnome-shell ")
Jun 16 20:29:43 machine dbus-daemon[2140]: [session uid=1001 pid=2140] Successfully activated service 'org.gnome.Maps'
Jun 16 20:30:11 machine dbus-daemon[1169]: [system] Activating via systemd: service name='org.freedesktop.GeoClue2' unit='geoclue.service' requested by ':1.263' (uid=1001 pid=20030 comm="/usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps ")



Quel est l'état de geoclue.service ?

systemctl status geoclue.service



Que donne :

/usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps



D'autres logiciels lancés par /usr/bin/gjs-console se lancent-ils correctement :

/usr/bin/gjs-console /usr/bin/gnome-documents


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#3 16-06-2021 22:32:53

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello --gilles-- et bonsoir et merci smile

Voici les retours :

gnome-control-center -v network


bash: gnome-control-center : commande introuvable


systemctl status geoclue.service


● geoclue.service - Location Lookup Service
     Loaded: loaded (/lib/systemd/system/geoclue.service; static)
     Active: inactive (dead)

juin 16 21:08:24 pc-198 systemd[1]: Starting Location Lookup Service...
juin 16 21:08:24 pc-198 systemd[1]: Started Location Lookup Service.
juin 16 21:12:50 pc-198 geoclue[5126]: Service not used for 60 seconds. Shutting down..
juin 16 21:12:50 pc-198 systemd[1]: geoclue.service: Succeeded.
 



/usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps



(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.071: Theme parsing error: gtk.css:7852:22: Expected '(' after 'url'

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.071: Theme parsing error: gtk.css:7852:147: Invalid character in string. Must be escaped.

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.074: Theme parsing error: gtk.css:11634:3: '/*' in comment block

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.074: Theme parsing error: gtk.css:11740:2: '/*' in comment block

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.074: Theme parsing error: gtk.css:11785:26: 'text-shadow' is not a valid color name

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:21.074: Theme parsing error: gtk.css:12045:14: 'ffffff' is not a valid color name

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.063: Theme parsing error: gtk.css:7852:22: Expected '(' after 'url'

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.063: Theme parsing error: gtk.css:7852:147: Invalid character in string. Must be escaped.

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.068: Theme parsing error: gtk.css:11634:3: '/*' in comment block

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.068: Theme parsing error: gtk.css:11740:2: '/*' in comment block

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.068: Theme parsing error: gtk.css:11785:26: 'text-shadow' is not a valid color name

(org.gnome.Maps:8924): Gtk-WARNING **: 22:21:22.069: Theme parsing error: gtk.css:12045:14: 'ffffff' is not a valid color name

(org.gnome.Maps:8924): Gjs-CRITICAL **: 22:21:22.238: JS ERROR: TypeError: source is undefined
_createTileSource@resource:///org/gnome/Maps/js/mapSource.js:91:9
_createCachedSource@resource:///org/gnome/Maps/js/mapSource.js:106:39
createAerialSource@resource:///org/gnome/Maps/js/mapSource.js:138:12
setMapType@resource:///org/gnome/Maps/js/mapView.js:409:54
_init@resource:///org/gnome/Maps/js/mapView.js:155:14
_init@resource:///org/gnome/Maps/js/mainWindow.js:99:25
_createWindow@resource:///org/gnome/Maps/js/application.js:281:28
vfunc_activate@resource:///org/gnome/Maps/js/application.js:300:14
vfunc_command_line@resource:///org/gnome/Maps/js/application.js:374:18
main@resource:///org/gnome/Maps/js/main.js:57:24
run@resource:///org/gnome/gjs/modules/script/package.js:222:19
start@resource:///org/gnome/gjs/modules/script/package.js:206:8
@/usr/share/gnome-maps/org.gnome.Maps:2:17
 


/usr/bin/gjs-console /usr/bin/gnome-documents


je n’ai pas installé gnome-documents, est-ce que gnome-calculator, gnome-calendar, gnome-contacts feraient l’affaire ?


Tousse antique Ovide !

Hors ligne

#4 17-06-2021 06:59:58

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonjour Philou92 smile
Pour les pistes du réseau et de geoclue, nous pouvons laisser tomber, ce n'est pas cela.




Philou92 a écrit :


je n’ai pas installé gnome-documents, est-ce que gnome-calculator, gnome-calendar, gnome-contacts feraient l’affaire ?


C'était pour évaluer si cela ne vient pas de gjs, mais ils ne font pas l'affaire puisque je ne les trouve pas avec :


less /var/log/syslog | grep gjs


Il faudrait l'installer si on veut creuser cette piste.




Est-ce que tu as bien gtk-2.0, gtk-3.0 et gtk-4.0 dans ~/.config ? Et webkitgtk-4.0 dans ~/.cache ?
Comme tu ne sembles pas avoir Gnome comme environnement de bureau, je me pose la question de la compatibilité du tien avec l'arrivée progressive de GTK4.




Ou alors un thème GTK foireux ? Est-ce que tu as des thèmes installés hors paquets debian ?

Dernière modification par --gilles-- (17-06-2021 07:46:28)


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#5 17-06-2021 14:59:53

robert2a
Membre
Inscription : 15-11-2014

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonjour
sous Mate je n'ai que gtk2 et gtk3 dans le ".config"  , pas de gtk4  (sous sid)
mais pas l'application gnome-maps installé
ps: a priori beaucoup de dépendances a installer (68 nouveaux paquets pour gnome-maps)
et pas de gtk4

Hors ligne

#6 17-06-2021 21:44:29

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

J’ai essayé de lancer gnome-maps sur une autre session utilisateur. Il fonctionne dans ce contexte.
Cette session dispose du thème par défaut Xfce.
Sur ma session j’ai un thème différent  dans les menu apparence et gestionnaire de fenêtre : McOS-MJV-Dark-XFCE-Edition-2.3
La piste du gtk foireux est peut-être la bonne. Maintenant j’ai souvenir que gnome-maps fonctionnait avec ce thème.

Tousse antique Ovide !

Hors ligne

#7 18-06-2021 13:13:33

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Philou92 a écrit :

Maintenant j’ai souvenir que gnome-maps fonctionnait avec ce thème.



gnome-maps fonctionnait avec ce thème, oui, mais comme tu utilises testing, les paquets, fichiers de configuration, etc évoluent tandis que le thème McOS-MJV-Dark-XFCE-Edition-2.3 n'a pas bougé depuis 3 ans.


Tu écris qu'avec une autre session utilisateur sans le thème McOS-MJV-Dark-XFCE-Edition-2.3, gnome-maps fonctionne correctement. Pour vérifier si ce thème est bien en cause dans la panne, je pense que tu devrais l'installer dans cette session et tu regardes ce qui se passe pour gnome-maps.


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#8 19-06-2021 21:49:21

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello Gilles,
Mettre le souk dans une autre session me gêne un peu.

J’ai essayé sans succès de mettre le thème par défaut de xfce à la place du McOS-MJV-Dark-XFCE-Edition-2.3.

Dans la session ou Cartes fonctionne, j’ai mis ci-dessous le syslog au démarrage de l’application.

Jun 19 21:28:51 pc-198 dbus-daemon[5846]: [session uid=1003 pid=5846] Activating service name='org.gnome.Maps' requested by ':1.75' (uid=1003 pid=6298 comm="gapplication launch org.gnome.Maps ")
Jun 19 21:28:51 pc-198 dbus-daemon[5846]: [session uid=1003 pid=5846] Successfully activated service 'org.gnome.Maps'
Jun 19 21:28:52 pc-198 dbus-daemon[658]: [system] Activating via systemd: service name='org.freedesktop.GeoClue2' unit='geoclue.service' requested by ':1.157' (uid=1003 pid=6302 comm="/usr/bin/gjs /usr/share/gnome-maps/org.gnome.Maps ")
Jun 19 21:28:52 pc-198 systemd[1]: Starting Location Lookup Service...
Jun 19 21:28:52 pc-198 dbus-daemon[658]: [system] Successfully activated service 'org.freedesktop.GeoClue2'
Jun 19 21:28:52 pc-198 systemd[1]: Started Location Lookup Service.
Jun 19 21:28:54 pc-198 systemd[1]: blueman-mechanism.service: Succeeded.
Jun 19 21:28:55 pc-198 tracker-store[5997]: OK
Jun 19 21:28:55 pc-198 systemd[5819]: tracker-store.service: Succeeded.



J’ai relancé gnome-maps dans ma session via un terminal et contrairement à mon post du 15 maintenant il génère un message d’erreur :

gnome-maps


(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.138: Theme parsing error: gtk.css:7852:22: Expected '(' after 'url'

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.138: Theme parsing error: gtk.css:7852:147: Invalid character in string. Must be escaped.

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.141: Theme parsing error: gtk.css:11634:3: '/*' in comment block

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.141: Theme parsing error: gtk.css:11740:2: '/*' in comment block

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.141: Theme parsing error: gtk.css:11785:26: 'text-shadow' is not a valid color name

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:46.141: Theme parsing error: gtk.css:12045:14: 'ffffff' is not a valid color name

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.104: Theme parsing error: gtk.css:7852:22: Expected '(' after 'url'

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.104: Theme parsing error: gtk.css:7852:147: Invalid character in string. Must be escaped.

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.109: Theme parsing error: gtk.css:11634:3: '/*' in comment block

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.109: Theme parsing error: gtk.css:11740:2: '/*' in comment block

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.109: Theme parsing error: gtk.css:11785:26: 'text-shadow' is not a valid color name

(org.gnome.Maps:7382): Gtk-WARNING **: 21:42:47.110: Theme parsing error: gtk.css:12045:14: 'ffffff' is not a valid color name

(org.gnome.Maps:7382): Gjs-CRITICAL **: 21:42:47.275: JS ERROR: TypeError: source is undefined
_createTileSource@resource:///org/gnome/Maps/js/mapSource.js:91:9
_createCachedSource@resource:///org/gnome/Maps/js/mapSource.js:106:39
createAerialSource@resource:///org/gnome/Maps/js/mapSource.js:138:12
setMapType@resource:///org/gnome/Maps/js/mapView.js:409:54
_init@resource:///org/gnome/Maps/js/mapView.js:155:14
_init@resource:///org/gnome/Maps/js/mainWindow.js:99:25
_createWindow@resource:///org/gnome/Maps/js/application.js:281:28
vfunc_activate@resource:///org/gnome/Maps/js/application.js:300:14
vfunc_command_line@resource:///org/gnome/Maps/js/application.js:374:18
main@resource:///org/gnome/Maps/js/main.js:57:24
run@resource:///org/gnome/gjs/modules/script/package.js:222:19
start@resource:///org/gnome/gjs/modules/script/package.js:206:8
@/usr/bin/gnome-maps:2:17

 



Il semble qu’il y a un problème de syntaxe dans un fichier css du thème McOS-MJV-Dark-XFCE-Edition-2.3.

Je vais chercher de ce côté…


Tousse antique Ovide !

Hors ligne

#9 19-06-2021 22:35:54

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

J’ai corrigé toutes les erreurs relevées dans le fichier .themes/McOS-MJV-Dark-XFCE-Edition-2.3/gtk-3.0/gtk.css

Au passage (rien à voir avec le problème actuel) cela a corrigé un bug de redimensionnement des fenêtres avec la souris. Le dimensionnement fonctionne par le bas de la fenêtre maintenant (uniquement en haut précédemment).

Il reste toutefois l’erreur critique Gjs :

(org.gnome.Maps:9961): Gjs-CRITICAL **: 22:31:34.660: JS ERROR: TypeError: source is undefined
_createTileSource@resource:///org/gnome/Maps/js/mapSource.js:91:9
_createCachedSource@resource:///org/gnome/Maps/js/mapSource.js:106:39
createAerialSource@resource:///org/gnome/Maps/js/mapSource.js:138:12
setMapType@resource:///org/gnome/Maps/js/mapView.js:409:54
_init@resource:///org/gnome/Maps/js/mapView.js:155:14
_init@resource:///org/gnome/Maps/js/mainWindow.js:99:25
_createWindow@resource:///org/gnome/Maps/js/application.js:281:28
vfunc_activate@resource:///org/gnome/Maps/js/application.js:300:14
vfunc_command_line@resource:///org/gnome/Maps/js/application.js:374:18
main@resource:///org/gnome/Maps/js/main.js:57:24
run@resource:///org/gnome/gjs/modules/script/package.js:222:19
start@resource:///org/gnome/gjs/modules/script/package.js:206:8
@/usr/bin/gnome-maps:2:17

Dernière modification par Philou92 (19-06-2021 22:43:01)


Tousse antique Ovide !

Hors ligne

#10 20-06-2021 13:21:53

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonjour smile

Le libellé de l'erreur que tu nous soumets mise dans un moteur de recherche ne donne pas grand chose à première vue :

https://duckduckgo.com/?t=ffab&q=(org.g … ned&ia=web


Peut-être un problème de compatibilité de version entre gjs et gnome-maps dans ta machine, à vérifier puisque si nous lisons :

aptitude show gjs

Paquet : gjs                                            
Version : 1.66.2-1
État: installé
Automatiquement installé: oui
Priorité : optionnel
Section : interpreters
Responsable : Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 91,1 k
Dépend: libc6 (>= 2.4), libgjs0g (>= 1.65.90), libglib2.0-0 (>= 2.58.0), gir1.2-gtk-3.0
Casse: gnome-characters (< 3.25.92), gnome-documents (< 3.30.0), gnome-maps (< 3.26.1), gnome-shell (< 3.29.90),
       gnome-sound-recorder (< 3.28.1-3~), gnome-weather (< 3.25.91), ostree-tests (< 2017.11-1~), polari (< 3.29.91)
Description : interfaces JavaScript basées sur Mozilla pour la plate-forme GNOME
 Ces interfaces permettent aux applications d'accéder à toutes les bibliothèques de la plate-forme GNOME par le langage
 JavaScript. Elles sont basées sur le moteur JavaScript de Mozilla et sur le cadre applicatif d'introspection GObject.
 
 Ce paquet fournit l'application console interactive.
Site : https://gitlab.gnome.org/GNOME/gjs/wikis
Étiquettes: devel::interpreter, devel::lang:ecmascript, implemented-in::c, role::program

 



gis Version : 1.66.2-1 casse gnome-maps (< 3.26.1)

Chez moi, j'en suis à gis Version : 1.66.2-1 et à gnome-maps Version : 3.38.2-1

En fait, cela m'étonnerait puisque tu n'es pas un bleu, ta machine doit être à jour ! big_smile


cat /var/log/syslog | grep "JS ERROR: TypeError: source is undefined"



cat /var/log/syslog.1 | grep "JS ERROR: TypeError: source is undefined"



zcat /var/log/syslog.2.gz | grep "JS ERROR: TypeError: source is undefined"




zcat /var/log/syslog.3.gz | grep "JS ERROR: TypeError: source is undefined"



zcat /var/log/syslog.4.gz | grep "JS ERROR: TypeError: source is undefined"


ne donne rien chez moi, je n'ai pas eu cette erreur du moins récemment, j'ai supprimé les syslog antérieurs.

Tu devrais lire à fond ce rapport de bug :

https://bugs.launchpad.net/ubuntu/+sour … ug/1930699


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#11 22-06-2021 21:37:31

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello Gilles, merci pour ton aide. smile

Oui mon PCest à jour. Pas de souci de ce côté. De plus cela fonctionne sur une autre session, donc ce n’est pas un problème de logiciel.
J’ai comparé les fichiers de configuration de xfce entre les deux sessions et n’ai trouvé aucune différence.
J’ai installé gnome-books qui utilise aussi gjs. Cette application fonctionne correctement. J’oserai dire que ce n’est pas un problème venant de gjs.
J’ai fais une recherche comme toi sur les log du syslog. J’ai constaté que le défaut est apparu entre le 23 mai et le 14 juin. Mon thème xfce a été installé bien avant le 23 mai. Je doute que le problème vienne de là.
Reste un possible fichier de configuration applicatif de gnome pourri. Problème je n’ai trouvé aucun fichier de configuration relatif à gnome-maps.
Je sèche et m’épuise à chercher… gloomy_by_cookiemagik-d5s3r8n.gif

Tousse antique Ovide !

Hors ligne

#12 05-10-2021 21:25:24

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

https://bugs.debian.org/cgi-bin/bugrepo … bug=990618

Debian Bug report logs - #990618
gnome-maps: fail to start (JS ERROR: TypeError: source is undefined)

Du nouveau. C’est bien un bug. Reste à attendre le correctif…

Tousse antique Ovide !

Hors ligne

#13 08-10-2021 17:27:08

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Salut Philou et les autres,
demain mise à niveau de Bullseye 11 à 11.1, et dedans y'a un correctif pour gnome maps

<correction gnome-maps "New upstream stable release; fix a crash when starting up with last-used map type being aerial, and no aerial tile definition ....



Je sais pas si ça résoudra ton bug, je comprend pas tout des explications.... à part qu'il y a une nouvelle version...
Même en français, ça reste assez "aérien" pour moi...

Nouvelle version amont stable ; correction d'un plantage lors du démarrage avec aérien comme dernier type de carte utilisé et qu'une définition de tuile non aérienne est trouvée ; parfois pas d'écriture de position de dernière vue cassée lors de la sortie ; correction de blocage lors de la sélection de marqueurs de route"



A voir demain, si ça résout ton problème

Hors ligne

#14 10-10-2021 21:27:49

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello ubub,

J’ai mis à jour Bulleseye hier et réinstallé gnome-maps, plus de problème.
Le correctif est efficace.

Pour la traduction de aerial problablement faut-il comprendre aérographiques ou un truc du genre pour parler des pavés de carte affichés. Comme traduction du journal des modifications du paquet je verrais plutôt :


Ne cherchez pas à définir les tuiles « aérographiques » si elles ne sont pas disponibles. Cela permet d'éviter un crash
      si les cartes « aérographiques » ont été enregistrées comme le dernier type de carte utilisé dans GSettings,
      et qu'au prochain démarrage, le service a abandonné le support. (Clôture : #990618).



En clair je comprends que si des tuiles ont préalablement été enregistrées ( en cache ? ) et que le support de ces tuiles n’est plus fourni alors c’est… la tuile (gnome-maps plante lamentablement).
Du coup je comprends mieux maintenant pourquoi ce problème n’affectait que ma session.

Je passe le sujet en résolu.


Tousse antique Ovide !

Hors ligne

#15 18-10-2021 02:33:52

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonsoir, philou, content que ton probleme se soit résolu, et merci de tes explications, j"ai à peu près saisi je crois..

Comme traduction du journal des modifications du paquet je verrais plutôt :


Ca, ça serait mieux que tu l"envoie direct à l'équipe de traduction debian-l10n-french@lists.debian.org
pour que la personne qui a traduit le document, et qui du coup est responsable de sa traduction et de sa publication puisse en prendre acte, et voir si ta version lui plait plus que la sienne ou pas, si t'as trouvé de meilleurs mots , etc...
Après vas-y, si tu as envie de proposer des trucs, les gens qui traduisent sont avides de relecteurs, paske des fois, c'est pas évident de trouver le mot juste... Moi, aérographe, je trouve ça bizar aussi, ça me fait plus penser à bombe de peinture et graffiti, mais c'est vrai que je trouve mieux que aérien, où là, pffff.....

Dernière modification par ubub (18-10-2021 03:04:58)

Hors ligne

#16 18-10-2021 11:46:16

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-9-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Bonjour Philou92 et ubub smile

J'aurais tendance à penser que "aerial" correspondrait à photographie aérienne ou fichier tiré de photographies aériennes. Voir la page de Géoportail consacrée aux cartes tirées de photographies aériennes :

https://www.geoportail.gouv.fr/donnees/ … -aeriennes

D'autre part, si l'on effectue Contrôle - O dans gnome-maps, il est possible d'ouvrir ce qui est appelé « fichiers de couche » avec le choix :

⏺ GeoJSON : https://fr.wikipedia.org/wiki/GeoJSON
⏺ KML : https://fr.wikipedia.org/wiki/Keyhole_Markup_Language
⏺ GPX : https://fr.wikipedia.org/wiki/GPX_(format_de_fichier)


zcat /usr/share/doc/gnome-maps/NEWS.gz

3.38.5 - Jun 4, 2021
=========================

Changes since 3.38.4
 - Fix a crash when starting up with last-used map type being aerial, and
   no aerial tile definition is found

All contributors to this release
Marcus Lundblad <ml@update.uu.se>




Don't try to set aerial tiles if not available. This avoids a crash
       if aerial maps were saved as the last-used map type in GSettings,
       and at next startup the service has dropped support. (Closes: #990618)



J'aurais donc tendance à traduire comme ceci :

Pour éviter un plantage, n'essayez plus d'ouvrir gnome-maps avec un fichier de description tiré de photographies aériennes puisque la prise en charge de ce type de fichier a été abandonnée.




Est-ce que réellement un type de fichier de description tiré de photographies aérienne était disponible auparavant avec gnome-maps ?
En fait, on en sait pas assez pour bien traduire à notre niveau. sad


Nos vies commencent à prendre fin le jour où nous devenons silencieux à propos des choses qui comptent. Martin Luther King

Hors ligne

#17 18-10-2021 21:51:12

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Hello gilles et ubub, smile
Je pense gilles que tu as la meilleure traduction. Il faut en effet comprendre aerial comme photographie aérienne.
Celles-ci étaient bien disponibles avant la mise à jour. Leur disparition n’est pas gênante tant le rendu était de piètre qualité par rapport à celui du géoportail.
@ubub, j’approuve ton idée de communiquer auprès de l’équipe de traduction. Aurais-tu le lien qui mène à la traduction française que tu as trouvée afin que je puisse y faire référence ?

Tousse antique Ovide !

Hors ligne

#18 18-10-2021 22:17:51

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [RÉSOLU] gnome-maps alias Cartes ne s’ouvre plus

Salut Philou et autres,
  Le lien de la traduction, je l'ai pas vraiment...
Mais l'annonce c'est là :
https://www.debian.org/News/2021/20211009
sinon là:
https://lists.debian.org/debian-l10n-fr … 00217.html
...(LCFC veut dire Last Chance For Comments je crois)
mais tu peux envoyer un message sur la liste, la personne qui a en charge de traduire reconnaitra direct ...
Ca aidera, car comme dit gilles, (en plus si t'es pas utilisateur du logiciel) y'a des mots ou tournure de phrases qui sont pas faciles à traduire quand tu sais pas vraiment de quoi on parle ...

Hors ligne

Pied de page des forums