Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-07-2021 07:46:08

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

plus d'accès à windows en dual-boot après une installation de debian

bonjour,
après avoir réinstallé une debian 10 sur un ordi uefi, qui tournait en dual boot avec un windows 10, je n'ai plus accès à windows 10.
j'ai mis sur ce fichier l'image du disque dur donnée par gparted.
on voit bien en sda4 la partition qui contient windows.
dans le grub, pas de ligne windows, même après un update-grub.
si j'essaie d'accéder à win via supergrub, cela ne fonctionne pas.
boot-repair ne fonctionne pas non plus. il me demande de créer une partition non formatée avec un flag boot-flag ou quelque chose comme cela. je l'ai fait, mais boot repair me donne toujours ce message d'erreur en disant il semble que votre disque soit gpt.
j'ai activé puis désactive secureboot dans le bios, mais cela ne change rien.
j'ai essayé de réparer le démarrage via l'outil de windows 10, à partir d'une clé usb, mais le dépannage windows ne fonctionne pas.
pour se résumer, actuellement, j'ai bien accès à la partition debian, qui apparaît dans le grub, mais aucun accès à la partition windows.
il faut noter qu'avant cette réinstallation de debian, l'accès au dual boot fonctionnait bien.
une idée ?

Dernière modification par jeanmarc1 (16-07-2021 07:47:27)


"Being is not doing"

Hors ligne

#2 16-07-2021 10:29:41

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

Debian démarre bien en mode EFI ? A priori oui puisque la partition système EFI est montée sur /boot/efi, mais vérifie quand même la présence de /sys/firmware/efi. Sinon os-prober ne détectera pas un Windows installé en mode EFI.

Tu peux installer le paquet boot-info-script, exécuter la commande bootinfoscript en root et poster le rapport.

En UEFI, os-prober détecte Windows par la présence de son chargeur d'amorçage dans la partition système EFI. Il devrait être visible dans /boot/efi/EFI/Microsoft/Boot, avec notamment les fichiers bootmgfw.efi et BCD (de mémoire).

Il vaut mieux montrer que raconter.

Hors ligne

#3 16-07-2021 10:58:40

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

merci pour ton aide. je m'en occupe et transmet les infos. à bientôt.

"Being is not doing"

Hors ligne

#4 16-07-2021 18:57:19

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

voilà, je viens seulement de pouvoir accéder à l'ordi en question.

oui, apparemment la partition est montée en efi :

$ [ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"
Session EFI
 



j'ai mis dans ce lien le rapport boot-info-script, car il est assez volumineux.

merci pour ton aide.


"Being is not doing"

Hors ligne

#5 16-07-2021 19:47:49

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

j'ai fait quelques essais avec rescatux, que je ne connaissais pas. intéressant logiciel. mais cela n'a rien donné...

Dernière modification par jeanmarc1 (16-07-2021 19:48:27)


"Being is not doing"

Hors ligne

#6 17-07-2021 10:06:25

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

Merci pour le rapport. L'inconvénient avec les "rescue-machin", c'est qu'ils brouillent les pistes en laissant des scories et qu'il est ensuite difficile de distinguer ce qui relève de l'état initial de ce qu'ils ont modifié, et parfois empirent la situation. Ici par exemple, il y a des éléments contradictoires et je ne serais pas surpris que tes tentatives n'y soient pas étrangères. Avant de toucher quoi que ce soit, on observe et on fait le point.

Eléments liés à l'amorçage EFI :
- la table de partition est au format GPT, ce qui est cohérent avec une installation de Windows pour l'amorçage EFI
- la partition EFI contient GRUB pour Debian mais ne contient pas le chargeur d'amorçage de Windows, ou alors bootinfoscript ne l'a pas trouvé ; les outils de "reparation" l'ont-il supprimé, ou as-tu reformaté la partition EFI lors de la réinstallation de Debian ?

Eléments liés à l'amorçage BIOS/legacy :
- le MBR du disque contient une boot image de GRUB pour l'amorçage BIOS/legacy qui pointe vers la zone non allouée de 30 Go entre sda5 et sda8 ; peut-être un reste d'une ancienne installation ?
- la partition sda4 contient /bootmgr qui est le chargeur d'amorçage de Windows pour l'amorçage BIOS/legacy ; ajouté par un outil de "réparation" ?

Actions :
Vérifier manuellement l'absence ou la présence du chargeur Window EFI dans /boot/efi/efi/Microsoft
Vérifier la présence d'une entrée pour Windows dans les variables d'amorçage EFI.
Vérifier la date du fichier bootmgr

find /boot/efi

efibootmgr -v

mount -r /dev/sda4 /mnt
ls -lh /mnt/
umount /mnt


Il vaut mieux montrer que raconter.

Hors ligne

#7 17-07-2021 14:53:37

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

merci beaucoup pour ton aide. voici déjà la réponse aux commandes demandées :

1/ find /boot/efi

sudo find /boot/efi
/boot/efi
/boot/efi/EFI
/boot/efi/EFI/Debian
/boot/efi/EFI/Debian/shimx64.efi
/boot/efi/EFI/Debian/grubx64.efi
/boot/efi/EFI/Debian/mmx64.efi
/boot/efi/EFI/Debian/fbx64.efi
/boot/efi/EFI/Debian/BOOTX64.CSV
/boot/efi/EFI/Debian/grub.cfg
/boot/efi/EFI/boot
/boot/efi/EFI/Microsoft
/boot/efi/EFI/Microsoft/Boot
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/shimx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/grubx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/mmx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/fbx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/BOOTX64.CSV
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/Debian/grub.cfg
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-26-49/boot
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/shimx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/grubx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/mmx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/fbx64.efi
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/BOOTX64.CSV
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Debian/grub.cfg
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/boot
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Microsoft
/boot/efi/EFI_PRE_RESCATUX_2021-07-16-17-30-29/Microsoft/Boot
 



2/ efibootmgr -v

$ sudo efibootmgr -v
BootCurrent: 0000
Timeout: 6 seconds
BootOrder: 0000,000C,000D,0001,0002
Boot0000* Windows Boot Manager  HD(2,GPT,8159eb1f-d7ce-4615-b905-f4ff15ce004e,0xe1800,0x31800)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* debian  VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0002* ubuntu  VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot000C* UEFI : LAN : IP4 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(b8aeed781e31,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot000D* UEFI : LAN : IP6 Realtek PCIe GBE Family Controller PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(b8aeed781e31,0)/IPv6([::]:<->[::]:,0,0)..BO
 



3/ mount -r /dev/sda4 /mnt

$ mount -r /dev/sda4 /mnt
 



4/ ls -lh /mnt/


$ ls -lh /mnt/
total 5.1G
drwxrwxrwx 1 root root    0 May 19  2020 '$GetCurrent'
drwxrwxrwx 1 root root    0 Nov 16  2019 '$Recycle.Bin'
drwxrwxrwx 1 root root 4.0K Feb 28  2018 '$SysReset'
drwxrwxrwx 1 root root    0 May 28  2020 '$WINDOWS.~BT'
drwxrwxrwx 1 root root 4.0K Jun  2  2020  87e473cc10c0efa88897d256ea74ea65
drwxrwxrwx 1 root root 4.0K Jan 23 07:03  8c355da4cd1f9f944c0c004087
-rwxrwxrwx 1 root root  24K Jun 16  2018  bdlog.txt
drwxrwxrwx 1 root root    0 Sep 21  2018  BOOT
-rwxrwxrwx 1 root root 387K Jul 10  2015  bootmgr
-rwxrwxrwx 1 root root   72 Feb 28  2018  bootTel.dat
drwxrwxrwx 1 root root    0 Jul 19  2020  Config.Msi
lrwxrwxrwx 2 root root   10 Feb 21  2018 'Documents and Settings' -> /mnt/Users
drwxrwxrwx 1 root root    0 Oct 15  2018  ESD
-rwxrwxrwx 2 root root 3.8K Apr 11  2008  eula.1028.txt
-rwxrwxrwx 2 root root  16K Apr 11  2008  eula.1031.txt
-rwxrwxrwx 2 root root 9.9K Apr 11  2008  eula.1033.txt
-rwxrwxrwx 2 root root  12K Apr 11  2008  eula.1036.txt
-rwxrwxrwx 2 root root  14K Apr 11  2008  eula.1040.txt
-rwxrwxrwx 2 root root 5.8K Apr 11  2008  eula.1041.txt
-rwxrwxrwx 2 root root 5.9K Apr 11  2008  eula.1042.txt
-rwxrwxrwx 2 root root 9.9K Apr 11  2008  eula.1049.txt
-rwxrwxrwx 2 root root 3.8K Apr 11  2008  eula.2052.txt
-rwxrwxrwx 2 root root  13K Apr 11  2008  eula.3082.txt
-rwxrwxrwx 1 root root 1.1K Apr 11  2008  globdata.ini
-rwxrwxrwx 1 root root 1.6G Jan 23 06:51  hiberfil.sys
-rwxrwxrwx 1 root root 550K Apr 11  2008  install.exe
-rwxrwxrwx 1 root root  843 Apr 11  2008  install.ini
-rwxrwxrwx 2 root root  75K Apr 11  2008  install.res.1028.dll
-rwxrwxrwx 2 root root  95K Apr 11  2008  install.res.1031.dll
-rwxrwxrwx 2 root root  90K Apr 11  2008  install.res.1033.dll
-rwxrwxrwx 2 root root  96K Apr 11  2008  install.res.1036.dll
-rwxrwxrwx 2 root root  94K Apr 11  2008  install.res.1040.dll
-rwxrwxrwx 2 root root  80K Apr 11  2008  install.res.1041.dll
-rwxrwxrwx 2 root root  79K Apr 11  2008  install.res.1042.dll
-rwxrwxrwx 2 root root  92K Apr 11  2008  install.res.1049.dll
-rwxrwxrwx 2 root root  75K Apr 11  2008  install.res.2052.dll
-rwxrwxrwx 2 root root  95K Apr 11  2008  install.res.3082.dll
drwxrwxrwx 1 root root    0 Feb 21  2018  Intel
drwxrwxrwx 1 root root    0 Oct  8  2017  MSOCache
-rwxrwxrwx 1 root root 3.5G Jan 23 06:51  pagefile.sys
drwxrwxrwx 1 root root    0 Apr 12  2018  PerfLogs
drwxrwxrwx 1 root root  24K Jul 19  2020  ProgramData
drwxrwxrwx 1 root root  12K Jul 19  2020 'Program Files'
drwxrwxrwx 1 root root 8.0K Jul 18  2020 'Program Files (x86)'
drwxrwxrwx 1 root root    0 Nov 19  2019  Recovery
-rwxrwxrwx 1 root root    0 Apr 27  2018  Recovery.txt
drwxrwxrwx 1 root root    0 Mar  4  2018 'Sauvegarde Personnelle'
-rwxrwxrwx 1 root root  16M Jan 23 06:51  swapfile.sys
drwxrwxrwx 1 root root 4.0K Jul 18  2020 'System Volume Information'
drwxrwxrwx 1 root root 8.0K Feb 27  2018  totalcmd
drwxrwxrwx 1 root root 4.0K Nov 16  2019  Users
-rwxrwxrwx 1 root root 3.7M Apr 11  2008  VC_RED.cab
-rwxrwxrwx 1 root root 5.6K Apr 11  2008  vcredist.bmp
-rwxrwxrwx 1 root root 228K Apr 11  2008  VC_RED.MSI
drwxrwxrwx 1 root root  28K Jan 23 07:01  Windows
drwxrwxrwx 1 root root 8.0K Jul 18  2020  Windows10Upgrade
drwxrwxrwx 1 root root 4.0K Jun 13  2018  Windows.old
 



4/ umount /mnt

$ umount /mnt
 

Dernière modification par jeanmarc1 (17-07-2021 14:58:58)


"Being is not doing"

Hors ligne

#8 17-07-2021 15:05:18

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur a écrit :

Merci pour le rapport. L'inconvénient avec les "rescue-machin", c'est qu'ils brouillent les pistes en laissant des scories et qu'il est ensuite difficile de distinguer ce qui relève de l'état initial de ce qu'ils ont modifié, et parfois empirent la situation. Ici par exemple, il y a des éléments contradictoires et je ne serais pas surpris que tes tentatives n'y soient pas étrangères. Avant de toucher quoi que ce soit, on observe et on fait le point.



ok, merci du conseil. j'ai préparé le fichier boot-info-script avant de tester rescatux. bon...

raleur a écrit :


Eléments liés à l'amorçage EFI :
- la table de partition est au format GPT, ce qui est cohérent avec une installation de Windows pour l'amorçage EFI
- la partition EFI contient GRUB pour Debian mais ne contient pas le chargeur d'amorçage de Windows, ou alors bootinfoscript ne l'a pas trouvé ; les outils de "reparation" l'ont-il supprimé, ou as-tu reformaté la partition EFI lors de la réinstallation de Debian ?



possible, de mémoire, oui, que j'ai du reformater la partition EFI quand j'ai réinstallé la debian.

raleur a écrit :


Eléments liés à l'amorçage BIOS/legacy :
- le MBR du disque contient une boot image de GRUB pour l'amorçage BIOS/legacy qui pointe vers la zone non allouée de 30 Go entre sda5 et sda8 ; peut-être un reste d'une ancienne installation ?



probable que j'ai supprimé "à la hussarde" une partition contenant une distrib ubuntu, en la détruisant depuis la debian via gparted, et en faisant simplement un update-grub

raleur a écrit :


- la partition sda4 contient /bootmgr qui est le chargeur d'amorçage de Windows pour l'amorçage BIOS/legacy ; ajouté par un outil de "réparation" ?



boot-repair a donné un message immédiat d'erreur. possible que son action ait laissé une trace. je ne sais pas.

merci !


"Being is not doing"

Hors ligne

#9 18-07-2021 21:15:29

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

C'est pas la joie.
Les répertoires du chargeur de Windows sont présents dans la partition EFI mais ils sont vides.
L'entrée "Windows Boot Manager" est bien présente dans les variables d'amorçage EFI mais elle pointe vers le GRUB de Debian. Ça ressemble à une bidouille bien connue faite sous Windows avec bcdedit, ça te dit quelque chose ?
Le fichier bootmgr (chargeur BIOS/Legacy) à la racine de la partition sda4 date de 2015, soit il est d'origine (et je ne comprends pas ce qu'il fait dans une installation UEFI), soit il a été déposé par un outil de "réparation" qui a préservé la date du fichier source.

jeanmarc1 a écrit :

possible, de mémoire, oui, que j'ai du reformater la partition EFI quand j'ai réinstallé la debian.


Pourtant ces répertoires installés par Windows sont bien présents (mais vides) :
/boot/efi/EFI/boot
/boot/efi/EFI/Microsoft
/boot/efi/EFI/Microsoft/Boot
Quelle est leur date ?


Il vaut mieux montrer que raconter.

Hors ligne

#10 20-07-2021 17:53:24

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

merci bcp pour ton retour. je n'ai pas encore pu avoir un accès à l'ordinateur en question. je reviens vers toi dès que possible. merci pour ta patience.

"Being is not doing"

Hors ligne

#11 20-07-2021 19:53:40

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur a écrit :

C'est pas la joie.
Les répertoires du chargeur de Windows sont présents dans la partition EFI mais ils sont vides.
L'entrée "Windows Boot Manager" est bien présente dans les variables d'amorçage EFI mais elle pointe vers le GRUB de Debian. Ça ressemble à une bidouille bien connue faite sous Windows avec bcdedit, ça te dit quelque chose ?



Non, je ne vois pas d'où cela peut venir.

raleur a écrit :


Le fichier bootmgr (chargeur BIOS/Legacy) à la racine de la partition sda4 date de 2015, soit il est d'origine (et je ne comprends pas ce qu'il fait dans une installation UEFI), soit il a été déposé par un outil de "réparation" qui a préservé la date du fichier source.



boot-repair a bien été utilisé, mais a donné un message immédiat d'erreur. je ne sais pas s'il a pu intervenir sur le fichier bootmgr.

raleur a écrit :


jeanmarc1 a écrit :

possible, de mémoire, oui, que j'ai du reformater la partition EFI quand j'ai réinstallé la debian.


Pourtant ces répertoires installés par Windows sont bien présents (mais vides) :
/boot/efi/EFI/boot
/boot/efi/EFI/Microsoft
/boot/efi/EFI/Microsoft/Boot
Quelle est leur date ?



dans la debian fonctionnelle, voici les dates :

/boot/efi/EFI/boot
11/06/2021

/boot/efi/EFI/Microsoft
16/07/2021

/boot/efi/EFI/Microsoft/Boot
16/07/2021


"Being is not doing"

Hors ligne

#12 24-07-2021 17:45:02

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

peut-être dois-je détruire les partitions windows, qui ne sont pas utilisables, et je verrai plus tard pour le réinstaller si cela s'avérait indispensable. merci en tout cas pour ton aide.

"Being is not doing"

Hors ligne

#13 25-07-2021 14:45:42

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

Il faut réinstaller/réparer l'amorçage UEFI de Windows. Aucune idée de comment on fait ça, mais il doit bien y avoir un outil Microsoft. Dans le temps on utilisait le CD/DVD d'installation en mode réparation.

EDIT : mais ça risque de poser un problème : apparemment l'entrée EFI "Windows Boot Manager" pointe vers GRUB et sert à démarrer Debian. Si la réparation de l'amorçage de Windows modifie cette entrée pour la faire pointer vers le chargeur Microsoft, il pourrait ne plus être possible de lancer Debian. Il y a bien une entrée EFI "debian" mais on ne sait pas vers quoi elle pointe (comme celle libellée "ubuntu"). Il serait souhaitable de créer une entrée EFI "debian" qui pointe vers GRUB.

Dernière modification par raleur (25-07-2021 14:51:48)


Il vaut mieux montrer que raconter.

Hors ligne

#14 25-07-2021 14:52:59

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

bonjour jeanmarc1  big_smile  big_smile  big_smile

si le boot de windows ne fonctionne pas ,

tu peux peut être essayer super grub disk .

tu crées un disque ou une clé  avec cet utilitaire ,
tu le lance (démarre dessus) , et , une fois dedans , tu choisis le système  que tu veux lancer .

https://www.supergrubdisk.org/category/ … sk-stable/

en espérant avoir bien répondu .

amicalement,
alain.

coyotus.png

p.s.: une fois dans windows , il reste le boot à recréer .
mais là , je peux pas t'aider .
tu dois avoir aussi des options d'aide sur le disque de dépannage de windows .
https://www.malekal.com/demarrer-option … indows-10/

Dernière modification par Debian Alain (25-07-2021 14:57:10)

Hors ligne

#15 25-07-2021 14:57:34

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

merci, alain. j'avais déjà testé supergrub. mais il n'offre pas la possibilité d'entrer dans windows. il ne trouve que la debian. curieux, mais c'est ainsi.

"Being is not doing"

Hors ligne

#16 25-07-2021 15:03:26

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

GRUB ne peut pas amorcer Windows directement, il ne peut que chaîner son chargeur d'amorçage. Mais ce dernier a disparu...

Il vaut mieux montrer que raconter.

Hors ligne

#17 25-07-2021 15:03:30

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur a écrit :

Il faut réinstaller/réparer l'amorçage UEFI de Windows. Aucune idée de comment on fait ça, mais il doit bien y avoir un outil Microsoft. Dans le temps on utilisait le CD/DVD d'installation en mode réparation.
EDIT : mais ça risque de poser un problème : apparemment l'entrée EFI "Windows Boot Manager" pointe vers GRUB et sert à démarrer Debian. Si la réparation de l'amorçage de Windows modifie cette entrée pour la faire pointer vers le chargeur Microsoft, il pourrait ne plus être possible de lancer Debian. Il y a bien une entrée EFI "debian" mais on ne sait pas vers quoi elle pointe (comme celle libellée "ubuntu"). Il serait souhaitable de créer une entrée EFI "debian" qui pointe vers GRUB.



merci de ton conseil. j'ai déjà testé l'outil de réparation de windows. mais on arrive à une fenêtre d'échec... dans l'idéal, il faudrait que je réinstalle complètement win, puis debian. mais je crois que je vais rester avec la debian sans windows sur cette machine pour l'instant. c'est comme en médecine. il y a parfois des maladies dites incurables.


"Being is not doing"

Hors ligne

#18 25-07-2021 15:05:45

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

jeanmarc1 a écrit :

j'ai déjà testé l'outil de réparation de windows. mais on arrive à une fenêtre d'échec.


As-tu pensé à demander l'aide de personnes qui connaissent bien Windows ? Ce n'est pas forcément ici que tu les trouveras.


Il vaut mieux montrer que raconter.

Hors ligne

#19 25-07-2021 15:06:55

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur a écrit :

jeanmarc1 a écrit :

j'ai déjà testé l'outil de réparation de windows. mais on arrive à une fenêtre d'échec.


As-tu pensé à demander l'aide de personnes qui connaissent bien Windows ? Ce n'est pas forcément ici que tu les trouveras.



non, je n'ai pas cherché. je crains que les dual-boot avec linux n'entrent guère dans les compétences des forums windows.


"Being is not doing"

Hors ligne

#20 25-07-2021 15:17:14

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : plus d'accès à windows en dual-boot après une installation de debian

Tu as regardé ce tuto ? --> https://debian-facile.org/doc:install:d … -de-l-uefi

Petit conseil: Windows et linux ensemble en principe ne font pas bon ménage ! Il vaut mieux les installer indépendamment l'un de l'autre !

Ou alors utiliser une VM, genre virtualbox ou autre !

Tu installes debian en dur et windows sur la VM !

Dernière modification par Jean-Pierre Pinson (25-07-2021 15:56:35)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#21 25-07-2021 15:33:45

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

Jean-Pierre Pinson a écrit :

Tu as regardé se tuto ? --> https://debian-facile.org/doc:install:d … -de-l-uefi

Petit conseil: Windows et linux ensemble en principe ne font pas bon ménage ! Il vaut mieux les installer indépendamment l'un de l'autre !

Ouais alors utiliser une VM, genre virtualbox ou autre !

Tu installes debian en dur et windows sur la VM !



merci pour le lien. j'ai trois autres machines identiques, des intel nuc, qui ont toutes des debian ou ubuntu en dual boot avec des windows 10, sans aucun souci. je crois que sur cette quatrième machine, le bug a été fait au moment de la réinstallation de la debian, qui buggait, quand le système d'installation a réclamé une partition EFI. possible que j'ai créé une nouvelle partition EFI ou bien formaté l'existante, et cela a créé le dysfonctionnement et l'impossibilité d'accès à win.


"Being is not doing"

Hors ligne

#22 25-07-2021 15:35:33

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

jeanmarc1 a écrit :

je crains que les dual-boot avec linux n'entrent guère dans les compétences des forums windows.


Le problème n'a rien à voir avec un dual boot. Les fichiers du chargeur d'amorçage UEFI de Windows ont disparu de la partition système EFI, c'est tout.


Il vaut mieux montrer que raconter.

Hors ligne

#23 25-07-2021 15:46:47

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Buster 10 en dual-boot sur Intel Nuc C7PJYH
Noyau : Linux 4.19.0-9-amd64
(G)UI : KDE
Inscription : 09-09-2012
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur a écrit :

jeanmarc1 a écrit :

je crains que les dual-boot avec linux n'entrent guère dans les compétences des forums windows.


Le problème n'a rien à voir avec un dual boot. Les fichiers du chargeur d'amorçage UEFI de Windows ont disparu de la partition système EFI, c'est tout.



ok, merci.


"Being is not doing"

Hors ligne

#24 25-07-2021 15:54:36

raleur
Membre
Inscription : 03-10-2014

Re : plus d'accès à windows en dual-boot après une installation de debian

Une "greffe" des répertoires Boot et Microsoft de la partition système EFI d'une autre machine ne suffirait probablement pas car le fichier BCD ne correspondra pas. Mais ensuite l'outil de réparation de Windows fonctionnera peut-être.

Il vaut mieux montrer que raconter.

Hors ligne

#25 25-07-2021 15:56:36

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (stable)
Noyau : Linux -5.10.0-8-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : plus d'accès à windows en dual-boot après une installation de debian

raleur  a écrit :

Le problème n'a rien à voir avec un dual boot. Les fichiers du chargeur d'amorçage UEFI de Windows ont disparu de la partition système EFI, c'est tout.

Debian ne donne pas la possibilité de recréer le chargeur d'amorçage , de manière générale .
c.a.d. que , dans le cas présent , on peut pas  réparer le multi amorçage de grub sous debian ?

Hors ligne

Pied de page des forums