Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-12-2021 21:45:35

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Problème de pilote (wifi tres très lent) ?

Bonsoir,

Ce soir, j'ai décidé de réinstaller Debian.
J'avais la version 10, je suis passé sur la version 11.

Mon soucis réside dans le wifi.
Quand je suis en Ethernet, internet fonctionne parfaitement.
Mais dès que je passe en wifi, il est extrêmement lent (plusieurs minutes pour afficher une simple page web).

J'ai un dualboot avec Windows 10 sur ce même PC et le wifi est "normal".
Sur Debian 10, pareil (aucun soucis de wifi).

J'imagine que c'est un soucis de pilote. ??

Comment faire ?

Merci beaucoup


Voici ce que j'ai dans le fichier sources :

  GNU nano 5.4                  /etc/apt/sources.list                          
# deb cdrom:[Debian GNU/Linux 11.2.0 _Bullseye_ - Official amd64 DVD Binary-1 2>

deb http://ftp.fr.debian.org/debian/ bullseye main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ bullseye main contrib non-free


bloc à supprimer si la commande n’affiche rien

Hors ligne

#2 27-12-2021 22:05:06

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

bonjour Euline  big_smile  big_smile  big_smile

regarde cette page :  https://debian-facile.org/doc:systeme:a … st:buster?

et crée toi un sources list conforme à celui - ci :

    # Debian Bullseye , dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ bullseye  main contrib non-free
    deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
     
    # Debian Bullseye, mises à jour de sécurité + paquets non libres
    deb http://deb.debian.org/debian-security/ bullseye/updates main contrib non-free
    deb-src http://deb.debian.org/debian-security/ bullseye/updates main contrib non-free
     
    # Debian Bullseye , mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
    deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free
 



avec nano

amicalement ,

alain.

coyotus.png

Dernière modification par Debian Alain (27-12-2021 22:06:21)

Hors ligne

#3 28-12-2021 11:59:53

jarek
Membre
Lieu : Haute Loire
Distrib. : bookworm
Noyau : linux 5.16
(G)UI : xfce4 - lightdm
Inscription : 24-06-2014

Re : Problème de pilote (wifi tres très lent) ?

Celle-là me semble incorrecte :

deb http://deb.debian.org/debian-security/ bullseye/updates main contrib non-free



Ce n'est pas plutôt ça :

deb http://deb.debian.org/debian-security bullseye-security main contrib non-free


L'europe c'est de la merde, on peut pas compter dessus . . .

Hors ligne

#4 28-12-2021 12:09:55

lagrenouille
Adhérent(e)
Lieu : Toulouse
Distrib. : debian buster_bulseyes
Noyau : d'olive
(G)UI : ça dépends des jours
Inscription : 28-03-2012
Site Web

Re : Problème de pilote (wifi tres très lent) ?

voila les miens, et ça gaze smile


deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye main contrib non-free

deb http://security.debian.org/debian-security bullseye-security main contrib non-free
#deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports

deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ bullseye-updates main

deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free

Hors ligne

#5 28-12-2021 12:48:29

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Problème de pilote (wifi tres très lent) ?

@Alain,
m'enfin .....

5.1.3. Changed security archive layout

For bullseye, the security suite is now named bullseye-security instead of codename/updates and users should adapt their APT source-list files accordingly when upgrading.

The security line in your APT configuration may look like:

deb https://deb.debian.org/debian-security bullseye-security main contrib

En ligne

#6 28-12-2021 12:53:50

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

bonjour   big_smile  big_smile  big_smile

arf ! t'as raison ubub .

j'étais parti  de la page de buster ,

j'ai bêtement remplacé buster par bullseye .

j'ai pas  trop réfléchi .

merci d'avoir rectifié l'erreur .

amicalement .

alain.

coyotus.png

je rectifie mon erreur :

le lien ad - hoc : https://debian-facile.org/doc:systeme:a … t:bullseye

le sources conseillé :

    # Debian Bullseye, dépôt principal + paquets non libres
    deb http://deb.debian.org/debian/ bullseye main contrib non-free
    deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
     
    # Debian Bullseye, mises à jour de sécurité + paquets non libres
    deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
    deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
     
    # Debian Bullseye, mises à jour "volatiles" + paquets non libres
    deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
    deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free
 



editer le sources.list avec nano :

sudo nano /etc/apt/sources.list


modifier les sources à la main suivant le texte et le lien ci-dessus .

ctrl + o pour écrire le fichier
ctrl + x pour le sauvegarder et fermer nano



sudo apt update   # mise à jour des sources
apt policy  # verifie les  sources (priorités)
sudo apt upgrade   # mise à jour des paquets


et n'oublie pas de poster les retours .
pour ton wifi , on va  voir çà un peu après .
d'abord , mets à jour tes sources .

Dernière modification par Debian Alain (28-12-2021 13:08:24)

Hors ligne

#7 29-12-2021 11:49:11

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Re : Problème de pilote (wifi tres très lent) ?

Merci pour vos réponses big_smile

Voilà, j'ai mis à jour mon fichier sources comme ceci :

# Debian Bullseye, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye main contrib non-free

# Debian Bullseye, mises à jour de sécurité + paquets non libres
deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free

# Debian Bullseye, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free



J'ai fait les apt update et apt upgrade qui a mis à jour quelques logiciels smile

Pour apt policy :

Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.debian.org/debian bullseye-updates/main amd64 Packages
     release v=11-updates,o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian-security bullseye-security/main amd64 Packages
     release v=11,o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=main,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/non-free amd64 Packages
     release v=11.2,o=Debian,a=stable,n=bullseye,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/contrib amd64 Packages
     release v=11.2,o=Debian,a=stable,n=bullseye,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian bullseye/main amd64 Packages
     release v=11.2,o=Debian,a=stable,n=bullseye,l=Debian,c=main,b=amd64
     origin deb.debian.org
Paquets épinglés :
 



J'ai redémarré le PC et j'ai toujours le soucis du wifi sad

Hors ligne

#8 29-12-2021 11:59:34

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

bon, sans garantie Euline , mais on va voir pour le wifi :

lspci -nnkd::0280


lspci -nnk | grep -i net -A2



tu as quoi comme bureau ?

echo $XDG_SESSION_DESKTOP $XDG_SESSION_TYPE



n'oublie pas de poster les retours,
je t'attends .
n.b.: ces commandes me serviront à voir ton interface matérielle et logicielle .
je te propose , si j'y arrive , une réinstallation de  ton pilote .

Dernière modification par Debian Alain (29-12-2021 12:02:11)

Hors ligne

#9 29-12-2021 13:11:43

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Re : Problème de pilote (wifi tres très lent) ?

Merci pour ta réponse smile

lspci -nnkd::0280


03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
  Subsystem: AzureWave AR9485 Wireless Network Adapter [1a3b:2126]
  Kernel driver in use: ath9k
  Kernel modules: ath9k



lspci -nnk | grep -i net -A2


03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
  Subsystem: AzureWave AR9485 Wireless Network Adapter [1a3b:2126]
  Kernel driver in use: ath9k
  Kernel modules: ath9k
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
  Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:200f]
  Kernel driver in use: r8169
  Kernel modules: r8169



echo $XDG_SESSION_DESKTOP $XDG_SESSION_TYPE


gnome wayland



J'ai Gnome 3.38.5 smile

Hors ligne

#10 29-12-2021 13:28:43

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

j' ai trouvé une  réponse , mais j'ai du mal à la  comprendre .

je te la soumets  .

cela  correspond il à ton souci ?

https://d-meeus.be/linux/atheroswifi.html

la solution "légère" est intéressante mais il faut l'adapter et , au plus , elle utilise le kernel backports 5.9.12 .

quel est ton noyau ?

ton cartouche est il à jour ?

tu es bien sous bullseye ?

tu as bien le noyau 5.10. ?

sudo dpkg -l | grep -iE "linux-image-|linux-headers-"



amicalement ,

alain .

coyotus.png

note : essaie aussi d'utiliser  wificheck

https://doc.ubuntu-fr.org/wificheck

 wget -N -t 5 -T 10 https://framagit.org/cracolinux/wificheck/raw/master/wificheck && chmod +x wificheck && ./wificheck

Dernière modification par Debian Alain (29-12-2021 15:01:25)

Hors ligne

#11 29-12-2021 22:03:39

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Re : Problème de pilote (wifi tres très lent) ?

Oui, moi aussi je ne capte pas trop hmm

uname -sr


Linux 5.10.0-10-amd64



lsb_release -a


No LSB modules are available.
Distributor ID: Debian
Description:  Debian GNU/Linux 11 (bullseye)
Release:  11
Codename: bullseye

Hors ligne

#12 30-12-2021 10:25:34

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

si non , tu as pensé à rajouter le dépôts des backports à ta stable ?

et à installer un kernel backporté ?

pour les problèmes de version de paquets , çà solutionne souvent .

https://debian-facile.org/doc:systeme:a … -backports

rajoute ceci , avec nano :

# stable-backports
deb http://deb.debian.org/debian/  bullseye-backports main contrib non-free
 



suivi de :

sudo apt update
sudo apt upgrade


apt search linux-image-5.14.


et poste le retour de cette dernière commande
poste aussi ton sources , que je puisse vérifier .



aussi , tu as une commande pratique pour checker  ton sources , c'est inxi .

sudo apt install inxi


inxi -r


et poste le retour


normalement , les données se recouperont .

note : tu as essayé "wificheck" comme mentionné  dans mon post précédent ?
il a  été créé sous ubuntu pour faciliter le dépannage des cartes wifi .
il est relativement exhaustif et très intéressant .
c'est un script , tu ne cassera rien . (je l'ai testé chez moi) .
au plus , certaines commandes non installées ne  fonctionneront pas , c'est tout .

copie - colle la ligne de commandes  que je t'ai soumise et
va chercher dans ton dossier personnel le fichier wificheck.log
que tu copie - colles ici .

amicalement ,

alain

coyotus.png

Dernière modification par Debian Alain (30-12-2021 10:51:28)

Hors ligne

#13 30-12-2021 12:21:19

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème de pilote (wifi tres très lent) ?

hello
@Debian Alain ...lu ton lien message #10 mais me semble plus d'actualité bien que l'article ai été modifié récemment

Appliqué le 18 juillet à mon noyau 3.8 de la distribution. Le résultat est pareil : extraordinaire !


C'est un peu loin le noyau 3.8

si ce n'est déja fait

apt install firmware-atheros


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 30-12-2021 12:30:23

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

Croutons  a écrit :


C'est un peu loin le noyau 3.8

oui , je m'en doute bien .
c'est en partie pour çà que je pense que le correctif doit être intégré dans un noyau plus récent .

j'ai pas pensé au firmare atheros .

j'ai regardé :

apt-cache madison firmware-atheros


... / ...
firmware-atheros | 20210315-3 | http://deb.debian.org/debian bullseye/non-free amd64 Packages
firmware-atheros | 20210315-3 | http://deb.debian.org/debian bullseye/non-free i386 Packages
... / ...
 


apt show firmware-atheros=20210315-3 | grep -iE "AR9485"


WARNING: apt does not have a stable CLI interface. Use with caution in scripts.



merci .

amicalement ,

alain .

coyotus.png

curiosité :

que donne : ? 

nmcli dev wifi



note :
trouvé  ceci mais je ne suis pas sûr de moi : https://github.com/fdaciuk/install-linu … ireless.sh

Dernière modification par Debian Alain (30-12-2021 15:38:47)

Hors ligne

#15 31-12-2021 10:09:43

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Re : Problème de pilote (wifi tres très lent) ?

J'ai rajouté les 2 lignes pour la backports.
J'ai déjà installé le pilote atheros afin d'avoir le bluetooth (après l'installation de Debian 11, le Bluetooth n'était pas reconnu) smile

apt search linux-image-5.14.


En train de trier... Fait
Recherche en texte intégral... Fait
linux-headers-5.14.0-0.bpo.2-amd64/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Header files for Linux 5.14.0-0.bpo.2-amd64

linux-headers-5.14.0-0.bpo.2-cloud-amd64/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Header files for Linux 5.14.0-0.bpo.2-cloud-amd64

linux-image-5.14.0-0.bpo.2-amd64/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Linux 5.14 for 64-bit PCs (signed)

linux-image-5.14.0-0.bpo.2-amd64-dbg/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Debug symbols for linux-image-5.14.0-0.bpo.2-amd64

linux-image-5.14.0-0.bpo.2-amd64-unsigned/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Linux 5.14 for 64-bit PCs

linux-image-5.14.0-0.bpo.2-cloud-amd64/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Linux 5.14 for x86-64 cloud (signed)

linux-image-5.14.0-0.bpo.2-cloud-amd64-dbg/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Debug symbols for linux-image-5.14.0-0.bpo.2-cloud-amd64

linux-image-5.14.0-0.bpo.2-cloud-amd64-unsigned/bullseye-backports 5.14.9-2~bpo11+1 amd64
  Linux 5.14 for x86-64 cloud



inxi -r


Repos:
  Active apt repos in: /etc/apt/sources.list
  1: deb http://deb.debian.org/debian/ bullseye main contrib non-free
  2: deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
  3: deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
  4: deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
  5: deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
  6: deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free
  7: deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free
 



wget -N -t 5 -T 10 https://framagit.org/cracolinux/wificheck/raw/master/wificheck && chmod +x wificheck && ./wificheck


--2021-12-31 09:06:40--  https://framagit.org/cracolinux/wificheck/raw/master/wificheck
Résolution de framagit.org (framagit.org)… 176.9.183.75, 2a01:4f8:231:4c99::75
Connexion à framagit.org (framagit.org)|176.9.183.75|:443… connecté.
requête HTTP transmise, en attente de la réponse… 200 OK
Taille : 2235 (2,2K) [text/plain]
Sauvegarde en : « wificheck »

wificheck                   100%[==========================================>]   2,18K  --.-KB/s    ds 0s      

En-tête de dernière modification manquant — horodatage arrêté.
2021-12-31 09:06:41 (17,5 MB/s) — « wificheck » sauvegardé [2235/2235]

No LSB modules are available.
sudo: lshw : commande introuvable
./wificheck: ligne 56: iwconfig : commande introuvable
./wificheck: ligne 66: ifconfig : commande introuvable
lo        Interface doesn't support scanning.

enp4s0    Interface doesn't support scanning.

wlp3s0    Interface doesn't support scanning : Network is down

usb0      Interface doesn't support scanning.

sudo: rfkill : commande introuvable
Le fichier wificheck.log a été crée dans /root
Vous n'avez plus qu'à copier/coller son contenu sur le forum
 accès →→ file://root/wificheck.log
 



apt-cache madison firmware-atheros


bloc à supprimer si la commande n’affiche rien



Merci beaucoup

Hors ligne

#16 31-12-2021 11:22:20

raleur
Membre
Inscription : 03-10-2014

Re : Problème de pilote (wifi tres très lent) ?

Debian Alain a écrit :

j'ai pas pensé au firmare atheros


Le module ath9k ne déclare aucun firmware :

/sbin/modinfo -F firmware ath9k


Euline a écrit :

(17,5 MB/s) — « wificheck » sauvegardé [2235/2235]


Ça me semble être un débit tout-à-fait convenable, mais peut-être pas très significatif vu la taille. Il faudrait retester avec téléchargement d'un fichier plus gros qui dure au moins 10 secondes.


Il vaut mieux montrer que raconter.

Hors ligne

#17 31-12-2021 12:02:59

Euline
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Gnome 3.38.5
Inscription : 06-05-2020

Re : Problème de pilote (wifi tres très lent) ?

raleur a écrit :

Debian Alain a écrit :

j'ai pas pensé au firmare atheros


Le module ath9k ne déclare aucun firmware :

/sbin/modinfo -F firmware ath9k


Euline a écrit :

(17,5 MB/s) — « wificheck » sauvegardé [2235/2235]


Ça me semble être un débit tout-à-fait convenable, mais peut-être pas très significatif vu la taille. Il faudrait retester avec téléchargement d'un fichier plus gros qui dure au moins 10 secondes.


Je suis en ethernet car impossible en wifi (très très long à télécharger).

Quand je dis ethernet, ça veut dire que je me connecte en wifi grâce à mon téléphone, et que je fais un partage de connexion via le câble USB (entre le téléphone et le PC) smile

Hors ligne

#18 31-12-2021 12:19:10

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème de pilote (wifi tres très lent) ?

Hello
17,5MB/s convenable tout est relatif, si c'est une connexion adsl oui meme tres bien
mais sur un abonnement fibre par exemple c'est déplorable

Il y a le paquet speedtest-cli qui est pas mal pour des petits test rapide dans son terminal
sinon pour un test plus poussé
https://www.60millions-mag.com/debitest … sommateurs

Enfin le débit de la connexion pour afficher une page web hein faut pas grand chose , meme avant quand j'étais avec 2 MB/s les pages s'affichait super vite
Et oui c'était bien 2MB soit environ 600Ko/s au mieux
Après se qui joue le + c'est le temps de réponse au ping au dessus de 60ms  pour de l'adsl c'est moche
il serait intéressant de voir le résultat , surtout si par exemple y'a des paquets perdu

ping google.fr


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#19 31-12-2021 12:37:46

raleur
Membre
Inscription : 03-10-2014

Re : Problème de pilote (wifi tres très lent) ?

Croutons a écrit :

17,5MB/s convenable tout est relatif, si c'est une connexion adsl oui meme tres bien


Un tel débit est impossible en ADSL dont le débit maximum théorique est 24 Mbit/s (et non Mo/s).


Il vaut mieux montrer que raconter.

Hors ligne

#20 31-12-2021 18:39:54

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

bonsoir Euline  smile  smile  smile

qui t'a dit de lancer la commande wget de  wificheck en root ?

la ligne de  commande  que je t'ai donnée s' éxécute en user .

wget -N -t 5 -T 10 https://framagit.org/cracolinux/wificheck/raw/master/wificheck && chmod +x wificheck && ./wificheck



je ne sais pas ce qu' en pensent les autres ,

mais je te conseillerai volontiers d'installer un noyau backports .

tu peux essayer ceci :

apt install linux-headers-5.14.0-0.bpo.2-amd64 linux-image-5.14.0-0.bpo.2-amd64


reboot


uname -a



en espérant que ce nouveau noyau puisse  assurer  la compatibilité avec ton matériel ...

que donnent  :

ls /etc/modprobe.d/


nmcli dev wifi



note : Euline , fais  attention à pas mélanger les commandes root et user .

amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (31-12-2021 18:47:11)

Hors ligne

#21 31-12-2021 19:02:59

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : Problème de pilote (wifi tres très lent) ?

@ alain : je mesure pas vraiment l'importance de pas wget ce script en root,
mais, il est bien, mais réglé pour *buntu ...
Sur Debian, ça risque de faire :
* sudo lshw : l'utilisateur machin a pas les droits sudoers (vu que si t'as créé un compte root, ton user aura pas de facto les droits sudo)
* de pas savoir exécuter lshw, si pas installé précédement ( c'est comme inxi, c'est pas installé de base, contrario à *buntu où ça l'est me semble)
* de renvoyer : iwconfig et ifconfig commandes introuvables ....
Après il est bien comme script, mais faudrait l'actualiser pour debian (genre iwconfig...mais comme je suis une bille, je donnerai pas la commande à utiliser à la place)...

  ...Je suis entrain de tester speedtest-cli, ça a l'air pas mal (le paquet, moi je suis à 0.20 Mbits ¡olé! )

En ligne

#22 31-12-2021 19:18:28

Debian Alain
Membre
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux sid 5.17.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Problème de pilote (wifi tres très lent) ?

tu as  en partie raison , ubub .  smile  smile  smile

ce script est  fait pour ubuntu .

pour l'avoir testé , il fonctionne très bien sous debian .

quelques commandes , en effet , ne sont pas reconnues .
car souvent pas installées ou dépréciées chez  debian .
mais ce n'est pas grave .
cela ne prête pas à conséquences .

je le mentionne , car , plutôt que de taper des commandes une à une ,
ici , nous  avons un listing des commandes "relativement"  exhaustif .
ce script fait une synthèse et c'est très pratique .

pour savoir  si Euline est bien membre du groupe sudo ,
ce qui évitera une partie des soucis :

getent group sudo



amicalement ,

alain .

coyotus.png

ta carte wifi , d'après la doc que je trouve , semble poser  beaucoup de problèmes de compatibilité avec linux .
je ne sais pas si tu trouvera une solution .
perso , moi , j'ai pas  trouvé .

Dernière modification par Debian Alain (31-12-2021 22:58:00)

Hors ligne

Pied de page des forums