Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 06-05-2022 15:14:14

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Cela semble résoudre le problème des clés expirées :

 apt-get update
Réception de : 1 http://archive.debian.org lenny Release.gpg [1034B]
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 2 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Ign http://archive.debian.org lenny/updates/contrib Translation-fr
Ign http://archive.debian.org lenny/updates/non-free Translation-fr
Atteint http://archive.debian.org lenny Release
Atteint http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Ign http://archive.debian.org lenny/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/main Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/contrib Packages/DiffIndex
Ign http://archive.debian.org lenny/updates/non-free Packages/DiffIndex
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/contrib Packages
Atteint http://archive.debian.org lenny/non-free Packages
Atteint http://archive.debian.org lenny/updates/main Packages
Atteint http://archive.debian.org lenny/updates/contrib Packages
Atteint http://archive.debian.org lenny/updates/non-free Packages
1870o réceptionnés en 0s (3561o/s)
Lecture des listes de paquets... Fait
 



Par contre, quand j'essaie d'installer libcurses5 pour avoir une version plus récente, je n'ai pas de mise à jour :

 apt-get upgrade libcurses5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  bind9-host dnsutils libbind9-50 libisccc50 libisccfg50 liblwres50
0 mis à jour, 0 nouvellement installés, 0 à enlever et 6 non mis à jour.
 



Même chose pour readline6, aucun paquet ne semble disponible :

 apt-get install readline6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet readline6
root@bafinddtest:/etc/apt# apt-cache search readline
cdecl - Turn English phrases to C or C++ declarations
cl-readline - Common Lisp interface to the GNU readline library
cle - Wrap any command-line driven tool with readline
libeditline-dev - development files for libeditline
libeditline0 - line editing library similar to readline
freetalk - A console based Jabber client
ghc6-doc - Documentation for the Glasgow Haskell Compilation system
ghc6-prof - Profiling libraries for the Glasgow Haskell Compilation system
ghc6 - GHC - the Glasgow Haskell Compilation system
libjline-java-doc - Java library for handling console input - documentation
libjline-java - Java library for handling console input
libreadline-java-doc - API docs for readline/editline wrappers for Java
libreadline-java - GNU readline and BSD editline wrappers for Java
libruby-extras - a bundle of additional libraries for Ruby
libruby1.8-extras - a bundle of additional libraries for Ruby 1.8
libterm-readline-gnu-perl - Perl extension for the GNU Readline/History Library
libterm-readline-perl-perl - Perl implementation of Readline libraries
libterm-readline-zoid-perl - Pure Perl implementation of Readline libraries
ncftp - A user-friendly and well-featured FTP client
nwall - version of wall that uses GNU readline
perlconsole - small program that lets you evaluate Perl code interactively
lib64readline5-dev - GNU readline and history libraries, development files (64-bit)
lib64readline5 - GNU readline and history libraries, run-time libraries (64-bit)
libreadline5-dbg - GNU readline and history libraries, debugging libraries
libreadline5-dev - GNU readline and history libraries, development files
libreadline-ruby - Readline interface for Ruby
libreadline-ruby1.8 - Readline interface for Ruby 1.8
ruby1.8 - Interpreter of object-oriented scripting language Ruby 1.8
libreadline-ruby1.9 - Readline interface for Ruby 1.9
shogun-dbg - Large Scale Machine Learning Toolbox
shogun-doc - Large Scale Machine Learning Toolbox
shogun-octave-modular - Large Scale Machine Learning Toolbox
shogun-octave - Large Scale Machine Learning Toolbox
shogun-python-modular - Large Scale Machine Learning Toolbox
shogun-python - Large Scale Machine Learning Toolbox
shogun-r - Large Scale Machine Learning Toolbox
shogun-readline - Large Scale Machine Learning Toolbox
swi-prolog-clib - SWI-Prolog interface to system libraries
swi-prolog-http - HTTP libraries for SWI-Prolog
swi-prolog-odbc - ODBC library for SWI-Prolog
swi-prolog-semweb - SWI-Prolog library for manipulating RDF triples
swi-prolog-sgml - SGML/XML/HTML parser for SWI-Prolog
swi-prolog-table - External table library for SWI-Prolog
swi-prolog-xpce - User interface library for SWI-Prolog
swi-prolog - ISO/Edinburgh-style Prolog interpreter
tftp-hpa - HPA's tftp client
renameutils - Programmes pour renommer plus facilement des fichiers
tintin++ - Client MUD classique en mode texte
rpncalc - Calculatrice RPN qui tente d'émuler une HP28S
rlfe - Une interface utilisant readline pour « cuisiner » des lignes d'entrée d'autres programmes
readline-common - Bibliothèques GNU readline et GNU history, fichiers communs
libedit2 - Bibliothèques BSD editline et history
rlwrap - Encapsuleur de ligne de commande utilisant readline
libedit-dev - Bibliothèques editline et history de BSD (fichiers de développement)
bibindex - Recherche rapide dans les bases de données bibliographiques BibTeX
libenv-ps1-perl - Formateur de chaîne d'invite de commande
tclreadline - Extension GNU Readline pour Tcl/Tk
libreadline5 - bibliothèques GNU readline et GNU history (exécutables)
root@bafinddtest:/etc/apt# apt-get upgrade libcurses5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  bind9-host dnsutils libbind9-50 libisccc50 libisccfg50 liblwres50
0 mis à jour, 0 nouvellement installés, 0 à enlever et 6 non mis à jour.
root@bafinddtest:/etc/apt# apt-cache search readline
cdecl - Turn English phrases to C or C++ declarations
cl-readline - Common Lisp interface to the GNU readline library
cle - Wrap any command-line driven tool with readline
libeditline-dev - development files for libeditline
libeditline0 - line editing library similar to readline
freetalk - A console based Jabber client
ghc6-doc - Documentation for the Glasgow Haskell Compilation system
ghc6-prof - Profiling libraries for the Glasgow Haskell Compilation system
ghc6 - GHC - the Glasgow Haskell Compilation system
libjline-java-doc - Java library for handling console input - documentation
libjline-java - Java library for handling console input
libreadline-java-doc - API docs for readline/editline wrappers for Java
libreadline-java - GNU readline and BSD editline wrappers for Java
libruby-extras - a bundle of additional libraries for Ruby
libruby1.8-extras - a bundle of additional libraries for Ruby 1.8
libterm-readline-gnu-perl - Perl extension for the GNU Readline/History Library
libterm-readline-perl-perl - Perl implementation of Readline libraries
libterm-readline-zoid-perl - Pure Perl implementation of Readline libraries
ncftp - A user-friendly and well-featured FTP client
nwall - version of wall that uses GNU readline
perlconsole - small program that lets you evaluate Perl code interactively
lib64readline5-dev - GNU readline and history libraries, development files (64-bit)
lib64readline5 - GNU readline and history libraries, run-time libraries (64-bit)
libreadline5-dbg - GNU readline and history libraries, debugging libraries
libreadline5-dev - GNU readline and history libraries, development files
libreadline-ruby - Readline interface for Ruby
libreadline-ruby1.8 - Readline interface for Ruby 1.8
ruby1.8 - Interpreter of object-oriented scripting language Ruby 1.8
libreadline-ruby1.9 - Readline interface for Ruby 1.9
shogun-dbg - Large Scale Machine Learning Toolbox
shogun-doc - Large Scale Machine Learning Toolbox
shogun-octave-modular - Large Scale Machine Learning Toolbox
shogun-octave - Large Scale Machine Learning Toolbox
shogun-python-modular - Large Scale Machine Learning Toolbox
shogun-python - Large Scale Machine Learning Toolbox
shogun-r - Large Scale Machine Learning Toolbox
shogun-readline - Large Scale Machine Learning Toolbox
swi-prolog-clib - SWI-Prolog interface to system libraries
swi-prolog-http - HTTP libraries for SWI-Prolog
swi-prolog-odbc - ODBC library for SWI-Prolog
swi-prolog-semweb - SWI-Prolog library for manipulating RDF triples
swi-prolog-sgml - SGML/XML/HTML parser for SWI-Prolog
swi-prolog-table - External table library for SWI-Prolog
swi-prolog-xpce - User interface library for SWI-Prolog
swi-prolog - ISO/Edinburgh-style Prolog interpreter
tftp-hpa - HPA's tftp client
renameutils - Programmes pour renommer plus facilement des fichiers
tintin++ - Client MUD classique en mode texte
rpncalc - Calculatrice RPN qui tente d'émuler une HP28S
rlfe - Une interface utilisant readline pour « cuisiner » des lignes d'entrée d'autres programmes
readline-common - Bibliothèques GNU readline et GNU history, fichiers communs
libedit2 - Bibliothèques BSD editline et history
rlwrap - Encapsuleur de ligne de commande utilisant readline
libedit-dev - Bibliothèques editline et history de BSD (fichiers de développement)
bibindex - Recherche rapide dans les bases de données bibliographiques BibTeX
libenv-ps1-perl - Formateur de chaîne d'invite de commande
tclreadline - Extension GNU Readline pour Tcl/Tk
libreadline5 - bibliothèques GNU readline et GNU history (exécutables)
 

Hors ligne

#27 06-05-2022 15:32:54

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

apt-get dist-upgrade


c'est pas mieux comme résultat pour la mise à jour?

edit : mysql-client-5.1 c'est un paquet sous lenny ou tu l'as téléchargé depuis un site?
j'ai trouvé sa mais y'a rien avant squeeze
https://sources.debian.org/src/readline6/

Dernière modification par Croutons (06-05-2022 15:38:06)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#28 06-05-2022 16:02:51

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

C'est un paquet que j'ai téléchargé ici :
http://archive.debian.org/debian-securi … mysql-5.1/

J'ai effectué la commande apt-get dist-upgrade mais pas readline6 après :

apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  libdns55 libisc52
Les NOUVEAUX paquets suivants seront installés :
  libdns58 libisc50
Les paquets suivants seront mis à jour :
  bind9-host dnsutils libbind9-50 libisccc50 libisccfg50 liblwres50
6 mis à jour, 2 nouvellement installés, 2 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1140ko dans les archives.
Après cette opération, 53,2ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://archive.debian.org lenny/main bind9-host 1:9.6.ESV.R4+dfsg-0+lenny4 [63,4kB]
Réception de : 2 http://archive.debian.org lenny/main dnsutils 1:9.6.ESV.R4+dfsg-0+lenny4 [149kB]
Réception de : 3 http://archive.debian.org lenny/main libbind9-50 1:9.6.ESV.R4+dfsg-0+lenny4 [34,7kB]
Réception de : 4 http://archive.debian.org lenny/main libisccfg50 1:9.6.ESV.R4+dfsg-0+lenny4 [46,2kB]
Réception de : 5 http://archive.debian.org lenny/main libisccc50 1:9.6.ESV.R4+dfsg-0+lenny4 [28,5kB]
Réception de : 6 http://archive.debian.org lenny/main libisc50 1:9.6.ESV.R4+dfsg-0+lenny4 [155kB]
Réception de : 7 http://archive.debian.org lenny/main libdns58 1:9.6.ESV.R4+dfsg-0+lenny4 [616kB]
Réception de : 8 http://archive.debian.org lenny/main liblwres50 1:9.6.ESV.R4+dfsg-0+lenny4 [46,9kB]
1140ko réceptionnés en 1s (1072ko/s)
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768694.604878244 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:35 est situé 47768692.604670046 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768694.604568834 secondes dans le futur.
(Lecture de la base de données... 47518 fichiers et répertoires déjà installés.)
Préparation du remplacement de bind9-host 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../bind9-host_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de bind9-host ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768694.56412077 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:36 est situé 47768693.563903181 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768672.563830183 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768694.563778989 secondes dans le futur.
Préparation du remplacement de dnsutils 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../dnsutils_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de dnsutils ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768694.543364924 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768672.543186337 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:35 est situé 47768692.543126852 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768672.543069322 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768672.543012671 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768694.542963147 secondes dans le futur.
Préparation du remplacement de libbind9-50 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../libbind9-50_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de libbind9-50 ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768694.527556188 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768672.527361054 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:36 est situé 47768693.527270263 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768672.527212741 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768672.527155876 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768694.527106316 secondes dans le futur.
Préparation du remplacement de libisccfg50 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../libisccfg50_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de libisccfg50 ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768694.495494367 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768672.495298325 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:36 est situé 47768693.495202034 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768672.495115996 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768672.495042083 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768694.4949917 secondes dans le futur.
Préparation du remplacement de libisccc50 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../libisccc50_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de libisccc50 ...
Traitement des actions différées (« triggers ») pour « man-db »...
(Lecture de la base de données... 47518 fichiers et répertoires déjà installés.)
Suppression de libdns55 ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Suppression de libisc52 ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768693.348465246 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768671.348227033 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:36 est situé 47768692.34817302 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768671.348123449 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768671.34807488 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768693.348031387 secondes dans le futur.
Sélection du paquet libisc50 précédemment désélectionné.
(Lecture de la base de données... 47508 fichiers et répertoires déjà installés.)
Dépaquetage de libisc50 (à partir de .../libisc50_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768693.259717926 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768671.259195815 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:35 est situé 47768691.259108172 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768671.25902733 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768671.258947333 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768693.258875612 secondes dans le futur.
Sélection du paquet libdns58 précédemment désélectionné.
Dépaquetage de libdns58 (à partir de .../libdns58_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
tar: ./md5sums : l'horodatage 2011-11-16 20:58:37 est situé 47768693.210320129 secondes dans le futur.
tar: ./shlibs : l'horodatage 2011-11-16 20:58:15 est situé 47768671.209677494 secondes dans le futur.
tar: ./control : l'horodatage 2011-11-16 20:58:36 est situé 47768692.20948027 secondes dans le futur.
tar: ./postrm : l'horodatage 2011-11-16 20:58:15 est situé 47768671.209315829 secondes dans le futur.
tar: ./postinst : l'horodatage 2011-11-16 20:58:15 est situé 47768671.20923487 secondes dans le futur.
tar: . : l'horodatage 2011-11-16 20:58:37 est situé 47768693.209166096 secondes dans le futur.
Préparation du remplacement de liblwres50 1:9.6.ESV.R1+dfsg-0+lenny2 (en utilisant .../liblwres50_1%3a9.6.ESV.R4+dfsg-0+lenny4_i386.deb) ...
Dépaquetage de la mise à jour de liblwres50 ...
Paramétrage de libisc50 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de libdns58 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de libisccc50 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de libisccfg50 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de libbind9-50 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de liblwres50 (1:9.6.ESV.R4+dfsg-0+lenny4) ...
ldconfig: File /usr/lib/libtds.so is empty, not checked.
Paramétrage de bind9-host (1:9.6.ESV.R4+dfsg-0+lenny4) ...
Paramétrage de dnsutils (1:9.6.ESV.R4+dfsg-0+lenny4) ...
 

Hors ligne

#29 06-05-2022 19:01:20

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

pour sur le paquet n'existe pas avant la version suivante squeeze
Ce que tu peux tenter c'est de faire du pinning
https://debian-facile.org/doc:systeme:apt:pinning
un fichier préférence du genre

nano /etc/apt/preferences.d/squeeze


Package: *
Pin: release n=squeeze
Pin-priority: 90



ajouter les sources de squeeze et faire un apt update
https://wiki.debian.org/fr/DebianSqueeze

nano /etc/apt/sources.list.d/squeeze.list


deb http://archive.debian.org/debian squeeze main
deb http://archive.debian.org/debian squeeze-lts main
 


apt-update


bien vérifier que le dépôt squeeze a la bonne priorité (90) défini dans le fichier préférences

apt-cache policy


faire une install en simulation avec l'option -s

apt-get install -s libreadline6


et si cela te parait correct tu peux faire la commande sans l'option -s

Une autre solution serait de faire une migration vers squeeze mais cela risque de faire pas mal de paquets a mettre à jour

edit : quel version disponible maintenant que les sources squeeze ont été ajouté? si sa se trouve il y a la version que tu veux installer

apt-get search mysql-client


Pour installer une version de squeeze il faut spécifier la branche car la priorité du dépôt est inférieur (fichier préférences)

apt-get install nom_du_paquet/squeeze

Dernière modification par Croutons (07-05-2022 08:38:08)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#30 09-05-2022 08:13:56

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Je vais tenter ta solution aujourd'hui.

Merci

Hors ligne

#31 09-05-2022 08:31:53

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Bonjour,

Le dossier Preferences.d n'existe pas, je l'ai créé et ensuite créé le fichier squeeze.

Quand je fais l'apt-cache policy, j'obtiens :

 apt-cache policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://archive.debian.org squeeze-lts/main Packages
     release v=6.0-lts,o=Debian,a=squeeze-lts,l=Debian,c=main
     origin archive.debian.org
 500 http://archive.debian.org squeeze/main Translation-fr
 500 http://archive.debian.org squeeze/main Packages
     release v=6.0.10,o=Debian,a=oldoldstable,l=Debian,c=main
     origin archive.debian.org
 500 http://archive.debian.org lenny/updates/non-free Packages
     release v=5.0,o=Debian,a=oldstable,l=Debian-Security,c=non-free
     origin archive.debian.org
 500 http://archive.debian.org lenny/updates/contrib Packages
     release v=5.0,o=Debian,a=oldstable,l=Debian-Security,c=contrib
     origin archive.debian.org
 500 http://archive.debian.org lenny/updates/main Packages
     release v=5.0,o=Debian,a=oldstable,l=Debian-Security,c=main
     origin archive.debian.org
 500 http://archive.debian.org lenny/non-free Packages
     release v=5.0.10,o=Debian,a=oldstable,l=Debian,c=non-free
     origin archive.debian.org
 500 http://archive.debian.org lenny/contrib Packages
     release v=5.0.10,o=Debian,a=oldstable,l=Debian,c=contrib
     origin archive.debian.org
 500 http://archive.debian.org lenny/main Translation-fr
 500 http://archive.debian.org lenny/main Packages
     release v=5.0.10,o=Debian,a=oldstable,l=Debian,c=main
     origin archive.debian.org
Paquets étiquetés :
 



Je n'ai pas l'impression que le fichier squeeze a été pris en compte ?

Merci

Hors ligne

#32 09-05-2022 08:48:42

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU]Dependances non trouvées

au vu de se que renvoie apt-cache policy se serait plutôt

nano /etc/apt/preferences.d/squeeze



Package: *
Pin: release a=squeeze-lts
Pin-priority: 90

Package: *
Pin: release v=6.0.10
Pin-priority: 90
 


je ne m’appuie pas sur a=oldoldstable car c'est volatile c'est en oldoldstable par que on a changé la date de la machine
d'ailleurs si  la date de resynchronise il faudra peut être arrêter le service histoire de pas être embeté

apt update


apt-cache policy


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#33 09-05-2022 17:15:01

EJIND
Membre
Inscription : 05-05-2022

Re : [RESOLU]Dependances non trouvées

Avec la 1ère config :

Package: *
Pin: release n=squeeze
Pin-priority: 90


j'ai bien les paquets mysql-server-5.1 et mysql-client-5.1. J'ai pu les installer. D'autres problèmes sont apparus mais cela ne concerne plus la gestion des paquets.

Merci à tous ceux qui ont répondu et en partculier à Croutons qui m'a bien aiguillé.

Hors ligne

Pied de page des forums