Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-07-2022 17:56:48

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Message disabled by BIOS au démarrage [Résolu]

Bonjour,

Depuis bien longtemps, au démarrage de mon portable (assez ancien, un HP EliteBook 2170p avec un ssd de 500GB, sur lequel il n'y a que Debian d'installé) j'ai le message au démarrage

[0.1838723 x86/cpu: UMX (outside TXT) disabled by BIOS

Après avoir affiché ce message, la mise en route s'arrête pendant environ une minute, puis reprend normalement.

Ce n'est pas très gênant, car à part cela mon portable (qui est mon seul ordinateur encore en état de marche) fonctionne très bien. Mais si c'est possible j'aimerais bien arranger cela. Comment faire ?

Cordialement,

C.-M. M.

Dernière modification par cmm (02-08-2022 13:41:49)

Hors ligne

#2 31-07-2022 20:16:29

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

Ce ne serait pas plutôt "VMX" ? Cela indique que la virtualisation est désactivée par le BIOS. Voir s'il y a une option pour l'activer dans les réglages du BIOS.
Je doute que ce message soit la cause de la pause d'une minute.

Dernière modification par raleur (31-07-2022 20:17:07)


Il vaut mieux montrer que raconter.

Hors ligne

#3 01-08-2022 08:08:11

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Merci. Oui, c'est bien VMX (les caractères sont si petits que j'avais mal lu). J'ai remarqué aussi que les chiffres qui précèdent changent à chaque démarrage. Je n'ai encore jamais osé modifier quoi que ce soit au BIOS.

Cordialement,

C.-M. M.

Hors ligne

#4 01-08-2022 09:20:54

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

cmm a écrit :

es chiffres qui précèdent changent à chaque démarrage


C'est le temps écoulé depuis le démarrage du noyau.

cmm a écrit :

Je n'ai encore jamais osé modifier quoi que ce soit au BIOS


Tu peux déjà regarder si tu trouves le réglage.


Il vaut mieux montrer que raconter.

Hors ligne

#5 01-08-2022 19:12:06

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Merci, je vais le faire. J'ai aussi une information nouvelle, car je pense que tu as raison en disant que ce message n'est pas la cause d'une pause d'une minute. Jusqu'à présent, je n'avais pas réussi à lire ce qui s'affiche lors de la reprise après cette pause, car cela se déroule très vite, et que je ne sais pas où on peut retrouver ces informations si elles sont enregistrées quelque part. Aussi je viens de photographier l'écran de mon ordinateur avec mon téléphone, au bon moment. Voici ce qu'on peut lire:

Gave up waiting for suspend/resume device
/dev/sda1: clean

Autrement dit "J'en ai marre d'attendre pour suspend, je laisse tomber et je reprends la main", si je comprends bien ce jargon anglo-informatique. Je me demande ce que veut dire "suspend" ?

/dev/sda1 est la partition primaire sur laquelle est installé /. /home  et swap sont sur deux partitions d'une partition étendue. 

Bien cordialement,

C.-M. M.

Hors ligne

#6 01-08-2022 20:35:28

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

"suspend" (to disk), c'est l'hibernation ou mise en veille profonde. L'initramfs recherche le swap enregistré pour la reprise (resume) afin de voir s'il contient une image d'hibernation.
Le swap enregistré dans l'initramfs pour la reprise de l'hibernation est normalement défini dans le fichier /etc/initramfs-tools/conf.d/resume. Si c'est une partition, elle est définie par son UUID. Il faut le comparer d'une part avec les swaps existants et actifs par exemple avec la commande

lsblk -f


En cas d'incohérence, il faut corriger dans le fichier resume (en root) puis reconstruire l'initramfs avec

update-initramfs -u


Le cas échéant, corriger aussi l'UUID du swap dans /etc/fstab.

Concernant le BIOS, si c'est le même que sur les modèles 2570p et 8470p, tu devrais trouver l'option avec F10 pour entrer dans les réglages, system configuration, device configurations, virtualization technology (VTx).


Il vaut mieux montrer que raconter.

Hors ligne

#7 02-08-2022 09:38:17

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Merci beaucoup pour ces informations et ces conseils, que je vais suivre!

J'ai regardé les options du BIOS, qu'on atteint effectivement grâce aux touches Escape puis F10 au démarrage. Je n'ai osé rien changer. Il y trois écrans, Fichiers, Sécurité et Configuration système avec sur chaque écran un assez grand nombre de liens qui ouvrent de nouveaux écrans. Je vais essayer de trouver VTx.

Encore merci!

Bien cordialement,

C.-M. M.

Hors ligne

#8 02-08-2022 10:05:24

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

Ton BIOS est réglé pour s'afficher en français. Il faut aller dans "configuration système" puis une rubrique qui doit s'appeler quelque chose comme "configuration périphériques".

Il vaut mieux montrer que raconter.

Hors ligne

#9 02-08-2022 13:35:36

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Cher Raleur, j'ai suivi tes recommandations à la lettre. Tout marche maintenant ! La commande

lsblk -f



affiche pour swap le même UUID que celui de /etc/fstab. J'ai ensuite tapé la commande

update-initramfs -u



ce qui a donné lieu à toutes sortes de lignes signalant que des firmwares pourraient manquer. Comme j'ai déjà vu ce genre de message sans que cela nuise au fonctionnement de mon ordinateur, je ne m'en suis pas inquiété. J'ai redémarré mon ordinateur, et appuyé sur la touche Escape puis sur F10 pour accéder au BIOS. Dans Configuration système --> configuration des périphériques, j'ai coché les cases "technologie de virtualisation" et "E-S dirigée de technologie de virtualisation". Puis j'ai enregistré ces modifications. Résultat: an démarrage je n'ai plus le message qui m'inquiétait et il n'y a plus de pause d'une minute lors du démarrage.

Non seulement çà marche mais en plus grâce à tes explications je crois que j'ai compris ce que j'ai fait!

Grand merci donc, et bonne journée,

C.-M. M.

Dernière modification par cmm (02-08-2022 13:39:14)

Hors ligne

#10 02-08-2022 19:37:36

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

cmm a écrit :

lsblk -f affiche pour swap le même UUID que celui de /etc/fstab


Et dans le fichier /etc/initramfs-tools/conf.d/resume ?

cmm a écrit :

je crois que j'ai compris ce que j'ai fait


C'est l'objectif principal.

cmm a écrit :

çà marche


Ce n'est qu'un effet secondaire.

Dernière modification par raleur (02-08-2022 20:10:39)


Il vaut mieux montrer que raconter.

Hors ligne

#11 03-08-2022 11:37:13

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Pardon, j'ai sauté une étape in indiquant ce que j'ai fait. J'ai d'abord regardé le fichier resume avec la commande

less /etc/initramfs-tool/conf.d/resume



J'ai constaté que l'UUID indiquée était différente de celle de swap dans /etc/fstab. J'ai alors édité ce fichier avec nano, en root, et remplacé l'UUID par celui indiqué dans /etc/fstab, avant de faire

update-initramfs -u



Maintenant il n'y a plus d'incohérence entre ces deux fichiers.

Bonne journée!

C.-M. M

Hors ligne

#12 03-08-2022 19:29:48

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

Le swap a donc été reformaté, ce qui a changé son UUID. Cela n'arrive pas tout seul. L'installateur de Debian le fait systématiquement lorsqu'il réutilise les espaces de swap existants, ce n'est probablement pas le seul. Y a-t-il eu une autre installation d'un système Linux sur cette machine ?

Il vaut mieux montrer que raconter.

Hors ligne

#13 04-08-2022 08:01:59

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : mate
Inscription : 23-09-2008
Site Web

Re : Message disabled by BIOS au démarrage [Résolu]

Oui, lorsque je l'ai acheté d'occasion il y avait windows, mais j'ai remplacé le disque dur d'origine par un ssd de 500 G sur lequel je n'ai mis que Debian (6 ou 7, je ne me souviens pas). Puis j'ai, plusieurs fois, refait entièrement l'installation (toujours en conservant /home intact sur une partition séparée) lorsque la mise à jour vers une  nouvelle version de Debian cafouillait (probablement à cause de mes maladresses). Et récemment, j'ai essayé de faire démarrer cet ordinateur à partir d'un disque externe contenant une copie de / faite avec rsync, sans succès d'ailleurs. J'ai fait cela pour essayer de comprendre pourquoi, de temps en temps, mon ordinateur se fige (la  flèche de la souris se balade toute seule sur l'écran, et toutes les commandes que j'essaie de taper au clavier sont totalement inopérantes). Je crois que ce phénomène, pas très fréquent heureusement, vient du fait que la partition /dev/sda1, qui contient la racine /, est trop pleine (plus de 85 %) alors  que celle qui contient /home a encore beaucoup de place. J'ai fait cet essai en prévision de la modification des partitions que je voudrais faire (agrandir la partition contenant / en déplaçant celles qui contiennent /home et swap). Cela explique pourquoi la partition de swap a été plusieurs fois reformatée.

Bonne journée, bien cordialement,

C.-M. M.

Hors ligne

#14 04-08-2022 10:42:08

raleur
Membre
Inscription : 03-10-2014

Re : Message disabled by BIOS au démarrage [Résolu]

cmm a écrit :

Je crois que ce phénomène, pas très fréquent heureusement, vient du fait que la partition /dev/sda1, qui contient la racine /, est trop pleine (plus de 85 %)


J'en doute. Ma partition racine de 6 Go est pleine à 95% et je n'ai jamais eu de blocage.


Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums