Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-04-2018 14:03:05

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stable Xfce
Noyau : Linux 4.19
Inscription : 30-09-2015

Quod Libet: avoir une version plus récente sous Stretch

Hello,

Juste pour signaler qu'il est possible d'avoir une version plus récente stable (4.0.2) ou instable de Quod Libet que sa version Stretch 3.7, via l'ajout d'un dépôt:

https://quodlibet.readthedocs.io/en/lat … tml#debian

Pas de différence notable à première vue sinon la traduction française intégrale dans les menus qui faisait défaut.

Très bon logiciel dont je ne peux plus me passer.

Edit à toto : Mis le dépôt plus lisible en utilisant la balise Autre code du forum.

Edit pour Toto: Nine, il ne s'agît que du lien vers la page du site wink

Dernière modification par zorzi (07-04-2018 07:25:30)


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Buster XFCE
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch XFCE

Hors ligne

#2 07-04-2018 00:20:22

David5647
Membre
Distrib. : Debian Bullseye/Sid
Noyau : 5.3.0-2-amd64
(G)UI : KDE/i3wm
Inscription : 27-08-2017

Re : Quod Libet: avoir une version plus récente sous Stretch

Salut,

Pfff, j'en ai mis du temps à le trouver ce petit lecteur, après en avoir testé des dizaines, je suis enfin satisfait (j'ai même commencé à codé un truc minimaliste en python^^)
J'ai trouvé peu de sites qui en parlent, il merite d'être plus connu :
    - interface simple et minimaliste (juste ma blibliothèque, tri par artiste/album possible)
    - et pourtant très configurable (le seul que j'ai trouvé qui permette le tri en "artiste de l'album")
    - gestion des tags des morceaux
    - codé en python, des tas de plugins
    - aucun problème de format jusqu'à présent (même mes morceaux lossless)

je n'ai pas trouvé à quelle version correspondait celle de stretch...
as tu vu d'autres différences notables?

Dernière modification par David5647 (07-04-2018 00:21:17)

Hors ligne

#3 07-04-2018 07:35:46

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stable Xfce
Noyau : Linux 4.19
Inscription : 30-09-2015

Re : Quod Libet: avoir une version plus récente sous Stretch

Salut,

En effet, c'est devenu mon lecteur musique de référence. Malgré l'apparence très spartiate de base, tout se configure assez vite et facilement. Le tag des morceaux est facile et intuitif, et la récupération des pochettes d'albums un vrai bonheur.

je n'ai pas trouvé à quelle version correspondait celle de stretch...



La version Stretch de Quod Libet est en 3.7.1-2:

https://packages.debian.org/stretch/quodlibet

Le développement est un peu plus détaillé ici:

https://quodlibet.readthedocs.io/en/lat … gelog.html

as tu vu d'autres différences notables?



Non, aucune autre pour le moment. Mais il faut dire que le logiciel marchait déjà impeccablement dans sa version 3.7. Seul la traduction française incomplète pêchait un peu.

EDIT: Ah si, il démarre enfin en plein écran. Avant et au démarrage, il ne démarrait que dans la zone de notification. C'était un peu agaçant.

Dernière modification par zorzi (07-04-2018 07:39:23)


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Buster XFCE
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch XFCE

Hors ligne

#4 07-04-2018 08:16:58

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Quod Libet: avoir une version plus récente sous Stretch

salut zorzi .

le lien que tu donnes est très intéressant .

https://quodlibet.readthedocs.io/en/lat … tml#debian

mais , il fait souvent référence à des dépôts ubuntu .

en ce sens , je ne lui fais pas  confiance .

pas envie de créer une frankendebian ! 

je préfère m'en tenir à la logithèque de debian .

et puis , si tout marche bien , pourquoi changer ?

merci quand mème , zorzi .

amicalement ,

alain .

nb: pour trouver la version de quod libet ,

tapes , en console et en user :

$ apt policy quodlibet


chez moi , ça donne :

quodlibet:
  Installé : 3.9.1-1.2
  Candidat : 3.9.1-1.2
 Table de version :
 *** 3.9.1-1.2 500
        500 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        500 http://ftp.fr.debian.org/debian testing/main i386 Packages
        100 http://ftp.fr.debian.org/debian unstable/main amd64 Packages
        100 http://ftp.fr.debian.org/debian unstable/main i386 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par Debian Alain (07-04-2018 08:21:00)


Grand Corps Malade - Inch' Allah ft. Reda Taliani

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#5 07-04-2018 09:17:52

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

On peut se faire un backport, faut juste regarder si c'est pas trop de travail avec plein de depends a rebuilder...
Sur cette page on y vois le DSC
https://lazka.github.io/ql-debian/stabl … et-stable/

Si un courageux veux s'y mettre, sinon je vous fais ça dans la journée, reste toujours où stocker les paquets et autres sources rebuildé ici, j'en parle :

https://debian-facile.org/viewtopic.php?id=21176
https://debian-facile.org/viewtopic.php?id=18540

A priori faut juste mutagen en 1.39, et le dsc est aussi proposé, donc je tente.

Dernière modification par seb95 (07-04-2018 09:28:23)

Hors ligne

#6 07-04-2018 10:05:52

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

Bon c'est fait mais maintenant comment les mettre a disposition? et pour info pas besoin de mutagen > 1.39

Dernière modification par seb95 (07-04-2018 10:08:03)

Hors ligne

#7 07-04-2018 10:07:39

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stable Xfce
Noyau : Linux 4.19
Inscription : 30-09-2015

Re : Quod Libet: avoir une version plus récente sous Stretch

mais , il fait souvent référence à des dépôts ubuntu .

en ce sens , je ne lui fais pas  confiance .



Hello,

Je comprends ta réticence, mais non, il ne s'agît pas d'un ppa type ubuntu, malgré les occurrences du terme ubuntu (peut-être rapport au serveur partagé).

D'ailleurs, sur la page en question, on voit bien la distinction entre la méthode d'installation pour ubuntu au moyen d'un ppa véritable, et celle pour Debian via un dépôt spécifique.

Ce n'est pas comme si on nous encourageait à utiliser le ppa pour ubuntu sous Debian (ce qui là, oui, est une vraie pratique à déconseiller)

Pas de risque a priori.

Et merci à Seb95 pour la proposition.


Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, DD 500 Go) / Debian Buster XFCE
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, DD 40 Go) / Debian Stretch XFCE

Hors ligne

#8 07-04-2018 10:09:04

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

Je peux aussi vous donner ma methode debian pour faire des paquets, si ça dit a quelques uns wink

Hors ligne

#9 07-04-2018 10:20:15

Debian Alain
Adhérent(e)
Distrib. : stable / ubuntu / testing
Noyau : Linux 5.4.0-2 amd 64
(G)UI : Gnome wayland / Gdm3
Inscription : 11-03-2017

Re : Quod Libet: avoir une version plus récente sous Stretch

par curiosité , je dirai bien oui .
si personne d'autre que moi ne réponds , envoie moi ça en MP.

merci seb95.

Dernière modification par Debian Alain (07-04-2018 10:27:32)


Grand Corps Malade - Inch' Allah ft. Reda Taliani

RYZEN7 1700X - PRIME X370 PRO - 2 x 8 GB DDR4 - RADEON RX 550 4GB - CORSAIR RM750X - SSD crucial MX500 500GB M.2

Hors ligne

#10 07-04-2018 10:27:45

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Quod Libet: avoir une version plus récente sous Stretch

seb95 a écrit :

Je peux aussi vous donner ma methode debian pour faire des paquets, si ça dit a quelques uns


Puisque tu es membre df, tu peux la mettre dans une page perso et ainsi elle sera répertoriée dans le wiki.

Les pages persos sont là :
https://debian-facile.org/utilisateurs:utilisateurs smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 07-04-2018 10:30:12

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

C'est dispo  sur mon espace tuxfamily, mais je sais pas si c'est pour du long terme normalement on n'a pas le droit de le faire wink
Faut trouver autre chose pour stoker nos paquets ;p
https://download.tuxfamily.org/passionl … n_paquets/

Hors ligne

#12 07-04-2018 10:30:33

bendia
Chadministrateur
Distrib. : Buster, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

seb95 a écrit :

Bon c'est fait mais maintenant comment les mettre a disposition?

Un paquet, c'est une simple archive non ? Dans quelle mesure ne t'es-t-il pas possible de la proposer en téléchargement sur ton site ?

Édit : postes croisés, j'ai ma réponse au dessus tongue

Rien n'empêche ensuite de créer une page du wiki recensant les liens vers les différents paquets sans que ça soit pour autant un dépôt ?


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#13 07-04-2018 10:32:25

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

smolski a écrit :

seb95 a écrit :

Je peux aussi vous donner ma methode debian pour faire des paquets, si ça dit a quelques uns


Puisque tu es membre df, tu peux la mettre dans une page perso et ainsi elle sera répertoriée dans le wiki.

Les pages persos sont là :
https://debian-facile.org/utilisateurs:utilisateurs smile



Coucou smolski, oui je vais pas tarder a en faire une mais c'est cradoc ma manière d'expliquer, faudra repasser derriere wink

Hors ligne

#14 07-04-2018 10:33:34

bendia
Chadministrateur
Distrib. : Buster, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

Il y a déjà un tuto la dessus dans le wiki, dans la section Mentorat je crois.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#15 07-04-2018 10:35:15

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

bendia a écrit :

seb95 a écrit :

Bon c'est fait mais maintenant comment les mettre a disposition?

Un paquet, c'est une simple archive non ? Dans quelle mesure ne t'es-t-il pas possible de la proposer en téléchargement sur ton site ?

Édit : postes croisés, j'ai ma réponse au dessus tongue

Rien n'empêche ensuite de créer une page du wiki recensant les liens vers les différents paquets sans que ça soit pour autant un dépôt ?



Et puis il y a aussi des gros paquets comme 0ad 0.22... là c'est carrément pas possible de les stocker sur mon site ou espace...

Hors ligne

#16 07-04-2018 10:37:46

smolski
admin quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports (buster) 10
Noyau : 4.9.65-3+deb9u2 4.19.0-6-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : Quod Libet: avoir une version plus récente sous Stretch

@seb95 T'inkièt', on repassera derrière pour éclairer...
L'essentiel est que des tutos se partagent, en plus de servir de pense-bête perso. smile

S'il y a des doublons, on fera avec. wink

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#17 07-04-2018 10:38:33

bendia
Chadministrateur
Distrib. : Buster, Stretch
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console et un peu Openbox
Inscription : 20-03-2012
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

seb95 a écrit :

Et puis il y a aussi des gros paquets comme 0ad 0.22... là c'est carrément pas possible de les stocker sur mon site ou espace...

là, comme je le dis sur ton autre fil, c'est pas forcément évident dans l'immédiat sur DF non plus hmm


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.

En ligne

#18 07-04-2018 10:48:56

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

bendia a écrit :

seb95 a écrit :

Et puis il y a aussi des gros paquets comme 0ad 0.22... là c'est carrément pas possible de les stocker sur mon site ou espace...

là, comme je le dis sur ton autre fil, c'est pas forcément évident dans l'immédiat sur DF non plus hmm



Oui oui smolki m'en a parlé sur un autre post wink

Hors ligne

#19 07-04-2018 22:14:11

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

arghhh, j'avais pas vu les nom des paquets pourries, quodlibet_4.0.2-0~ppa0~quodlibet~bpo9+1_all.deb et exfalso_4.0.2-0~ppa0~quodlibet~bpo9+1_all.deb , faudra que je les refasse pour virer "~ppa0~quodlibet".

Hors ligne

#20 08-04-2018 06:56:25

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Quod Libet: avoir une version plus récente sous Stretch

bendia a écrit :

Il y a déjà un tuto la dessus dans le wiki, dans la section Mentorat je crois.


Bonjour smile
Voir cette page du wiki https://debian-facile.org/doc:mentors:mentors
Et plus particulièrement celle sur le rétroportage https://debian-facile.org/doc:mentors:retroportage

Ta méthode est différente ? Ou il y a des points à préciser peut-être ?


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#21 08-04-2018 21:01:39

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

Coucou Chalu, Merci pour tes liens, j'en ai un qui m’intéresse fortement et qui pourtant m'était connu...

Ta méthode est différente ? Où il y a des points à préciser peut-être ?


En faite très peu, j'utilise dget pour télécharger des sources depuis ubuntu pour controler et le fabriquer par la suite, en gros dget télécharge le fichier .dsc, qui va a son tour permettre de télécharger le origin.tar et le debian.tar.

par exemple pour ghostwriter :

dget https://launchpad.net/~wereturtle/+archive/ubuntu/ppa/+files/ghostwriter_1.6.0-0ppa1~xenial1.dsc



Tiens je vois que une nouvelle version est dispo smile je vais devoir la faire smile

Ensuite je n'utilise pas l'option -i de la commande dch:

dch -i


ghostwriter (1.5.0-1~bpo9+2) UNRELEASED; urgency=medium

  *

 -- Sebastien CHAVAUX <sebastien@debiacerlinux.schavfr>  Sun, 08 Apr 2018 21:53:23 +0200

ghostwriter (1.5.0-1~bpo9+1) stretch-backports; urgency=medium

  [ Sebastien CHAVAUX ]
  * Rebuild for stretch-backports



Mais dch -r qui donne en faite une non modification de la version qui m'interesse plus (+) puisque je fais principalement des backport et donc je veux garder la numérotation.

dch -r


ghostwriter (1.5.0-1~bpo9+1) stretch-backports; urgency=medium

  [ Sebastien CHAVAUX ]
  * Rebuild for stretch-backports

  [ wereturtle ]
  * New upstream release.

 -- Sebastien CHAVAUX <sebastien@debiacerlinux.schavfr>  Sun, 08 Apr 2018 21:55:35 +0200
 



ensuite c'est debuild pour fabriquer le paquet ou les paquets, si je ne veux pas de la signature c'est avec l'option -uc.

Voila.

Hors ligne

#22 09-04-2018 07:01:01

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Quod Libet: avoir une version plus récente sous Stretch

raconté ainsi ça fait tout simple wink ça doit dépendre des dépendances non ?

Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#23 09-04-2018 12:12:49

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : Quod Libet: avoir une version plus récente sous Stretch

En faite je ne parle que de la difference avec la methode cité dans la doc, sinon ce que je ne cite pas c'est que c'est a 100% pareil.
Pour les dépendances, si c'est un paquet venant de SID pareil que la methode debian-facile mais si ça vient de ubuntu, je fais cette commande:

apt-get build-dep /home/login/paquet/fichier-ou-se-trouve-le-dsc



Apres je ne fais que du backport, mais parfois ça demande de retroporté trop de chose, comme mldonkey par exemple et là je ne vais pas plus loin car pas envie de me retrouver à faire tout un tas de paquets si ce n'est pas pour partager et le garder que pour moi...

Hors ligne

Pied de page des forums