Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-09-2020 10:32:26

JesusKS
Membre
Distrib. : MX Linux 18.3 basé sur Debian 9
Noyau : Linux 4.19.0-1-amd64
(G)UI : i3wm
Inscription : 30-08-2016

Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Bonjour à tous,

J'ai un problème avec Virtualbox  sur ma MX Linux 18.3 (Debian 9). L'installation ne veut démarrer aucune VM.

J'ai deux boîtes de dialogues qui apparaîsse :

La première boîte de dialogue qui dit :

Échec de l'ouverture de session pour la machine virtuelle WP.

The virtual machine 'WP' has terminated unexpectedly during startup with exit code 1 (0x1).

Code d'erreur : NS_ERROR_FAILURE (0x80004005)
Composant : MachineWrap
Interface : IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}




Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.



J'ai fais tellement de manip sur le terminal suite à mes lectures sur le net, réinstaller, utiliser la version du dépôt, celles du site virtualbox (notamment la 6.0.14) etc.

Je n'arrive à rien faire...

Merci pour votre aide, s'il vous plaît.

P.-S. : J'ai installé à côté une MX19 toute fraîche et le problème était le même...

Hors ligne

#2 23-09-2020 10:38:16

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

salut JesusKS  smile  smile  smile

tu utilises quelle version ?

apt policy virtualbox


sudo dpkg -l | grep -iE virtualbox



aussi , tu as installé quels kernels  ?

sudo dpkg -l | grep -i -e "linux-image-|linux-headers-"


tu as quoi comme machine ?

sudo apt install inxi

installer l'utilitaire (tu ne risque rien)


inxi -Fr

et poste le retour

Dernière modification par Debian Alain (23-09-2020 10:47:54)

Hors ligne

#3 28-12-2020 16:25:55

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

J'ai le même problème, je suis intéressé par la suite de ton aide Alain ! Voila les retours de ces commandes :
Système

inxi -Fr



System:    Host: captp Kernel: 5.9.0-1-amd64 x86_64 bits: 64 Desktop: Cinnamon 4.8.3 Distro: Debian GNU/Linux bullseye/sid
Machine:   Type: Desktop System: HP product: 550-157nf v: 1.04 serial: <superuser required>
           Mobo: HP model: 2B47 v: 1.04 serial: <superuser required> UEFI: AMI v: A0.12 date: 11/10/2015
CPU:       Info: Quad Core model: Intel Core i5-6400 bits: 64 type: MCP L2 cache: 6 MiB
           Speed: 826 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 826 2: 810 3: 811 4: 812
Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] driver: amdgpu v: kernel
           Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.39.0 5.9.0-1-amd64 LLVM 11.0.0) v: 4.6 Mesa 20.2.6
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel
           Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] driver: snd_hda_intel
           Sound Server: ALSA v: k5.9.0-1-amd64
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
           IF: wlan0 state: down mac: d2:1f:36:01:2a:e3
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: eth0 state: down mac: c0:7c:d1:a0:49:04
           Device-3: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
           IF: wlp4s0 state: up mac: 18:a6:f7:d1:9f:5d
Drives:    Local Storage: total: 931.51 GiB used: 436.35 GiB (46.8%)
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-60M2NA0 size: 931.51 GiB
Partition: ID-1: / size: 18.98 GiB used: 14.4 GiB (75.9%) fs: ext4 dev: /dev/sda5
           ID-2: /boot/efi size: 356 MiB used: 77.7 MiB (21.8%) fs: vfat dev: /dev/sda1
           ID-3: /home size: 18.21 GiB used: 13.33 GiB (73.2%) fs: ext4 dev: /dev/sda4
Swap:      ID-1: swap-1 type: partition size: 4.66 GiB used: 0 KiB (0.0%) dev: /dev/sda3
Sensors:   System Temperatures: cpu: 25.0 C mobo: N/A gpu: amdgpu temp: 32.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1113
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
           2: deb http://security.debian.org/ stable/updates main contrib non-free
           3: deb http://ftp.fr.debian.org/debian/ stable-updates main non-free contrib
           4: deb http://www.deb-multimedia.org jessie main non-free
           5: deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
           6: deb http://download.virtualbox.org/virtualbox/debian buster contrib
           7: deb https://dl.winehq.org/wine-builds/debian/ buster main
           8: deb-src https://dl.winehq.org/wine-builds/debian/ buster main
           Active apt repos in: /etc/apt/sources.list.d/dropbox.list
           1: deb [arch=i386,amd64] http://linux.dropbox.com/debian sid main
           Active apt repos in: /etc/apt/sources.list.d/spotify.list
           1: deb http://repository.spotify.com stable non-free
Info:      Processes: 256 Uptime: 1h 08m Memory: 15.58 GiB used: 3.67 GiB (23.6%) Shell: Bash inxi: 3.2.01
 



Version Virtualbox

apt policy virtualbox



virtualbox:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :



 dpkg -l | grep -i virtualbox



rc  virtualbox-5.2                        5.2.34-133893~Ubuntu~bionic          amd64        Oracle VM VirtualBox
ii  virtualbox-6.1                        6.1.16-140961~Debian~buster          amd64        Oracle VM VirtualBox
 



Version kernel image

dpkg -l | grep -i -e "linux-image-*"



ii  linux-image-4.19.0-1-amd64            4.19.12-1                            amd64        Linux 4.19 for 64-bit PCs (signed)
ii  linux-image-5.9.0-1-amd64             5.9.1-1                              amd64        Linux 5.9 for 64-bit PCs (signed)
 



Version kernel headers

dpkg -l | grep -i -e "linux-headers-*"



ii  linux-headers-4.19.0-1-amd64          4.19.12-1                            amd64        Header files for Linux 4.19.0-1-amd64
ii  linux-headers-4.19.0-1-common         4.19.12-1                            all          Common header files for Linux 4.19.0-1
ii  linux-headers-5.8.0-2-amd64           5.8.10-1                             amd64        Header files for Linux 5.8.0-2-amd64
ii  linux-headers-5.8.0-2-common          5.8.10-1                             all          Common header files for Linux 5.8.0-2
ii  linux-headers-5.9.0-1-amd64           5.9.1-1                              amd64        Header files for Linux 5.9.0-1-amd64
ii  linux-headers-5.9.0-1-common          5.9.1-1                              all          Common header files for Linux 5.9.0-1
ii  linux-headers-5.9.0-5-686-pae:i386    5.9.15-1                             i386         Header files for Linux 5.9.0-5-686-pae
ii  linux-headers-5.9.0-5-amd64           5.9.15-1                             amd64        Header files for Linux 5.9.0-5-amd64
ii  linux-headers-5.9.0-5-common          5.9.15-1                             all          Common header files for Linux 5.9.0-5
ii  linux-headers-686-pae:i386            5.9.15-1                             i386         Header files for Linux 686-pae configuration (meta-package)
ii  linux-headers-amd64                   5.9.15-1                             amd64        Header files for Linux amd64 configuration (meta-package)
 



Est ce que ça aide ? Merci d'avance !

Hors ligne

#4 28-12-2020 17:05:25

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

a supprimé

Dernière modification par Croutons (28-12-2020 20:19:13)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#5 28-12-2020 18:13:07

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Salut,

Ben je suis pas sur sid en théorie (même si ça apparaît dans le inxi effectivement...) voila mes sources de dépot :


# stable
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
# deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free

# stable security
deb http://security.debian.org/ stable/updates main contrib non-free
# deb-src http://security.debian.org/ stable/updates main contrib non-free

# stable volatile
deb http://ftp.fr.debian.org/debian/ stable-updates main non-free contrib
# deb-src http://ftp.fr.debian.org/debian/ stable-updates main non-free contrib

# stable multimedia
deb http://www.deb-multimedia.org stable main non-free
# deb-src http://www.deb-multimedia.org main non-free

################################################
# testing
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free

# Virtualbox
#deb http://download.virtualbox.org/virtualbox/debian buster contrib
 



Y'avait rien dans les dépôts debian, c'est pour ça que j'avais rajouté ceux de virtualbox. J'ai viré le secureboot, ce qui a réglé le problème dans certains cas (vu que les paquets des dépôts virtualbox sont pas signés) mais pas pour moi...

Hors ligne

#6 28-12-2020 19:59:27

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

bonsoir Breunz   smile smile smile

il est généralement déconseillé de squatter le fil d'un autre .

tu aurai peut être gagné à ouvrir ton propre fil .

bon , c'est pas grave mais si tout le monde  se mélange les pinceaux , sois pas étonné .

pour ta distribution , que donne :

apt policy



si tout est bien réglé , tu dois trouver les dépôts testing à une priorité de 100 .

si non , il y a des chances que ta distribution soit devenue hybride : mi - buster , mi - testing .

il te faudra donc  faire un choix :

- soit rester sur buster et donc , downgrader ta distribution .
( en n'oubliant pas , cette fois , de mettre un fichier  "preferences" dûment configuré )
débian n'est pas conçue pour ça et je sais pas  faire .

- soit upgrader à testing / sid
( ce qui semble déjà être le cas )

curiosité : que donne

lsb_release -a



les dépôts virtualbox se trouvent dans  "sid"  ou , comme tu sembles l'avoir fait , sur le site de  "oracle" ( archives  *.deb pour stable de préférence )

Dernière modification par Debian Alain (28-12-2020 20:14:05)

Hors ligne

#7 28-12-2020 20:18:38

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Salut,

Tu as tout à fait raison et je m'en excuse, mais je me suis dit qu'après 3 mois sans réponse, JesusKS avait soit renoncé à réglé son problème soit trouvé une solution. Voila pourquoi je me suis incrusté ici, de façon un peu unilatérale...

Pour te répondre :

apt policy


Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 900 http://repository.spotify.com stable/non-free i386 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=i386
     origin repository.spotify.com
 900 http://repository.spotify.com stable/non-free amd64 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=amd64
     origin repository.spotify.com
 500 http://linux.dropbox.com/debian sid/main amd64 Packages
     release o=Dropbox.com,a=sid,n=sid,l=Dropbox Debian Repository,c=main,b=amd64
     origin linux.dropbox.com
 500 http://linux.dropbox.com/debian sid/main i386 Packages
     release o=Dropbox.com,a=sid,n=sid,l=Dropbox Debian Repository,c=main,b=i386
     origin linux.dropbox.com
 900 http://ftp.fr.debian.org/debian testing/non-free i386 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian testing/non-free amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian testing/contrib i386 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian testing/contrib amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian testing/main i386 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian testing/main amd64 Packages
     release o=Debian,a=testing,n=bullseye,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 900 http://www.deb-multimedia.org stable/non-free i386 Packages
     release v=10.7,o=Unofficial Multimedia Packages,a=stable,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin www.deb-multimedia.org
 900 http://www.deb-multimedia.org stable/non-free amd64 Packages
     release v=10.7,o=Unofficial Multimedia Packages,a=stable,n=buster,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin www.deb-multimedia.org
 900 http://www.deb-multimedia.org stable/main i386 Packages
     release v=10.7,o=Unofficial Multimedia Packages,a=stable,n=buster,l=Unofficial Multimedia Packages,c=main,b=i386
     origin www.deb-multimedia.org
 900 http://www.deb-multimedia.org stable/main amd64 Packages
     release v=10.7,o=Unofficial Multimedia Packages,a=stable,n=buster,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin www.deb-multimedia.org
 500 http://ftp.fr.debian.org/debian stable-updates/non-free i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian stable-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian stable-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian stable-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 900 http://security.debian.org stable/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 900 http://security.debian.org stable/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 900 http://security.debian.org stable/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 900 http://security.debian.org stable/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 900 http://ftp.fr.debian.org/debian stable/non-free i386 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian stable/non-free amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian stable/contrib i386 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian stable/contrib amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian stable/main i386 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 900 http://ftp.fr.debian.org/debian stable/main amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin ftp.fr.debian.org
 



et

lsb_release -a


No LSB modules are available.
Distributor ID: Debian
Description:  Debian GNU/Linux bullseye/sid
Release:  testing
Codename: bullseye



J'ai obtenu l'erreur en question (celle du premier message du fil) après avoir pris l'archive .deb sur le site d'oracle, effectivement, et la version pour buster (stable donc)

Dernière modification par Breunz (28-12-2020 20:19:25)

Hors ligne

#8 28-12-2020 20:49:56

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-3-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

ben , je garantis pas  avoir la  science "infuse" comme on dit , mais , si tu regarde bien , c'est clairement précisé : debian 10 , donc buster stable et non bullseye  (debian 11 testing / sid) .

https://www.virtualbox.org/wiki/Linux_Downloads

pas étonnant que çà coince un peu .

comme le nom de la distribution l'indique : bullseye (testing) / sid .

mais je vois que tu connais déjà les fichiers préférences . visiblement , tu as  déjà joué avec .

si tu tenais à rester sous stable , tu aurai dû régler les priorités de testing à 100 et non à 900 , comme tu l'as  fait .

regarde : https://debian-facile.org/doc:systeme:apt:pinning?s

990 ≤ P < 1000 : le paquet sera installé sauf si une version plus récente est déjà installée.

500 ≤ P < 990 : le paquet ne sera installé qu'à défaut de version plus récente installée ou disponible dans la distribution cible.

100 ≤ P < 500 : le paquet ne sera installé que s'il n'en existe aucune version plus récente, installée ou disponible dans une autre branche.
 



en mettant les priorités de testing à 900 , tu as passé cette distribution en "prioritaire" et donc , tranquilou , tu as  upgradé ta distribution .

en mettant les priorités de testing à 100 , tu n'aurai installé les paquets de  testing uniquement qu'en faisant ceci :

apt install -t testing <paquet>



ce qui est déjà un peu plus sécure .

ce qui reste à faire :

désinstaller l'ancien paquet de virtualbox (oracle)

mettre les dépôts de "sid" dans tes sources.

régler les préférences de "sid" à 100

retirer ou plutôt commenter le dépôt de virtualbox

et installer le nouveau (sid)

apt install -t sid virtualbox



et tests

Dernière modification par Debian Alain (28-12-2020 21:52:51)

Hors ligne

#9 29-12-2020 08:53:44

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Oui, je voulais dire que j'avais pris la version "buster" de Virtualbox, alors que je viens de me rendre compte que ma distrib est plutôt testing.

J'ai installé les dépôts de sid et tenté d'installer, mais il y a une erreur liée à la version du noyau que j'utilise.

apt install -t sid virtualbox


loading new virtualbox-6.1.16 DKMS files...
Building for 5.9.0-1-amd64
Building initial module for 5.9.0-1-amd64
Error! Bad return status for module build on kernel: 5.9.0-1-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/6.1.16/build/make.log for more information.
 



Le fichier make.log contient le retour suivant :

more /var/lib/dkms/virtualbox/6.1.16/build/make.log



DKMS make.log for virtualbox-6.1.16 for kernel 5.9.0-1-amd64 (x86_64)
mar. 29 déc. 2020 08:47:59 CET
make : on entre dans le répertoire « /usr/src/linux-headers-5.9.0-1-amd64 »

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.

make[1]: *** [/usr/src/linux-headers-5.9.0-1-common/Makefile:718 : include/config/auto.conf] Erreur 1
make: *** [/usr/src/linux-headers-5.9.0-1-common/Makefile:185 : __sub-make] Erreur 2
make : on quitte le répertoire « /usr/src/linux-headers-5.9.0-1-amd64 »



J'hésite à poursuivre car je maitrise pas trop, je voudrais pas tout casser...

Hors ligne

#10 29-12-2020 10:17:49

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Hello
c'est pas le bon noyau qui correspond a testing ou je me trompe?
ça donne quoi

uname -a



que renvoie

apt policy linux-headers-amd64 linux-image-amd64

Dernière modification par Croutons (29-12-2020 10:26:37)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#11 29-12-2020 10:31:42

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Hello,

Je pensai que le noyau 4.19 correspondait à buster et 5.9 à testing.

uname -a


Linux captp 5.9.0-1-amd64 #1 SMP Debian 5.9.1-1 (2020-10-17) x86_64 GNU/Linux
 



et

apt policy linux-headers-amd64 linux-image-amd64



linux-headers-amd64:
  Installé : 5.9.15-1
  Candidat : 5.9.15-1
 Table de version :
 *** 5.9.15-1 900
        900 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     4.19+105+deb10u8 900
        900 http://ftp.fr.debian.org/debian stable/main amd64 Packages
     4.19+105+deb10u7 900
        900 http://security.debian.org stable/updates/main amd64 Packages
linux-image-amd64:
  Installé : (aucun)
  Candidat : 5.9.15-1
 Table de version :
     5.9.15-1 900
        900 http://ftp.fr.debian.org/debian testing/main amd64 Packages
        100 http://ftp.fr.debian.org/debian sid/main amd64 Packages
     4.19+105+deb10u8 900
        900 http://ftp.fr.debian.org/debian stable/main amd64 Packages
     4.19+105+deb10u7 900
        900 http://security.debian.org stable/updates/main amd64 Packages
 

Hors ligne

#12 29-12-2020 11:05:32

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

oui mais il semblerait que tu soit resté bloqué et que les mises à jour des noyaux ne se fasse plus
install le meta paquet

apt install linux-image-amd64


après redémarrage tu devrais être sur la dernière version disponible du noyau

après cela Virtualbox devrait mieux ce comporter et pouvoir construire ses modules
le script Virtualbox devrait toujours être d'actualité, ce qui évite de réinstaller virtualbox

/sbin/vboxconfig

Dernière modification par Croutons (29-12-2020 11:30:12)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#13 29-12-2020 11:25:59

Breunz
Membre
Distrib. : stable / testing
Noyau : Linux 5.9.0-1-amd64
(G)UI : Cinnamon 4.8.3-3
Inscription : 28-12-2020

Re : Virtualbox ne fonctionne pas (rc=-1908) [MX Linux 18.3]

Suite aux manips que tu proposais Croutons, Virtualbox remarche.
Merci beaucoup pour votre aide à tous ! smile

Dernière modification par Breunz (29-12-2020 11:36:01)

Hors ligne

Pied de page des forums