Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-01-2021 12:32:17

Riton60
Membre
Inscription : 23-01-2021

Plantage au démarrage après installation [Résolu]

Bonjour, Je voudrais me mettre à debian. J'ai donc récupéré un vieux PC qui fonctionnait sous Windows et j'ai installé Debian

Le PC
Acer avec un intel core i3
carte graphique Radeon

j'ai téléchargé et installé en mode graphique : debian10.7.0 amd64 netinst.iso
A part la parttion Home, j'ai répondu OK à toutes les questions lors de l'installation.

tout c'est semble t-il bien passé, sauf qu'au redémarrage, cela s’arrêtait à un écran noir avec le message du type ==> Ne trouve pas le ROOT.

J'ai réinstallé Debian sur un autre disque au cas ou ==> Même problème

J'ai téléchargé : boot-repair-disk-64

Et il a eu semble t-il une "réparation", car maintenant au lancement il me charge tout les services, mais a un moment il s'arrête et plus rien ne se passe.

J'ai tenté un démarrage en recorvery, avec le mot de passe du "super utilisateur", j'arrive bien à la console, dans le root sauf que la je ne sais pas quoi faire; J'ai juste fait un "ls", mais le dossier "root" est vide.

Auriez vous une idée.

Merci par avance

Dernière modification par Riton60 (27-01-2021 08:41:21)

Hors ligne

#2 23-01-2021 13:03:16

raleur
Membre
Inscription : 03-10-2014

Re : Plantage au démarrage après installation [Résolu]

Riton60 a écrit :

au redémarrage, cela s’arrêtait à un écran noir avec le message du type ==> Ne trouve pas le ROOT.


Il aurait fallu conserver le message d'erreur exact et complet ainsi que les messages précédents.
En utilisant boot-repair tu as détruit les indices et tu n'auras rien appris si le problème se présente à nouveau.

Riton60 a écrit :

maintenant au lancement il me charge tout les services, mais a un moment il s'arrête et plus rien ne se passe.


Il faut probablement installer le paquet firmware-amd-graphics de la section non-free pour le GPU Radeon.

Dernière modification par raleur (23-01-2021 13:08:47)


Il vaut mieux montrer que raconter.

En ligne

#3 23-01-2021 16:31:37

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Bonjour,
Je vais tenter d'installer ce paquet. je vous tiens au courant

merci

Hors ligne

#4 23-01-2021 17:03:40

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

J'ai contourné le problème en enlevant la carte vidéo radeon Hd 7470.

Maintenant cela démarre effectivement, donc le problème vient de la carte. Y a t-il une solution ?

je suis vraiment novice, j'aimerai comprendre ce que je fais.

Merci par avance

Hors ligne

#5 23-01-2021 18:15:01

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Plantage au démarrage après installation [Résolu]

Il faut installer le pilote graphique qui correspond à ta carte comme te le dit @raleur


apt install firmware-amd-graphics

Dernière modification par cyrille (23-01-2021 18:15:19)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."
== Ainsi parlait Zarathoustra. ==
=== Nietzsche ===

Hors ligne

#6 23-01-2021 18:40:37

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Merci pour cette réponse.

Je teste cela demain matin

Bonne soirée

Hors ligne

#7 23-01-2021 20:50:10

raleur
Membre
Inscription : 03-10-2014

Re : Plantage au démarrage après installation [Résolu]

cyrille a écrit :

Il faut installer le pilote graphique qui correspond à ta carte comme te le dit @raleur


Ce n'est pas un pilote, c'est un ensemble de firmwares (microcodes).


Il vaut mieux montrer que raconter.

En ligne

#8 24-01-2021 10:48:08

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Bonjour,

Les problèmes se cumulent, lorsque j'ai tenté l'installation j'ai eu le message d'erreur suivant :

    -ne parvient pas à résoudre "tfp.fr.debian.org"

j'ai donc tenté un ifconfig mais il n'a pas la commande, donc je suis passé à  : ip addr

sa réponse :

1: lo <LOOPBACK, UP ,LOWER_UP< mtu 65536 qdisc noqueue state UNKNOW group default qlen 1000
    link/loopback 00:00:00:00:00:00: brd 00:00:00:00:00:00:
    inet 127.0.0.1/8 scop host lo
         valid_lft forever preferred_lft forever
    inet6 ::1/128 scophost
         valid foreve preferred_lft forever
2: eno1: <BROADCAST, MULTICAST> mtu 1500 qdisk noop state DOWN group default qlen 1000
        in/ether ec:a8:6b:d0:4a:61 brd ff:ff:ff:ff:ff:ff

Je précise que le PC est bien connecté

Merci par avance

Hors ligne

#9 24-01-2021 11:39:30

raleur
Membre
Inscription : 03-10-2014

Re : Plantage au démarrage après installation [Résolu]

1) C'est "ftp", pas "tfp".
2) Ne pas oublier d'ajouter la section non-free dans les sources le cas échéant.
3) Si le réseau n'est pas démarré en mode recovery, il faut le démarrer manuellement, selon le gestionnaire utilisé :

systemctl start networking
systemctl start network-manager
systemctl start wicd


Ou alors simplement pour configurer en DHCP

dhclient eno1


Il vaut mieux montrer que raconter.

En ligne

#10 24-01-2021 12:19:09

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Merci beaucoup

Cela change de Windows !!!!, on a vraiment l'impression d'être acteur c'est cool. Bon ceci étant acteur mais mauvais acteur !

J'arrive bien a me connecter, j'ai fais la mise à jour mais par contre le paquet "firmware-amd-graphics" il ne connait pas.

Il me dit de chercher ailleurs, mais ailleurs ou, ailleurs comment ?

En tout cas encore une fois merci

Hors ligne

#11 24-01-2021 12:21:34

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Plantage au démarrage après installation [Résolu]

que te donne :

 find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;


Cette commande va lister l'ensemble de tes sources.list


On verra si c'est bien configurer pour les depots non free car ce paquet en est un

apt show  firmware-amd-graphics
Package: firmware-amd-graphics
Version: 20201218-2
Priority: optional
Section: non-free/kernel




@raleur : autant pour moi ce n'est pas un driver mais un microcode, j'aurais du faire attention à bien appeler un chat un chat wink

Dernière modification par cyrille (24-01-2021 12:24:10)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."
== Ainsi parlait Zarathoustra. ==
=== Nietzsche ===

Hors ligne

#12 24-01-2021 12:39:33

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Je l'ai contrôlé plusieurs fois il ne semble pas que j'ai fait d'erreur de frappe, voilà la reponse:

-: -c: ligne 0: fin de fichier (EOF) prématurée lors de la recherche du caractère   "  correspondant
-: -c: ligne 1: erreur de syntaxe : fin de fichier prématurée

Hors ligne

#13 24-01-2021 12:50:32

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Je viens de retaper la ligne, j'avais interverti un "l" et le "1"

cela me donne maintenant juste :

>

Hors ligne

#14 24-01-2021 12:53:03

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

encore un truc je suis no pas en user mais en "root"

comment puis je me mettre en "user" si cela à une importance, puisque je ne peux pas démarrer normalement ?

Je dois quitter mon PC pour aujourd'hui. Je ne pourrai  me replonger sur ce problème que Mardi matin

Merci encore et Bon Dimanche

Dernière modification par Riton60 (24-01-2021 13:02:52)

Hors ligne

#15 24-01-2021 13:06:32

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Plantage au démarrage après installation [Résolu]

Donne nous surtout le retour de

 find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;




Copie dans un message ce que le terminal te renvoie


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."
== Ainsi parlait Zarathoustra. ==
=== Nietzsche ===

Hors ligne

#16 24-01-2021 15:44:23

raleur
Membre
Inscription : 03-10-2014

Re : Plantage au démarrage après installation [Résolu]

Riton60 a écrit :

cela me donne maintenant juste :

>


Tu as dû faire une faute de frappe, un guillemet simple ou double manquant ou en trop. Ctrl+c pour abandonner.

Le résultat de la commande est sympa mais elle est trop compliquée, le risque de faute de frappe est trop grand. Plus simple :

cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*

Dernière modification par raleur (24-01-2021 15:44:51)


Il vaut mieux montrer que raconter.

En ligne

#17 26-01-2021 18:02:26

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Bonjour voici ce que les commandes demandées m'ont données:

/eric@PC-Linux:~$ find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list
     1    #
     2   
     3    # deb cdrom:[Debian GNU/Linux 10.7.0 _Buster_ - Official amd64 NETINST 20201205-11:16]/ buster main
     4   
     5    #deb cdrom:[Debian GNU/Linux 10.7.0 _Buster_ - Official amd64 NETINST 20201205-11:16]/ buster main
     6   
     7    deb http://ftp.fr.debian.org/debian/ buster main
     8    deb-src http://ftp.fr.debian.org/debian/ buster main
     9   
    10    deb http://security.debian.org/debian-security buster/updates main
    11    deb-src http://security.debian.org/debian-security buster/updates main
    12   
    13    # buster-updates, previously known as 'volatile'
    14    deb http://ftp.fr.debian.org/debian/ buster-updates main
    15    deb-src http://ftp.fr.debian.org/debian/ buster-updates main
    16   
    17    # This system was installed using small removable media
    18    # (e.g. netinst, live or single CD). The matching "deb cdrom"
    19    # entries were disabled at the end of the installation process.
    20    # For information about how to configure apt package sources,
    21    # see the sources.list(5) manual.
eric@PC-Linux:~$ apt show firmware-amd-graphics
Package: firmware-amd-graphics
State: pas un véritable paquet (virtuel)
N: Impossible de choisir une version candidate du paquet « firmware-amd-graphics » qui n'en n'a pas
N: Impossible de choisir les versions du paquet « firmware-amd-graphics » qui n'est qu'un paquet virtuel
N: Aucun paquet n'a été trouvé

Pour la deuxième:
eric@PC-Linux:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 10.7.0 _Buster_ - Official amd64 NETINST 20201205-11:16]/ buster main

#deb cdrom:[Debian GNU/Linux 10.7.0 _Buster_ - Official amd64 NETINST 20201205-11:16]/ buster main

deb http://ftp.fr.debian.org/debian/ buster main
deb-src http://ftp.fr.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main
deb-src http://security.debian.org/debian-security buster/updates main

# buster-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ buster-updates main
deb-src http://ftp.fr.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

merci par avance

Dernière modification par Riton60 (26-01-2021 18:14:54)

Hors ligne

#18 26-01-2021 18:36:46

raleur
Membre
Inscription : 03-10-2014

Re : Plantage au démarrage après installation [Résolu]

raleur a écrit :

2) Ne pas oublier d'ajouter la section non-free dans les sources le cas échéant.


Il faut éditer /etc/apt/sources.list pour ajouter "non-free"  à la suite de "main" et exécuter "apt-get update" pour mettre à jour la liste des paquets. Ensuite firmware-amd-graphics devrait être disponible.


Il vaut mieux montrer que raconter.

En ligne

#19 26-01-2021 18:55:40

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Plantage au démarrage après installation [Résolu]

Pour éditer ton sources.list, en root

nano /etc/apt/sources.list




Tu apportes les modifications, puis ctr + o , entrée pour le sauvegarder et ctl + x pour le quitter


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."
== Ainsi parlait Zarathoustra. ==
=== Nietzsche ===

Hors ligne

#20 26-01-2021 19:03:02

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Plantage au démarrage après installation [Résolu]

Riton60 Voir le tuto : Trop cool d'indiquer son installation dans son profil !

Et pour Buster : https://debian-facile.org/doc:system:ap … ist:buster

Dernière modification par Jean-Pierre Pinson (26-01-2021 19:08:55)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#21 26-01-2021 19:10:41

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Excuses moi juste à la suite de quel "main", il est a la fin de chaque ligne ?

Hors ligne

#22 26-01-2021 19:15:37

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : sid / bullseye (future stable)
Noyau : Linux -5.10.0-7-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Plantage au démarrage après installation [Résolu]

ton sources.list  doit ressembler à ceci , Riton60 :

nano /etc/apt/sources.list


# Debian Buster, dépôt principal + paquets non libres
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free
 
# Debian Buster, mises à jour de sécurité + paquets non libres
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free
 
# Debian Buster, mises à jour "volatiles" + paquets non libres
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free
 



amicalement ,

alain.

coyotus.png

Dernière modification par Debian Alain (26-01-2021 19:16:19)

En ligne

#23 26-01-2021 19:16:07

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Plantage au démarrage après installation [Résolu]

je t'ai mis un lien, Tu as juste à faire un copier coller du sources.list

Dernière modification par Jean-Pierre Pinson (26-01-2021 19:16:33)


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#24 26-01-2021 19:22:10

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Cela à fonctionné !!!!

Merci à tous pour votre aide

Hors ligne

#25 26-01-2021 19:25:14

Riton60
Membre
Inscription : 23-01-2021

Re : Plantage au démarrage après installation [Résolu]

Dernière question Bête comment indique t-on que le problème est résolu ?

Hors ligne

Pied de page des forums