Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-03-2021 10:30:24

Sandman
Membre
Inscription : 16-02-2021

Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Bonjour,

J'ai installé debian et windows 10 en dual boot. Juste après l'installation, J'avais le choix entre debian et windows avec le 1er choix qui se lance par défaut mais depuis quelques temps windows se lance automatiquement sans me laisser le choix entre les deux. J'ai essayé de changer les paramètres dans le bios, mais dès que je redémarre windows se remet en 1er et annule, mais changement. J'ai essayé les commandes de cette question https://debian-facile.org/viewtopic.php?id=23272 mais pareil dès que je redémarre tout s'annule. Si vous avez des idées je suis preneur.



HP 15-G201NF
AMD A8-6410 (Quad-Core 2 GHz) - 1To - 4Go - Ecran 15.6 pouces HD
Kernel: Linux 4.19.0-13-amd64

Hors ligne

#2 16-03-2021 15:08:14

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Bonjour,
il semblerait que le GRUB ait été remplacé par Windows Boot Manager.
Regarde cet article si ça peut solutionner ton souci:
https://lecrabeinfo.net/reparer-restaur … -plus.html

Dernière modification par Herve33 (16-03-2021 15:09:28)


Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#3 20-03-2021 03:48:23

Sandman
Membre
Inscription : 16-02-2021

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Je reste bloquer avec le même problème. Dès que je redémarre les modifications sur l'ordre de boot sont annulés et redémarre à nouveau sur windows et non debian.

Hors ligne

#4 20-03-2021 09:51:23

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Tu as désactivé le Fast-Boot sur Window$ ?
https://lecrabeinfo.net/desactiver-dema … ws-10.html

Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#5 20-03-2021 14:15:48

Sandman
Membre
Inscription : 16-02-2021

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

J'ai réussi à changer le démarrage rapide qui n'apparaissait pas dans le bios, J'ai refais la commande bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi. J'ai redémarré et encore windows qui se démarre en premier.
J'ai vérifié le démarrage rapide est toujours désactivé, j'ai changer l'ordre dans le bios à nouveau pour mettre debian en 1er, redémarrage toujours windows qui démarre.

papa@papa-pc:~$ efibootmgr -v
BootCurrent: 0002
Timeout: 5 seconds
BootOrder: 0000,3000,0002,2001,2002,2003
Boot0000* Windows Boot Manager  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Windows Boot Manager  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...I................
Boot0002* debian  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\debian\shimx64.efi)
Boot2001* USB Drive (UEFI)  RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)  RC
Boot3000* Internal Hard Disk or Solid State Disk  RC
Boot3001* Internal Hard Disk or Solid State Disk  RC
Boot3002* Internal Hard Disk or Solid State Disk  RC
 




Je crois comprendre que je dois supprimer dans windows un des boots manager je pense le 0001 puis redémarrer en debian changer l'ordre du boot puis redémarrer à nouveau pour vérifier.

Hors ligne

#6 20-03-2021 18:13:41

raleur
Membre
Inscription : 03-10-2014

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Ne pas confondre l'option "fast boot" du BIOS et l'option "démarrage rapide" (fast startup) de Windows qui n'ont rien à voir l'une avec l'autre.

Sandman a écrit :

J'ai refais la commande bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi


Si le secure boot est activé dans le BIOS, c'est plutôt \EFI\debian\shimx64.efi qu'il faut mettre, comme dans l'entrée "debian".

Sandman a écrit :

Je crois comprendre que je dois supprimer dans windows un des boots manager je pense le 0001


C'est plutôt l'entrée 0000 qui lance le chargeur de Windows et qui est en premier dans BootOrder qu'il faudrait supprimer. Et 0001 aussi puisqu'elle n'est pas référencée dans BootOrder.


Il vaut mieux montrer que raconter.

Hors ligne

#7 22-03-2021 17:07:19

Sandman
Membre
Inscription : 16-02-2021

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

papa@papa-pc:~$ efibootmgr -v
BootCurrent: 0002
Timeout: 5 seconds
BootOrder: 0000,3000,0002,2001,2002,2003
Boot0000* Windows Boot Manager  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Windows Boot Manager  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\debian\shimx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...I................
Boot0002* debian  HD(2,GPT,dde5cb74-8db2-4aa9-9343-3e64272c65b6,0x145800,0x82000)/File(\EFI\debian\shimx64.efi)
Boot2001* USB Drive (UEFI)  RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)  RC
Boot3000* Internal Hard Disk or Solid State Disk  RC
Boot3001* Internal Hard Disk or Solid State Disk  RC
Boot3002* Internal Hard Disk or Solid State Disk  RC




Je n'ai pas vu d'option fastboot dans le bios mais j'ai désactivé le démarrage rapide dans windows avec les instructions de herve33.
Sous debian, j'ai cet ordre de boot. Je dois donc supprimer 0000 et 3000 pour avoir grub en 1er choix.
Sous windows, je devrais exécuter dans un cmd.exe en administrateur en remplaçant identifiant par ceux correspondant:
bcdedit /delete {xxxidentifiant_0000xxx}
bcdedit /delete {xxxidentifiant_3000xxx}

Je ne comprend pas à quoi corresponde les 3 Internal Hard Disk or Solid State Disk RC (3000,3001,3002).
J'ai un seul dd partitionner en deux avec une partition windows et une pour debian.

Si vous avez des suggestions, es ce que vous pouvez me dire quelles commandes utiliser exactement parce que je m'y perds un peu.

Hors ligne

#8 23-03-2021 21:43:57

raleur
Membre
Inscription : 03-10-2014

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

Sandman a écrit :

Sous debian, j'ai cet ordre de boot. Je dois donc supprimer 0000 et 3000 pour avoir grub en 1er choix.


Pourquoi ne pas plutôt changer le BootOrder avec efibootmgr en ne mettant que 0002 par exemple ?

efibootmgr --bootorder 0002


Sinon, pour supprimer l'entrée 0000 :

efibootmgr --bootnum 0000 --delete-bootnum


Sandman a écrit :

Je ne comprend pas à quoi corresponde les 3 Internal Hard Disk or Solid State Disk RC (3000,3001,3002).
J'ai un seul dd partitionner en deux avec une partition windows et une pour debian.


Il y a longtemps que j'ai renoncé à chercher la moindre logique dans la gestion de l'amorçage par les firmwares UEFI.
Une seule partition système EFI ? Avec un disque qui en avait plusieurs, le firmware me générait une entrée de boot pour chacune.
Pas de lecteur de carte mémoire qui pourrait être traité comme un disque ?


Il vaut mieux montrer que raconter.

Hors ligne

#9 28-03-2021 08:37:32

Sandman
Membre
Inscription : 16-02-2021

Re : Dual-boot Windows 10 - Debian : démarre systématiquement sur Windows

J'ai essayé et vérifié le résultat des deux commandes mais au redémarrage.
Le boot ordre se remet comme avant windows ( bootmgfw.efi ) en 1er et debian après...

Hors ligne

Pied de page des forums