Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-07-2021 17:16:24

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Fenêtre intempestive "Firefox en navigateur par défaut"

Bonjour à tous,

A l'ouverture de Firefox j'ai très régulièrement la fenêtre me demandant si je souhaite faire de Firefox mon navigateur par défaut.

Je clique toujours sur oui en cochant la case "ne plus me demander" mais la fenêtre finit toujours par réapparaître pour une raison que je n'arrive pas à identifier scratchhead.gif

Je penchais pour un conflit entre deux versions de Firefox installées, mais d'après Synaptic je n'ai que le paquet firefox-78.12.0esr-1 (de plus je n'ai jamais installé Firefox hors dépôt officiel Debian donc je doute que ça vienne de là)

Dans les paramètres d'application par défaut de XFCE Firefox est indiqué comme étant défini par défaut, mais l'icône n'est pas correctement affichée (j'ai aussi le choix entre "Navigateur Sensible Debian" et "Vivaldi" mais ce dernier a été complètement désinstallé.

YXD68Oi.png

Auriez-vous des suggestions pour identifier l'origine du problème ?

Dernière modification par cihoa (10-08-2021 18:21:10)

Hors ligne

#2 28-07-2021 18:10:58

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Via la barre d’adresse de Firefox, rends-toi sur : about:preferences#general
Tu y trouveras les options permettant de régler ce comportement.

file-Rc5f38c37006a7541eba3b13ab01cbc9e

Jouer sous Debian ? Facile !

Hors ligne

#3 30-07-2021 04:36:44

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Bonjour vv222,

Je viens de me rendre sur l'onglet :

qtFGqxQ.png

Pour une raison que je n'arrive pas à expliquer le navigateur quand je clique sur des liens d'email depuis Thunderbird ou parfois seulement aprèsu n redémarrage il arrive que Firefox ne soit plus le navigateur par défaut (à moins que cela ne se produise après que je fasse un nettoyage avec Bleachbit mais j'ai du mal à voir le lien possible avec ça).

Hors ligne

#4 30-07-2021 09:26:00

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

cihoa a écrit :

à moins que cela ne se produise après que je fasse un nettoyage avec Bleachbit


À mon avis, c’est une hypothèse qui vaut le coup d’être testée wink


Jouer sous Debian ? Facile !

Hors ligne

#5 30-07-2021 20:45:25

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Hello
voit peut être ce que t'affiche

update-alternatives --get-selections



--get-selections
              Affiche tous les noms principaux d'alternatives (ceux qui contrôlent un groupe de liens) ainsi que leur état (depuis  la  version 1.15.0).  Chaque  ligne
              comporte  jusqu'à trois champs (séparés par une ou plusieurs espaces). Le premier est le nom de l'alternative, le second est son état (auto ou manual) et
              le dernier montre le choix actuel pour l'alternative (il s'agit d'un nom de fichier et donc peut contenir des espaces).



update-alternatives --get-selections |grep browser


gnome-www-browser              auto     /usr/bin/firefox-esr
infobrowser                    auto     /usr/bin/info
x-www-browser                  auto     /usr/bin/firefox-esr
 


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 31-07-2021 17:16:34

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Je viens de tester un nettoyage Bleachbit et le message n'est pas réapparu donc j'écarte pour le moment cette hypothèse cool

Par rapport à ta commande Croutons j'ai pratiquement la même chose que toi (merci pour la documentation wink )

update-alternatives --get-selections |grep browser


gnome-www-browser              auto     /usr/bin/firefox-esr
x-www-browser                  auto     /usr/bin/firefox-esr



Étant sur XFCE devrais-je ôter gnome-www-browser ?
Quelle est la différence avec x-www-browser ?

Hors ligne

#7 31-07-2021 18:04:16

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

cihoa a écrit :

Étant sur XFCE devrais-je ôter gnome-www-browser ?


Non, c’est un nom qui est automatiquement fourni par firefox-esr que tu sois ou non sur GNOME.

cihoa a écrit :

Quelle est la différence avec x-www-browser ?


À mon avis (qui est peut-être légèrement teinté de mesquinerie) les devs/mainteneurs de GNOME ont décidé qu’ils méritaient bien une option à part plutôt que de suivre x-www-browser comme la plèbe.


Jouer sous Debian ? Facile !

Hors ligne

#8 31-07-2021 18:23:12

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : Linux 5.13.10
(G)UI : openbox
Inscription : 26-08-2010

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Bonjour,
dans le post #3, je vois que l'option « Toujours vérifier que firefox est votre navigateur par défaut »
est coché. Je pense qu'il suffit de décocher cette option. Je ne sais pas trop ce que ça fait,
étant donné les multiples façons d'avoir une application par défaut (xdg-open, mailcap, alternatives)
mais ça doit être la chose à faire pour éviter qu'il pose la question à chaque démarrage de l'application.

Hors ligne

#9 31-07-2021 19:25:01

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.1
Noyau : 5.10.0-9-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

si dans le ficher /home/USER/.config/mimeapps.list (sur XFCE)
il est indiqué dans [Default Applications]

[Default Applications]
....
text/html=firefox-esr.desktop
x-scheme-handler/http=firefox-esr.desktop
x-scheme-handler/https=firefox-esr.desktop
...

Ne pas tenir compte du message sur des liens des mail depuis Thunderbird

Dernière modification par jce76350 (31-07-2021 21:07:41)


--
Jc E

Hors ligne

#10 31-07-2021 23:16:16

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

À mon avis (qui est peut-être légèrement teinté de mesquinerie) les devs/mainteneurs de GNOME ont décidé qu’ils méritaient bien une option à part plutôt que de suivre x-www-browser comme la plèbe.


Ahah pas mal lol

Bonjour,
dans le post #3, je vois que l'option « Toujours vérifier que firefox est votre navigateur par défaut »
est coché. Je pense qu'il suffit de décocher cette option. Je ne sais pas trop ce que ça fait,
étant donné les multiples façons d'avoir une application par défaut (xdg-open, mailcap, alternatives)
mais ça doit être la chose à faire pour éviter qu'il pose la question à chaque démarrage de l'application.



Effectivement mais sur la capture d'écran comme actuellement dans mes options cette case cochée est également grisée (verrouillée), je ne peux pas cliquer dessus. Dans tous les cas depuis quelques jours je n'ai plus la fenêtre donc j'imagine qu'il fallait que je passe par tous les scénarios probables (cliquer depuis un lien de mail, ouvrir un fichier html local, etc ...) pour aboutir au fait que "Firefox soit bien pris par défaut partout".

si dans le ficher /home/USER/.config/mimeapps.list (sur XFCE)
il est indiqué dans [Default Applications]

[Default Applications]
....
text/html=firefox-esr.desktop
x-scheme-handler/http=firefox-esr.desktop
x-scheme-handler/https=firefox-esr.desktop
...

Ne pas tenir compte du message sur des liens des mail depuis Thunderbird



J'ai vérifié le fichier en question et effectivement j'ai bien ces lignes donc je vais suivre ton conseil et ignorer les éventuelles fenêtres à venir.

Hors ligne

#11 06-08-2021 08:57:04

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

bonjour   smile  smile  smile

et pardon pour le dérangement .

je me trouve dans un cas analogue à cihoa .

sUGO4mcm.png

apt policy firefox-l10n-fr firefox*ESR chromium


firefox-l10n-fr:
  Installé : 88.0.1-1
  Candidat : 88.0.1-1
 Table de version :
     90.0-2 1
          1 https://deb.debian.org/debian experimental/main amd64 Packages
          1 https://deb.debian.org/debian experimental/main i386 Packages
 *** 88.0.1-1 500
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        500 https://deb.debian.org/debian unstable/main i386 Packages
        100 /var/lib/dpkg/status
firefox-esr:
  Installé : 78.12.0esr-1
  Candidat : 78.12.0esr-1
 Table de version :
 *** 78.12.0esr-1 500
        100 https://deb.debian.org/debian testing/main amd64 Packages
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     78.11.0esr-1~deb10u1 100
        100 http://deb.debian.org/debian stable/main amd64 Packages
chromium:
  Installé : 90.0.4430.212-1
  Candidat : 90.0.4430.212-1
 Table de version :
 *** 90.0.4430.212-1 500
        100 https://deb.debian.org/debian testing/main amd64 Packages
        500 https://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     89.0.4389.114-1~deb10u1 100
        100 http://deb.debian.org/debian stable/main amd64 Packages
 



update-alternatives --get-selections |grep browser


gnome-www-browser              auto     /usr/bin/firefox-esr
www-browser                    auto     /usr/bin/lynx
x-www-browser                  auto     /usr/bin/firefox-esr



dans firefox 88 :  nJ6naYOm.png

dans firefox 78 esr : IgSnTerm.png

dans chromium 90 :  UN95Xbym.png

je vais voir si çà continue ...

amicalement ,

alain.

coyotus.png

Dernière modification par Debian Alain (06-08-2021 09:00:48)

Hors ligne

#12 10-08-2021 18:26:21

cihoa
Membre
Distrib. : Debian 11 (bullseye)
Noyau : Linux 5.10.0-8
(G)UI : XFCE 4.16.12
Inscription : 09-09-2020

Re : Fenêtre intempestive "Firefox en navigateur par défaut"

Salut Debian Alain,

Personellement le problème est aussi revenu quelques jours plus tard, avec toujours les mêmes fenêtres.

J'ai remarqué que le problème survenait surtout lorsque je cliquais sur des liens présents dans les mails affichés par Thunderbird (parfois le clic n'ouvrait pas firefox mais indiquait dans l'angle gauche de Thunderbird "vous êtes déjà abonné à ce flux", ou sinon cela ouvrait firefox en proposant de le fixer comme navigateur par défaut).

Depuis j'ai réinstallé complètement Firefox avec export des marques-pages, suppression de l'ancien profil et réimport dans un profil tout neuf, puis j'ai complètement supprimmé Thunderbird.

Après cette manipulation plus aucun soucis de fenêtres, mais cela ne m'a pas permis d'expliquer précisément l'origine du problème.

Hors ligne

Pied de page des forums