Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-10-2021 18:52:20

ralain
Membre
Inscription : 20-10-2021

debian et scanner hp

bonjour
depuis que je suis passe sous debian 11 ,je n'arrive pas a utiliser mon scanner ; alors que précédement sur debian 10 je n'avais aucun soucis

-quand je lance xsane il voit le scanner et quand je valide le lancement j'ai ce message :
erreur d'ouverture de périphérique   "escl:http:127.0.0.1.6000  Dépassement de mémoire

-quand je lance simplescan il voit le périphérique :HP envy 5540 usb  et quand je fais numeriser j'ai ce message :
Echec de la numérisation   ,impossible de se connecter au périphérique de numérisation

voila j'ai cherché et je n'ai pas trouvé de solutions ,si quelqu'un veut bien m'aider je l'en remercie d'avance

Hors ligne

#2 21-10-2021 08:39:40

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Bonjour @ralain,

Comment as-tu installé ton imprimante? Est-elle branchée en USB ou bien en réseau? As-tu installé hp-lip (et utilisé ses pilotes)?

Navré de te poser ces questions, mais elles permettront de t'aider. En attendant ton retour, je te souhaite une belle journée smile

Hors ligne

#3 21-10-2021 09:15:40

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

Bonjour et merci de ton aide
L'imprimante est branchée en USB .Tout marchait sans soucis sous debian 10 .Depuis mon passage sous 11 ,l'impression est aléatoire et le scanner inopérant .J'avais bien installé HPlip .
J'ai ,au vu d'un autre post (quelqu'un qui rencontrait les mêmes problèmes que moi mais avec une autre imprimante),installé les dépôt backports et réinstaller hplip et un autre paquet .
Cela a marche sur l'imprimante vu avec une dénomination escHp.....mais pas avec HP
Mais c'est instable et non satisfaisant .
J'espère que j'ai été clair car j'écris de mon téléphone au travail et non devant l'ordinateur
Amicalement

Dernière modification par ralain (21-10-2021 09:22:14)

Hors ligne

#4 21-10-2021 18:27:04

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

bonjour
je n'arrive pas a afficher mes copies d'ecran ,j'y travaille et je reviens
desole

Dernière modification par ralain (21-10-2021 18:29:46)

Hors ligne

#5 22-10-2021 09:10:51

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Tu pourrais m'envoyer le retour de la commande

lsusb

s'il te plait ?

Hors ligne

#6 24-10-2021 11:46:04

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

bonjour et merci pour ton aide et désolé pour le retard de ma réponse
dans la console j'ai donc :
alain@debian:~$ lsusb
Bus 004 Device 003: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 03f0:ce11 HP, Inc ENVY 5540 series
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 046d:082b Logitech, Inc. Webcam C170
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


pour moi l'ordi voit l'imprimante mais c'est la gestion qui est tres bizarre ,par exemple
quand je demarre xsane et que je choisis parmi 3 propositions la seule qui marche  eSCL hp envy 5540
le scan marche bizzarement ;me dis occupé ,je valide puis demarre le scan
pour l'impression c'est aussi erratique ,c'est un peu quand ca veut
j'ai essaye de faire des copies d'ecran des messages mais je n'arrive pas a les mettre dans les messages
amicalement

Hors ligne

#7 24-10-2021 11:55:16

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : bookworm unstable sid / bullseye (stable)
Noyau : Linux -5.14.0-4-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

En ligne

#8 25-10-2021 11:11:30

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Bonjour @ralain,

En regardant sur le site d'HP, ton imprimante n'est plus maintenue par eux. Probablement la raison pour laquelle hplip ne fonctionne pas avec une version plus récente. Essaie d'installer une ancienne version, celle qui correspond à ton imprimante (3.15.9 d'après eux).

Lien vers le site d'HP : https://developers.hp.com/hp-linux-imag … ices/index
Lien vers HPLIP : https://sourceforge.net/projects/hplip/ … ip/3.15.9/

Pour l'installer, tu télécharges le fichier .run et tu exécutes les commandes suivantes :

sudo apt purge 'hplip*'


chmod +x /lien/vers/le/fichier/hplip.run && sudo ./lien/vers/le/fichier/hplip.run

Hors ligne

#9 25-10-2021 11:42:22

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : debian et scanner hp

Bonjour,

J'ai aussi de gros soucis avec le  paquet hplip. Dans des logs hplip fait référence a un paquet debian disparu de la dernière version stable.
hp-check fait clairement n'importe quoi, me réclame un tas de paquets déjà installés.

Dernière modification par nlancien (25-10-2021 11:43:06)

Hors ligne

#10 25-10-2021 11:44:36

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

c.f. ma réponse du dessus.

Hors ligne

#11 25-10-2021 19:04:09

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

merci hyrr0
je m'y suis mis ce soir ,je dois avouer etre un debutant pas trop fortiche .D'ou

-la commande sudo apt purge 'hplip*'  facile

-ensuite je vais dans mon dossier ou j'ai telecharge hplip3.15.9

-la commande chmod +x hplip-3.15.9.run  est bien passée

mais ensuite :

alain@debian:~$ sudo hplip-3.15.9.run
[sudo] Mot de passe de alain :
sudo: hplip-3.15.9.run : commande introuvable


desole je patine ....

Hors ligne

#12 25-10-2021 19:11:11

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : debian et scanner hp

sudo ./hplip-3.15.9.run


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

En ligne

#13 25-10-2021 19:45:52

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

desole

alain@debian:~$ sudo ./hplip-3.15.9.run
sudo: ./hplip-3.15.9.run : commande introuvable

Hors ligne

#14 25-10-2021 19:52:41

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

Ca se corse :j'ai reussi a passer la commande en tapant :sudo: ./hTAB
et cela donne cela 
alain@debian:~/Documents/linux/debian $ sudo ./hplip-3.15.9.run
[sudo] Mot de passe de alain :
Creating directory hplip-3.15.9
Verifying archive integrity... All good.
Uncompressing HPLIP 3.15.9 Self Extracting Archive..
./hplip-install: ligne 2: python : commande introuvable
./hplip-install: ligne 3: python : commande introuvable
./hplip-install: ligne 4 : [:  : nombre entier attendu comme expression
./hplip-install: ligne 10: python : commande introuvable
alain@debian:~/Documents/linux/debian $

Hors ligne

#15 26-10-2021 08:59:35

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : debian et scanner hp

De https://developers.hp.com/hp-linux-imag … g/gethplip
Je télécharge la dernière version


 08:44 XXXX@YYYY Téléchargements $ bash hplip-3.21.8.run
Creating directory hplip-3.21.8
Verifying archive integrity... All good.
Uncompressing HPLIP 3.21.8 Self Extracting Archive......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.21.8)
HPLIP Installer ver. 5.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Tue-26-Oct-2021_08:44:56.log

warning: debiangnu/linux distro is not found in AUTH_TYPES
\
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.
error: debian-11 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.9 version packages.

Press 'y' to continue auto installation. Press 'n' to quit auto instalation(y=yes, n=no*):


 



Super.......
error: debian-11 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.9 version packages.

https://developers.hp.com/hp-linux-imag … quirements

Python 2.2 or higher and python-devel (Python 2.3+ for fax support)

Hors ligne

#16 26-10-2021 09:26:35

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Essaie déjà d'installer toutes les dépendances de hplip avec cette commande :

sudo apt install adduser cups hplip-data libhpmud0 libsane-hpaio lsb-base printer-driver-hpcups python3-dbus python3-gi python3-pexpect python3-pil python3-reportlab wget xz-utils python3 python3 libc6 libcups2 libdbus-1-3 libpython3.9 libsane1



Si tu es curieux, j'ai obtenu ces paquets grâce à la commande

apt-cache depends hplip

puis j'ai isolé les paquets requis dans la commande que je te donne ci-dessus pour t'éviter de galérer.

Normalement, une fois la commande passée, tu devrais avoir tous les paquets requis. Essaie de relancer le script d'installation pour voir. Si ça bloque encore, on essaiera autre chose smile

Y'a quand même une chose à savoir : C'est que HP n'a jamais fait AUCUN effort pour Linux. Leur support est minimal. Souvent catastrophique. Chaque imprimante est une galère à installer et la tienne étant en plus assez vieille n'aide pas. Je trouve ça aberrant de leur part ... mais c'est comme ça. Business is business comme on dit ... bref, je vais essayer de t'aider comme je peux. On va trouver une solution smile

Hors ligne

#17 26-10-2021 10:32:20

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : debian et scanner hp

Merci de ton retour, j'avais installé hplip via apt-get, sans lui spécifier le --no-install-recommends.

10:18 XXXX@YYYY ~ $ dpkg -l adduser cups hplip-data libhpmud0 libsane-hpaio lsb-base printer-driver-hpcups python3-dbus python3-gi python3-pexpect python3-pil python3-reportlab wget xz-utils python3 python3 libc6 libcups2 libdbus-1-3 libpython3.9 libsane1
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                   Version            Architecture Description
+++-=====================-==================-============-=========================================================================
ii  adduser               3.118              all          add and remove users and groups
ii  cups                  2.3.3op2-3+deb11u1 amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  hplip-data            3.21.2+dfsg1-2     all          HP Linux Printing and Imaging - data files
ii  libc6:amd64           2.31-13+deb11u2    amd64        GNU C Library: Shared libraries
ii  libcups2:amd64        2.3.3op2-3+deb11u1 amd64        Common UNIX Printing System(tm) - Core library
ii  libdbus-1-3:amd64     1.12.20-2          amd64        simple interprocess messaging system (library)
ii  libhpmud0:amd64       3.21.2+dfsg1-2     amd64        HP Multi-Point Transport Driver (hpmud) run-time libraries
ii  libpython3.9:amd64    3.9.2-1            amd64        Shared Python runtime library (version 3.9)
ii  libsane-hpaio:amd64   3.21.2+dfsg1-2     amd64        HP SANE backend for multi-function peripherals
ii  libsane1:amd64        1.0.31-4.1         amd64        API library for scanners
ii  lsb-base              11.1.0             all          Linux Standard Base init script functionality
ii  printer-driver-hpcups 3.21.2+dfsg1-2     amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  python3               3.9.2-3            amd64        interactive high-level object-oriented language (default python3 version)
ii  python3-dbus          1.2.16-5           amd64        simple interprocess messaging system (Python 3 interface)
ii  python3-gi            3.38.0-2           amd64        Python 3 bindings for gobject-introspection libraries
ii  python3-pexpect       4.8.0-2            all          Python 3 module for automating interactive applications
ii  python3-pil:amd64     8.1.2+dfsg-0.3     amd64        Python Imaging Library (Python3)
ii  python3-reportlab     3.5.59-2           all          ReportLab library to create PDF documents using Python3
ii  wget                  1.21-1+b1          amd64        retrieves files from the web
ii  xz-utils              5.2.5-2            amd64        XZ-format compression utilities
 


L'install ne pose pas plus de soucis que ca.
Si je lance hp-doctor :


error: 'cups' package is missing or 'cups' service is not running.
error: 'libcups2' package is missing or 'cups' service is not running.
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libjpeg62-turbo-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing or 'cups' service is not running.
error: 'cups-bsd' package is missing or 'cups' service is not running.
error: 'cups-client' package is missing or 'cups' service is not running.
error: 'libcupsimage2' package is missing or 'cups' service is not running.
error: 'libcupsimage2-dev' package is missing or 'cups' service is not running.
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libavahi-client-dev' package is missing/incompatible
error: 'libavahi-core-dev' package is missing/incompatible
error: 'libavahi-common-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp' package is missing/incompatible
error: 'libssl-dev' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
Missing Optional Dependencies
-----------------------------
error: 'avahi-utils' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible
 



error: 'cups' package is missing or 'cups' service is not running ... Euh... localhost:631 répond. Si je tente une "impression" pdf via cups-pdf ca marche
python3-pyqt4 Pas dans les dépôts stables.... oldstable, oldoldstable, oui.

Dernière modification par nlancien (26-10-2021 10:32:56)

Hors ligne

#18 26-10-2021 12:02:47

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Y'a un truc que je ne comprends pas.. ces packages s'installent chez moi sur debian 11.

Tu as bien une debian 11? Les dépôts sont bien les bons? J'ai l'impression que tu as un souci à ce niveau là avant même d'avoir un souci avec HP à proprement parler.

Hors ligne

#19 26-10-2021 13:23:17

nlancien
Membre
Distrib. : Debian Stable
Noyau : Linux 4.19.0-12-amd64
(G)UI : Openbox
Inscription : 17-07-2019

Re : debian et scanner hp

Bonjour,
Les paquets s'installent bien, sur une stable sans fioritures stable main contrib non-free. Le seul qui ne s'installe pas est python3-pyqt4

root@YYYY:~# apt-get install python3-pyqt4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet python3-pyqt4 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « python3-pyqt4 » n'a pas de version susceptible d'être installée
 



cups est installé et fonctionne, par contre hp-doctor déconne, pour cups au moins. J'ai désactivé apparmor, si l'information peut être utile.

Hors ligne

#20 26-10-2021 14:01:30

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

pyqt4 c'est pour l'interface de hplip. Dans un premier temps, on n'en a pas besoin.. tu peux pas installer le .run sans pyqt4?

Hors ligne

#21 26-10-2021 18:29:59

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

bonjour je reviens sur le post qui ,je ne lui en veux absolument pas ,a ete emprunté par nlancien ,que je salue amicalement
pour rappel je vous avais quitter hier soir sur

alain@debian:~/Documents/linux/debian $ sudo ./hplip-3.15.9.run
[sudo] Mot de passe de alain :
Creating directory hplip-3.15.9
Verifying archive integrity... All good.
Uncompressing HPLIP 3.15.9 Self Extracting Archive..
./hplip-install: ligne 2: python : commande introuvable
./hplip-install: ligne 3: python : commande introuvable
./hplip-install: ligne 4 : [:  : nombre entier attendu comme expression
./hplip-install: ligne 10: python : commande introuvable
alain@debian:~/Documents/linux/debian $

j'ai installe par synaptic python -all 2.7.18.3
et quand je relance la commande j'ai :

alain@debian:~/Documents/linux/debian $ sudo ./hplip-3.15.9.run
[sudo] Mot de passe de alain :
Creating directory hplip-3.15.9
Verifying archive integrity... All good.
Uncompressing HPLIP 3.15.9 Self Extracting Archive...
./hplip-install: ligne 2: python : commande introuvable
./hplip-install: ligne 3: python : commande introuvable
./hplip-install: ligne 4 : [:  : nombre entier attendu comme expression
./hplip-install: ligne 10: python : commande introuvable
alain@debian:~/Documents/linux/debian $

j'avoue que j'ai besoin d'aide

Hors ligne

#22 27-10-2021 09:33:42

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

hyrr0 a écrit :

Essaie déjà d'installer toutes les dépendances de hplip avec cette commande :

sudo apt install adduser cups hplip-data libhpmud0 libsane-hpaio lsb-base printer-driver-hpcups python3-dbus python3-gi python3-pexpect python3-pil python3-reportlab wget xz-utils python3 python3 libc6 libcups2 libdbus-1-3 libpython3.9 libsane1



Si tu es curieux, j'ai obtenu ces paquets grâce à la commande

apt-cache depends hplip

puis j'ai isolé les paquets requis dans la commande que je te donne ci-dessus pour t'éviter de galérer.

Normalement, une fois la commande passée, tu devrais avoir tous les paquets requis. Essaie de relancer le script d'installation pour voir. Si ça bloque encore, on essaiera autre chose smile

Y'a quand même une chose à savoir : C'est que HP n'a jamais fait AUCUN effort pour Linux. Leur support est minimal. Souvent catastrophique. Chaque imprimante est une galère à installer et la tienne étant en plus assez vieille n'aide pas. Je trouve ça aberrant de leur part ... mais c'est comme ça. Business is business comme on dit ... bref, je vais essayer de t'aider comme je peux. On va trouver une solution smile



Je t'invite à essayer la première commande puis à relancer le script d'installation.

HPLIP utilise python3. Tu as installé python2 qui n'est plus maintenu depuis plusieurs années déjà. La chose étrange, c'est que Python3 est normalement installé par défaut avec Debian (et tous les systèmes unix)... tu l'as supprimé volontairement ou par mégarde?

A tout hasard, peux tu m'envoyer le résultat de la commande suivante avant et après l'exécution de la commande sus-citée stp ?

python --version

Dernière modification par hyrr0 (27-10-2021 09:35:23)

Hors ligne

#23 27-10-2021 18:24:36

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

bonjour et merci pour l'aide
je m'y suis remis ce soir et j'ai donc passer ta commande d'instal avec tous les paquets .tout est bien passé sans erreur .
quant au script d'installation :toujours la meme reponse dans la console (identique mon post ci dessus)
sur ta commande python cela donne :
lain@debian:~$ python --version
Command 'python' not found, did you mean:
  command 'python3' from deb python3
  command 'python' from deb python-is-python3


il est a note  que xsane remarche en choisissant : eSCL  HP ENVY 5540 ser ip=127.0.0.1 [airscan .............)parmi 3 choix possibles
l'impression marche en choisissant HP_ENVY_......-USB parmi 3 choix possibles

bon maintenant le scaner et l'imprimante marche ,mais cela semble un peu brouillon ,mais si tu n'as pas d'autres idées ca m'ira quand meme et merci

Hors ligne

#24 27-10-2021 18:26:25

ralain
Membre
Inscription : 20-10-2021

Re : debian et scanner hp

desole en me relisant j'ai eu une idée et j'ai tape ca dans la console :
alain@debian:~$ python --version
Command 'python' not found, did you mean:
  command 'python3' from deb python3
  command 'python' from deb python-is-python3
alain@debian:~$ python3 --version
Python 3.9.2

Hors ligne

#25 03-11-2021 10:14:57

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : debian et scanner hp

Désolé, j'étais en vacances et sans mon ordi !

Pour ton problème, tu as bien python d'installer mais le script cherche "python" et toi tu as que "python3". Il faut faire le lien entre python3 et python.. le plus simple pour ça, tu as un package Debian qui s'en occupe que tu peux installer :

sudo apt install python-is-python3



Ensuite tu devrais pouvoir réexécuter le script d'installation de hplip.

Hors ligne

Pied de page des forums