Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-02-2022 12:35:06

CptNemo
Membre
Inscription : 23-02-2022

Installation qui tourne à la galère

Bonjour à toutes et à tous,

J'ai le "malheur" de vouloir installer linux sur un "ancien" PC et distri après distri ça ne veut pas fonctionner.
Je tente ma chance sur Debian on va voir si j'ai plus de chance qu'avec Lubuntu...mais c'est très mal parti.

Voici tout d'abord ma config :
- Core2duo E7300 sur P5Q pro avec 2Go RAM DDR2. BIOS à jour.
- Carte graphique GT 430 de Nvidia
- Disque Sata de 150 Go

1) La config initialement fonctionnait bien sous Windows 7. Par contre plus de mises à jour et de suivi de Microsoft et ça commençait à ramer grave niveau surf par exemple. Je souhaite également tester l'univers linux que je ne connais pas.
2) J'ai testé également la mémoire plusieurs heures avec memtest et il n'y a pas de problème avec la RAM. Le hardware semble donc ok.

Mon objectif est d'installer des émulateurs (Mame, émulateurs C64 et Amiga pour en faire une station de rétro gaming) et de pouvoir un peu surfer sur le net. Bref rien d'exceptionnel pour cette config...

- En premier lieu j'ai voulu installer dessus Lubuntu 20.04 LTS, apparemment conseillé pour des vieux chars comme celui la. J'ai galéré au début avec un écran noir post boot du aux driver Nvidia. J'ai pu corriger le problème en recovery en installant le driver 390 propriétaire de Nvidia. Les émulateurs fonctionnaient à la perfection sur cette distri agréable à utiliser. Malheureusement niveau surf ça a été la douche froide !!! Peu importe le navigateurs, au bout d'un moment Lubuntu freezait et seul ALT+IMPR ECRAN +REISUB permettait de rebooter. Sur le forum d'Ubuntu des personnes ont essayé de m'aider https://forum.ubuntu-fr.org/viewtopic.php?id=2070316 mais ça n'a mené à rien. J'ai regardé aussi pas mal de forum US concernant ces problèmes de freezes sous ubuntu 20.04 LTS et dans beaucoup de cas personne ne trouvait de solution.

J'ai décidé de passer à une autre distri. On m'a conseillé Debian. Je vais passer sur mes tentatives foireuses avec Emmabuntu et vous demander de l'aide avec la dernière version Debian Facile amd64 que j'essaye de faire fonctionner.

En l'état, après une installation arrivée à son terme via une clé USB, l'écran de chargement de Debian apparaît un instant et devient noir ensuite (comme mes débuts sur Lubuntu).
Je me doute que c'est de nouveaux ces foutus drivers non free Nvidia qui foutent le bordel.
Avec Lubuntu 20.04 LTS en mode recovery j'avais accès à une interface graphique qui m'a permis d'installer le driver proprio 390 d'Nvidia. Ici sur Debian facile j'ai rien capté. Le mode recovery m'envoi direct en mode console (ce qu'on appel root ? je pense). A ma grande frayeur il va surement falloir tout faire à la main avec des commandes du diable qu'un néophyte comme moi ne maîtrise pas...de plus j'ai l'impression qu'en mode console recovery ma clé wifi n'est pas reconnu (ping passe pas alors que sous Lubuntu ça passait)). Sans le net c’est cuit pour les commandes...

Peut être connaissez vous un moyen d'aller quand même sur l'interface graphique en mode sans échec pour changer le driver avec une interface sans se fader ces commandes horribles pour des noob comme moi ? Le truc étrange c'est que la distri fonctionne parfaitement en mode LIVE. Il est donc possible de se passer de ces foutus drivers Nvidia pour accéder au bureau.

Bref dur dur linux pour les ptits nouveaux !

Merci d'avance pour votre aide.

Hors ligne

#2 23-02-2022 12:43:16

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Installation qui tourne à la galère

Bonjour, tu dois pouvoir accéder à la console tty en faisant: Ctrl + Alt + F3 affichera l’invite de connexion, il semblerait que c'est la carte graphique GT 430 de Nvidia qui pose problème,
Regarde ici à tout hasard: https://debian-facile.org/doc:materiel: … ia:accueil mais je ne garantie rien, car souvent les cartes de marque Nvidia récentes ont des problèmes pour fonctionner sous Linux

Dernière modification par Jean-Pierre Pinson (23-02-2022 12:50:37)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#3 23-02-2022 12:56:06

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

Oui j'avais déjà parcouru cette doc. La GT 430 c'est du très vieux matos quand même (2010).

Tu ne connais pas un moyen pour entrer dans l'interface graphique de Debian en mode dégradé ? Cela me simplifierais grandement la vie de pouvoir changer le driver avec l'interface au lieu de la console. J'avais pu le faire avec Lubuntu il doit bien avoir un moyen avec Debian ? Le Live de Debian fonctionne sans le driver Nvidia, on doit donc pouvoir trouver un moyen de forcer le mode graphique basic ?

Dernière modification par CptNemo (23-02-2022 12:58:38)

Hors ligne

#4 23-02-2022 13:37:08

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Installation qui tourne à la galère

Bjr,
Je ne connais pas les dernières images iso, mais c'est étonnant qu'un driver graphique ne soit pas installé si tu le demande. "Nouveau" prend, apparemment, ta carte en charge.
Quelle image iso a tu mis sur ta clé d'installation ?

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#5 23-02-2022 13:50:56

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

bonjour CptNemo  smile  smile  smile

tu es en console ?

si oui , essaies ceci :

systemctl status NetworkManager


et regarde si tu as du réseau (ligne "active")


si tu as du réseau , essaies ceci :

apt install nvidia-detect


pour l'installer , puis :


nvidia-detect


on verra , par exemple , si ta carte est prise en charge par un pilote propriétaire Nvidia
ou non et lequel.  
si non , faudra penser au projet "nouveau" (pilote debian) .


mais je connais très mal le support Nvidia .
je suis nettement plus AMD .

amicalement,

alain.

coyotus.png

NB: au fait , c'est un portable ou une tour ?

Dernière modification par Debian Alain (23-02-2022 13:52:51)

Hors ligne

#6 23-02-2022 13:55:17

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

C'est la dernière iso dispo sur le site https://debian-facile.org/viewtopic.php?id=30872. Dans le grub au début j'ai le choix entre : démarrage normal --> écran noir ou options avancées avec recovery mode qui m'amène à la console textuelle. Ma clé wifi n'a pas l'air de fonctionner dans ce mode alors pour les lignes de commande ça va pas le faire sad . Avec le recovery de Lubuntu et la même clé wifi le réseau était prit en charge...ça m'énerve.

Par contre comme expliqué, avec ma carte graphique une "bête" GT 430 même sur Lubuntu 20.04 LTS c'était écran noir direct après la première installation.
Seulement sur Lubuntu j'ai pu démarrer à partir du grub dans un mode graphique dégradé et changer de driver dans le gestionnaire dédié (Nvidia 390). Je comprends pas pourquoi sur Debian on n'arrive pas en mode graphique"dégradé" avec le recovery (je ne connais rien en Linux) pour corriger le problème. Si seulement des distri existaient avec du contenus non free de base on se ferait beaucoup moins chier...

Dernière modification par CptNemo (23-02-2022 13:57:09)

Hors ligne

#7 23-02-2022 14:05:52

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

@Debian Alain.
Merci pour ton aide. En ce moment je suis au boulot sur mon temps de pause wink . Je vais voir ce soir et mettre les mains dans le cambouis ; je sens qu'on ne peut pas y couper avec Linux. J'utilise les OS Windows depuis 20 ans et j'ai jamais eu autant de problèmes au niveau de l'installation...ça fera surement bondir les amateurs du pingouin mais pour un novice le choc est rude par rapport à la facilité d'accès "standardisée" des produits Microsoft. Vaste débat...

Hors ligne

#8 23-02-2022 14:13:33

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

CptNemo ,  big_smile  big_smile  big_smile

Debian procède parfois à une mise à jour de ses noyaux .

il arrive que certains supports très anciens soient retirés .

bien sûr , ceux qui en ont besoin se retrouvent alors dans les ennuis .

et la solution est un peu ardue à trouver .

çà arrive .

j'espère que l'on pourra te dépanner.

amicalement ,

alain.

coyotus.png

note : la DF-linux essaie , autant que faire ce peut , de garder la compatibilité avec le vieux matériel .
mais des fois , c' est pas possible .
bonne chance .

Dernière modification par Debian Alain (23-02-2022 14:13:56)

Hors ligne

#9 23-02-2022 14:30:06

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

Merci Alain.
Mise à part les freeze sur internet avec Lubuntu 20.04, elle fonctionnait super bien sous Linux cette config.
Après je ne sais pas si Debian est très différent dans sa gestion des driver graphiques par rapport à Lubuntu ?
On va voir dès que j'aurais accès à la console...

Hors ligne

#10 23-02-2022 15:09:08

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : Installation qui tourne à la galère

CptNemo a écrit :

@Debian Alain.
Merci pour ton aide. En ce moment je suis au boulot sur mon temps de pause wink . Je vais voir ce soir et mettre les mains dans le cambouis ; je sens qu'on ne peut pas y couper avec Linux. J'utilise les OS Windows depuis 20 ans et j'ai jamais eu autant de problèmes au niveau de l'installation...ça fera surement bondir les amateurs du pingouin mais pour un novice le choc est rude par rapport à la facilité d'accès "standardisée" des produits Microsoft. Vaste débat...


en complément du post de Debian Alain : il faudra au préalable modifier ton fichier sources.list pour y ajouter les dépôts non-free car ils n'y sont pas d'origine.
Tu trouveras le modèle à copier ici dans la partie sources.list non libre : https://debian-facile.org/doc:systeme:a … -non-libre

Hors ligne

#11 23-02-2022 17:15:30

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

bartaba a écrit :

CptNemo a écrit :

@Debian Alain.
Merci pour ton aide. En ce moment je suis au boulot sur mon temps de pause wink . Je vais voir ce soir et mettre les mains dans le cambouis ; je sens qu'on ne peut pas y couper avec Linux. J'utilise les OS Windows depuis 20 ans et j'ai jamais eu autant de problèmes au niveau de l'installation...ça fera surement bondir les amateurs du pingouin mais pour un novice le choc est rude par rapport à la facilité d'accès "standardisée" des produits Microsoft. Vaste débat...


en complément du post de Debian Alain : il faudra au préalable modifier ton fichier sources.list pour y ajouter les dépôts non-free car ils n'y sont pas d'origine.
Tu trouveras le modèle à copier ici dans la partie sources.list non libre : https://debian-facile.org/doc:systeme:a … -non-libre




Merci Bartaba ! Mais comment éditer le fichier sources.list en mode console ?

Ce qui me scie le fessier c'est que ces quelques lignes pourraient être proposées via un menu + disclamer  au moment de l'installation de Linux.
Quel gain de temps se serait pour toute la communauté.

Hors ligne

#12 23-02-2022 17:21:24

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

big_smile  big_smile  big_smile

regarde si çà peut pas t'aider , CptNemo  :

https://debian-facile.org/doc:systeme:a … t-non-free

amicalement ,

alain .

coyotus.png

p.s.: pour ta carte graphique , tu gagnerai plus à te procurer une AMD RX 5xx .
elles commencent à être vieilles et difficiles à trouver  sur le net mais ,
elles ont l'énorme avantage d'être beaucoup plus compatibles avec linux que Nvidia .
en plus , elles ne sont pas encore complètement passées .
elles peuvent  toujours fournir un service très intéressant .
bien sûr , faudra voir aussi le  chapitre de l'alimentation .
en fonction de ta carte , faudra pas  prendre n'importe quoi .

Dernière modification par Debian Alain (23-02-2022 17:52:56)

Hors ligne

#13 23-02-2022 18:01:10

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Installation qui tourne à la galère

Vous êtes surs qu'il faut aller changer le sources.list ? Extrait d'ici : https://debian-facile.org/projets:iso-debian-facile

Le choix est également fait d'inclure des paquets Debian non-libres afin d'avoir une reconnaissance optimale du matériel.


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#14 23-02-2022 18:12:18

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

big_smile  big_smile  big_smile

que donne : ?

cat /etc/apt/sources.list


poste le retour



amicalement ,

alain .

coyotus.png

Hors ligne

#15 23-02-2022 18:19:59

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Installation qui tourne à la galère

Tu devrais le savoir il est sur une iso DF

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#16 23-02-2022 18:43:38

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

big_smile  big_smile  big_smile

je viens d'installer une iso D F en  v.m.

j'ai regardé les  dépôts .

il n'y a rien à faire .

si ta carte graphique n'est pas reconnue ,
c'est qu'il y a de grandes chances  qu'elle soit trop vieille .

tourne toi vers une AMD RX 5xx , tu as plus de chances de la voir fonctionner .
en plus , AMD fait généralement de gros efforts (pas pour tout)
pour assurer la  compatibilité de son matériel avec linux .
ce qui n'est souvent pas le cas pour Nvidia .

amicalement ,

alain .

coyotus.png

Dernière modification par Debian Alain (23-02-2022 18:44:54)

Hors ligne

#17 23-02-2022 19:18:50

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Installation qui tourne à la galère

J'ai une N7600 GS et "nouveau" la reconnait. Pour CptNemo c'est le chip GF108.
Il doit avoir eu un problème à l'install.

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#18 23-02-2022 21:15:58

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

phlinux a écrit :

J'ai une N7600 GS et "nouveau" la reconnait. Pour CptNemo c'est le chip GF108.
Il doit avoir eu un problème à l'install.



Je pense aussi que tout n'est pas perdu pour la GT 430. Comment expliquer que j'ai réussi a installer Lubuntu 20.04 et à faire marcher Mame du tonnerre de feu avec le driver 190 proprio d'Nvidia ? Sans mes problèmes de freeze des navigateurs je serais resté sur cette distri.

Je vais faire le max pour que Debian tourne. Merci pour votre aide. J'ai mis à coté du "PC Linux" mon portable Windows 10 pour continuer à poster sur le fofo en attendant que ca tourne. J'ai pas mal de vos astuces à tenter dans la console avant de baisser les bras.

Merci de votre aide. Pour l'instant j'ai relancer une installation depuis 0 pour repartir sur de bonnes bases. Je vous tiens au courant big_smile

Dernière modification par CptNemo (23-02-2022 21:17:48)

Hors ligne

#19 23-02-2022 21:43:06

bonyred
Membre
Distrib. : Debian bulleseye - 11
Noyau : 5.10.0-8-amd64
(G)UI : mate sur le portable et gnome sur ma tour
Inscription : 15-05-2015

Re : Installation qui tourne à la galère

Salut,
As tu le secure boot desactivé dans le bios. si non le désactivé. Je sais que nvidia et secure boot ne font pas bon ménage.
Si j'étais toi je désinstallerais nvidia en tty et relancerais la machine.
Surement pas la solution mais c'est ce que j'essaierais.
Bon courage.

Hors ligne

#20 23-02-2022 21:43:30

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

Debian Alain a écrit :

bonjour CptNemo  smile  smile  smile

tu es en console ?

si oui , essaies ceci :

systemctl status NetworkManager


et regarde si tu as du réseau (ligne "active")


si tu as du réseau , essaies ceci :

apt install nvidia-detect


pour l'installer , puis :


nvidia-detect


on verra , par exemple , si ta carte est prise en charge par un pilote propriétaire Nvidia
ou non et lequel.  
si non , faudra penser au projet "nouveau" (pilote debian) .


mais je connais très mal le support Nvidia .
je suis nettement plus AMD .

amicalement,

alain.

https://debian-facile.org/img/smilies/xtras/coyotus.png

NB: au fait , c'est un portable ou une tour ?



Bon bon...je suis dans la console du mode recovery et comme je m'en doutait la ligne active : est inactive (dead)
Ma clé Wifi n'est pas reconnue. Alors que pendant l'installation elle a été utilisée et elle marchait en recovery Lubuntu. Bref...
Ce soir j'ai plus le temps mais je vais essayer de brancher un RJ45 demain. C'est vraiment la galère.
Sans réseau pas la peine de continuer ce soir.
Encore merci à tous...

Dernière modification par CptNemo (23-02-2022 21:45:20)

Hors ligne

#21 23-02-2022 21:44:35

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

bonyred a écrit :

Salut,
As tu le secure boot desactivé dans le bios. si non le désactivé. Je sais que nvidia et secure boot ne font pas bon ménage.
Si j'étais toi je désinstallerais nvidia en tty et relancerais la machine.
Surement pas la solution mais c'est ce que j'essaierais.
Bon courage.



Ba c'est un bios de 2008 je trouve rien dedans en rapport avec le secure boot...

Dernière modification par CptNemo (23-02-2022 21:44:50)

Hors ligne

#22 23-02-2022 21:53:50

Debian Alain
Membre
Lieu : Bretagne
Distrib. : sid (unstable) / bullseye (stable)
Noyau : Linux sid 6.1.0-1-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : Installation qui tourne à la galère

big_smile  big_smile  big_smile

puisque tu n'as pas de réseau , essaies ceci pour l'activer :

systemctl restart NetworkManager


et teste , ensuite :

systemctl status NetworkManager


pour verifier . mais normalement tu dois pas en avoir besoin



amicalement ,

alain .

coyotus.png

Hors ligne

#23 23-02-2022 22:02:52

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : Installation qui tourne à la galère

CptNemo a écrit :

bartaba a écrit :

CptNemo a écrit :

@Debian Alain.
Merci pour ton aide. En ce moment je suis au boulot sur mon temps de pause wink . Je vais voir ce soir et mettre les mains dans le cambouis ; je sens qu'on ne peut pas y couper avec Linux. J'utilise les OS Windows depuis 20 ans et j'ai jamais eu autant de problèmes au niveau de l'installation...ça fera surement bondir les amateurs du pingouin mais pour un novice le choc est rude par rapport à la facilité d'accès "standardisée" des produits Microsoft. Vaste débat...


en complément du post de Debian Alain : il faudra au préalable modifier ton fichier sources.list pour y ajouter les dépôts non-free car ils n'y sont pas d'origine.
Tu trouveras le modèle à copier ici dans la partie sources.list non libre : https://debian-facile.org/doc:systeme:a … -non-libre




Merci Bartaba ! Mais comment éditer le fichier sources.list en mode console ?

Ce qui me scie le fessier c'est que ces quelques lignes pourraient être proposées via un menu + disclamer  au moment de l'installation de Linux.
Quel gain de temps se serait pour toute la communauté.



avec nano

sudo nano /etc/apt/sources.list

Hors ligne

#24 24-02-2022 09:06:32

CptNemo
Membre
Inscription : 23-02-2022

Re : Installation qui tourne à la galère

Bonjour et encore merci à tous pour votre aide.

Hier soir j'ai pas eu le temps de continuer. J’aurais l'occasion de m'y remettre en fin de journée.
A+

Hors ligne

#25 24-02-2022 11:25:46

phlinux
Membre
Distrib. : Buster
Noyau : 5.10
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Installation qui tourne à la galère

bartaba a écrit :


avec nano

sudo nano /etc/apt/sources.list



Je crois que cette question a été résolue

Debian Alain a écrit :

big_smile  big_smile  big_smile
je viens d'installer une iso D F en  v.m.
j'ai regardé les  dépôts .
il n'y a rien à faire .


Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

Pied de page des forums