Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-12-2022 14:04:15

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 6.0.10-arch2-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

[Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Bonjour,

j'essaie désespérément de sortir le son sur cette commande :


            mpv --lavfi-complex="[aid1]asplit[a1][a2]; \
            [a1]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
            [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
            [a2]showvolume=w=800:h=40:r=30:b=1:t=1:v=1:o=1:ds=log:f=0.5:m=r:dm=1:dmc=red:p=1[vmeter]; \
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
            [ol1][vmeter]overlay=x=20:y=20,format=yuv420p[vo]"  "$file"
 



J'obtiens bien le style de vidéo que je veux :

NO_AUDIO.png


Contrairement cette commande :


            mpv  --lavfi-complex="[aid1]asplit[a1][a2]; \
            [a1]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
            [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
            [a2]ebur128=video=1:size=640x980:meter=9:target=-16:dualmono=true[vebur][ao]; \
            [vebur]format=rgba,colorchannelmixer=1.150:0.150:0.150:0.150:1.149:0.186:0.168:0.000:0.172:0.134:0.131:0.000:0.000:0.000:0.000:0.300[vmeter]; \
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
            [ol1][vmeter]overlay=x=20:y=20,format=yuv420p[vo]" "$file"
 



me donne du son mais le filtre ebur128 ne me convient pas. C'est pour cela que j'ai voulu le remplacer par showvolume

Si quelqu'un pouvait m'aider, ça serait cool.

Dernière modification par golgot200 (03-12-2022 12:20:18)

Hors ligne

#2 02-12-2022 17:44:19

Cram28
Adhérent(e)
Lieu : Eure-et-Loir
Distrib. : Debian bullseye (11)
Noyau : Linux 5.10.0-19-amd64
(G)UI : Xfce
Inscription : 14-09-2020

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Bonjour golgot200,

Sympa ça ! Et même souci sur ma bécane...

Tu semblais y être parvenu , non ?

C'est pour moi un peu du charabia toutes ces options...scratchhead.gif (pas limpide en tous cas)
Peut-être un problème d'«imbrication» ? Il me dit:

cram@cardamome:~$ mpv --lavfi-complex="[aid1]asplit[a1][a2]; \
            [a1]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
            [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
            [a2]showvolume=w=800:h=40:r=30:b=1:t=1:v=1:o=1:ds=log:f=0.5:m=r:dm=1:dmc=red:p=1[vmeter]; \
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
            [ol1][vmeter]overlay=x=20:y=20,format=yuv420p[vo]"  "$FILE"
Track 1 can't be selected twice.
 (+) Video --vid=1 (*) (h264 640x360 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] Parsed_showcqt_1: fractional step.
VO: [gpu] 1920x1080 yuv420p
(Paused) V: 00:00:33 / 00:08:15 (6%)
 


Il n'y a pas cette alerte dans la console avec ton autre commande. Il ne peut pas choisir deux fois la même piste dans le 1ier cas (audio et la vidéo ?) ?
Avec la seconde commande, il n'a pas ce problème et il y a 'pulse' et du son en plus en effet...

cram@cardamome:~$ mpv  --lavfi-complex="[aid1]asplit[a1][a2]; \
            [a1]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
            [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
            [a2]ebur128=video=1:size=640x980:meter=9:target=-16:dualmono=true[vebur][ao]; \
            [vebur]format=rgba,colorchannelmixer=1.150:0.150:0.150:0.150:1.149:0.186:0.168:0.000:0.172:0.134:0.131:0.000:0.000:0.000:0.000:0.300[vmeter]; \
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
            [ol1][vmeter]overlay=x=20:y=20,format=yuv420p[vo]" "$FILE"
 (+) Video --vid=1 (*) (h264 640x360 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 1920x1080 yuv420p
(Paused) AV: 00:00:04 / 00:08:15 (0%) A-V:  0.000
 


Tu as dû remarquer sans doute et pas d'une grande aide je suis... (je vais suivre ce fil)

Bonne fouille !
@+


Travaille du chapeau: "Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas certain que vous réalisiez que ce que vous avez entendu n'est pas exactement ce que je voulais dire..."

Hors ligne

#3 02-12-2022 18:43:56

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 6.0.10-arch2-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

@Cram28

On va y arriver, je commence à piger un peu le truc. Essaies ça :



            mpv --lavfi-complex="[aid1]asplit[ao][a]; \
           [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
           [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \



            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[vo]"
\
            "TA_VIDEO.mkv"
 





 (+) Video --vid=1 (*) (h264 640x480 29.970fps)
     Video --vid=2 (png 640x480)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
     Audio --aid=2 --alang=eng (opus 2ch 48000Hz)
     Audio --aid=3 --alang=eng (opus 2ch 48000Hz)
     Audio --aid=4 --alang=eng (opus 2ch 48000Hz)
File tags:
 Artist: Metallica
 Comment: https://www.youtube.com/watch?v=boanuwUMNNQ
 Date: 20091027
 Description: Metallica's official music video for “Whiskey in the Jar,” from the album “Garage Inc.” Subscribe for more videos: https://metallica.lnk.to/subscribe

Listen to Metallica: https://metallica.lnk.to/listen

Directed by Jonas Åkerlund
Filmed in November 1998 in Brooklyn, NY

Video Premiere Date: March 16, 1999

Follow Metallica:
Website & Store: http://www.metallica.com
Official Live Recordings: http://www.livemetallica.com
Instagram: http://www.instagram.com/metallica
Facebook: http://www.facebook.com/metallica
Twitter: http://www.twitter.com/metallica

© 1999 Blackened Recordings

#Metallica #GarageInc
 Title: Metallica: Whiskey in the Jar (Official Music Video)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [alsa] 48000Hz stereo 2ch float
VO: [gpu] 1920x1080 rgba
(Paused) AV: 00:00:47 / 00:04:44 (17%) A-V:  0.000

 







Manque plus que le showvolume wink

Dernière modification par golgot200 (02-12-2022 18:47:17)

Hors ligne

#4 02-12-2022 20:04:12

Cram28
Adhérent(e)
Lieu : Eure-et-Loir
Distrib. : Debian bullseye (11)
Noyau : Linux 5.10.0-19-amd64
(G)UI : Xfce
Inscription : 14-09-2020

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Merci,

Jusque-là, ça roule:

cram@cardamome:~$ mpv --lavfi-complex="[aid1]asplit[ao][a]; \
            [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
            [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[vo]"             "$FILE"
 (+) Video --vid=1 (*) (h264 640x360 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 1920x1080 rgba
(Paused) AV: 00:00:16 / 00:03:20 (8%) A-V:  0.000
 



@suivre, @+


Travaille du chapeau: "Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas certain que vous réalisiez que ce que vous avez entendu n'est pas exactement ce que je voulais dire..."

Hors ligne

#5 03-12-2022 12:18:43

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 6.0.10-arch2-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

@Cram28

yessssss !!! trouvé big_smile


[aid1]asplit=3[ao][a][b];
 




            mpv  --lavfi-complex="[aid1]asplit=3[ao][a][b]; \
           [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
           [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
           [b]showvolume=r=20:o=v:w=260:h=50:t=0:f=0.34[v]; \
           
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
           [ol1][v]overlay=x=20:y=20,format=yuv420p[vo]"
Metallica_-_Whiskey_in_the_Jar_Official_Music_Video.mkv
 





Resuming playback. This behavior can be disabled with --no-resume-playback.
 (+) Video --vid=1 (*) (h264 640x480 29.970fps)
     Video --vid=2 (png 640x480)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
     Audio --aid=2 --alang=eng (opus 2ch 48000Hz)
     Audio --aid=3 --alang=eng (opus 2ch 48000Hz)
     Audio --aid=4 --alang=eng (opus 2ch 48000Hz)
File tags:
 Artist: Metallica
 Comment: https://www.youtube.com/watch?v=boanuwUMNNQ
 Date: 20091027
 Description: Metallica's official music video for “Whiskey in the Jar,” from the album “Garage Inc.” Subscribe for more videos: https://metallica.lnk.to/subscribe

Listen to Metallica: https://metallica.lnk.to/listen

Directed by Jonas Åkerlund
Filmed in November 1998 in Brooklyn, NY

Video Premiere Date: March 16, 1999

Follow Metallica:
Website & Store: http://www.metallica.com
Official Live Recordings: http://www.livemetallica.com
Instagram: http://www.instagram.com/metallica
Facebook: http://www.facebook.com/metallica
Twitter: http://www.twitter.com/metallica

© 1999 Blackened Recordings

#Metallica #GarageInc
 Title: Metallica: Whiskey in the Jar (Official Music Video)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [alsa] 48000Hz stereo 2ch float
VO: [gpu] 1920x1080 yuv420p
(Paused) AV: 00:02:24 / 00:04:44 (51%) A-V:  0.000

 



wink

Hors ligne

#6 03-12-2022 13:08:52

Cram28
Adhérent(e)
Lieu : Eure-et-Loir
Distrib. : Debian bullseye (11)
Noyau : Linux 5.10.0-19-amd64
(G)UI : Xfce
Inscription : 14-09-2020

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Hello,

Bien joué ! Ça fonctionne ici aussi !


mpv  --lavfi-complex="[aid1]asplit=3[ao][a][b]; \
           [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
           [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
           [b]showvolume=r=20:o=v:w=260:h=50:t=0:f=0.34[v]; \
           [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
           [ol1][v]overlay=x=20:y=20,format=yuv420p[vo]"  \
           "$FILE"
 (+) Video --vid=1 (*) (h264 640x360 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 1920x1080 yuv420p
(Paused) AV: 00:00:17 / 00:04:27 (6%) A-V:  0.000
 


Tout est dans 'asplit=3', nombre de «composants» à suivre j'ai l'impression ?

Du coup, j'ai repris ton format initial de showvolume un chouia différent ([vmeter]), et ça le fait:


mpv  --lavfi-complex="[aid1]asplit=3[ao][a][b]; \
           [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
           [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
           [b]showvolume=w=800:h=40:r=30:b=1:t=1:v=1:o=1:ds=log:f=0.5:m=r:dm=1:dmc=red:p=1[vmeter]; \
           [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
           [ol1][vmeter]overlay=x=20:y=20,format=yuv420p[vo]" \
           "$FILE"
 (+) Video --vid=1 (*) (h264 640x360 29.970fps)
 (+) Audio --aid=1 (*) (aac 2ch 44100Hz)
[ffmpeg] Parsed_showcqt_1: fractional step.
AO: [pulse] 44100Hz stereo 2ch float
VO: [gpu] 1920x1080 yuv420p
AV: 00:07:30 / 00:08:15 (90%) A-V:  0.000

Exiting... (Quit)


T'es bien mûr pour fabriquer un lecteur réseau audio/video toi, sur Raspberry + écran tactile + DAC + ampli... wink

Merci golgot200, @+

Dernière modification par Cram28 (03-12-2022 13:11:57)


Travaille du chapeau: "Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas certain que vous réalisiez que ce que vous avez entendu n'est pas exactement ce que je voulais dire..."

Hors ligne

#7 03-12-2022 13:22:34

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 6.0.10-arch2-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

wink

OK_audio.png


colorkey=0x000000:0.1:0.8
 




            mpv  --lavfi-complex="[aid1]asplit=3[ao][a][b]; \
           [a]showcqt=fps=24:axis_h=64:bar_t=0.5:count=6:axis=0:axis_h=2:bar_h=1000:timeclamp=0.53,format=rgba[vcqt]; \
           [vid1]scale=w=480*dar:h=480,setsar=1,format=rgba,colorchannelmixer=aa=0.8[v1]; \
           [b]showvolume=r=60:o=v:w=800:h=120:t=0:f=0.34,drawbox=x=0:y=0:c=yellow@0.1,colorkey=0x000000:0.1:0.8[v]; \
           
            [vcqt][v1]overlay=x=main_w-overlay_w-20:y=20:format=auto[ol1]; \
           [ol1][v]overlay=x=20:y=20,format=yuv420p[vo]"
"LE_FICHIER"

 

Dernière modification par golgot200 (03-12-2022 13:26:07)

Hors ligne

#8 04-12-2022 20:39:12

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 6.0.10-arch2-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Bonsoir,

j'en suis pas loin ...

4_overlay.png

Hors ligne

#9 04-12-2022 21:53:50

Cram28
Adhérent(e)
Lieu : Eure-et-Loir
Distrib. : Debian bullseye (11)
Noyau : Linux 5.10.0-19-amd64
(G)UI : Xfce
Inscription : 14-09-2020

Re : [Résolu] mpv --lavfi-complex ( pas d'audio sur un code )

Hello bonsoir,

Je reste preneur de la commande finale... merci.gif

@+

Travaille du chapeau: "Je sais que vous croyez comprendre ce que vous pensez que j'ai dit, mais je ne suis pas certain que vous réalisiez que ce que vous avez entendu n'est pas exactement ce que je voulais dire..."

Hors ligne

Pied de page des forums