logo Debian Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés logo inclusivité

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-03-2024 16:25:33

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

[Abandonné]downgrader trixie/sid vers bookworm

Bonjour à tous,

J'ai un serveur sous bookworm stable qui me sert de serveur de musique avec mpd, de stockage et sauvegarde. Le tout était en local avec blocage d'accès internet sur la box pour ne pas devoir me soucier de la sécurité.

Souhaitant avoir un accès externe, je me dis que la première base de la sécurité est de mettre à jour.

# apt-get update
# apt-get upgrade
# apt-get dist-upgrade



Ca a bien du prendre 30 min.

De bookworm stable je suis passé a trixie/sid

~$ cat /etc//*release
PRETTY_NAME="Debian GNU/Linux trixie/sid"
NAME="Debian GNU/Linux"
VERSION_CODENAME=trixie
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"



La ligne deb http://ftp.fr.debian.org/debian sid main   a été ajouté à mon source-list.

nano /etc/apt/sources.list


#deb cdrom:[Debian GNU/Linux 12.1.0 _Bookworm_ - Official i386 NETINST with firmware 20230722-10:48]/ bookworm main non-free-firmware

#deb https://deb.debian.org/debian bookworm main non-free-firmware
deb-src https://deb.debian.org/debian bookworm main non-free-firmware

#deb http://security.debian.org/debian-security bookworm-security main non-free-firmware
deb-src http://security.debian.org/debian-security bookworm-security main non-free-firmware

# bookworm-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
#deb https://deb.debian.org/debian bookworm-updates main non-free-firmware
deb-src https://deb.debian.org/debian bookworm-updates main non-free-firmware

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
deb http://deb.debian.org/debian/ bookworm main contrib non-free non-free-firmware
deb http://security.debian.org/debian-security bookworm-security main contrib non-free non-free-firmware
deb http://deb.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware
deb http://deb.debian.org/debian/ bookworm-proposed-updates main contrib non-free non-free-firmware
deb http://ftp.fr.debian.org/debian bookworm main
deb http://ftp.fr.debian.org/debian sid main



1/ Pourquoi suis je passé d'une version stable à une version instable?
3/ Dois-je m'attendre à des désagréments? Pour l'instant il semble que je fasse tout ce que je faisais avant
2/ Un downgrade est -il souhaitable/possible pour un novice?


Merci par avance de vos conseils.
Les prochains essais de serveur externe se feront sur une machine dédiée.Snif....et en vous demandant de l'aide AVANT...

Dernière modification par wardidi (06-04-2024 07:49:30)

Hors ligne

#2 28-03-2024 17:15:36

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

Pour rétrograder en stable, je suppose que je peux m’inspirer de la réponse de  vv222 https://debian-facile.org/viewtopic.php?id=32149

vv222 a écrit :

1. Sources de paquets

Pour préparer le retour en arrière, il faut avant tout s’assurer qu’on utilise les bonnes sources de paquets. Pour ça commence par supprimer toutes tes anciennes sources avec :

rm /etc/apt/sources.list /etc/apt/sources.list.d/*


Et crée pour les remplacer un nouveau fichier /etc/apt/sources.list.d/debian.sources avec ce contenu :

Types: deb
URIs: http://deb.debian.org/debian
Suites: bullseye bullseye-updates
Architectures: amd64 i386
Components: main contrib non-free

Types: deb
URIs: http://security.debian.org
Suites: bullseye-security
Architectures: amd64 i386
Components: main contrib non-free


Une fois ce fichier créé, lance la mise-à-jour de l‘index des paquets disponibles avec :

apt update



2. Priorité entre les versions

Les paquets dans les versions les plus élevées (plus récents) étant prioritaires sur ceux avec une version plus basse (plus anciens), il ne suffit pas de revenir au sources de Bullseye. Il faut aussi donner explicitement une priorité importante aux versions de Bullseye pour que apt les considère comme plus importantes que celles de Sid.

Comme pour les sources il faut commencer par retirer toute configuration précédente des priorités entre paquets :

rm /etc/apt/preferences /etc/apt/preferences.d/*


Ensuite crée le fichier /etc/apt/preferences.d/bullseye-downgrade avec ce contenu :

Package: *
Pin: release o=debian,n=bullseye
Pin-Priority: 1001

Package: *
Pin: release o=debian,n=bullseye-security
Pin-Priority: 1001



3. Désinstallation des paquets tiers

La commande suivante te donne une liste de paquets qui ne sont pas disponibles dans les dépôts de Debian Bullseye, mais sont quand même installés sur ton système :

apt list '?obsolete'


Pour simplifier le retour en arrière qui va suivre il vaut mieux que cette liste soit la plus courte possible, idéalement vide. Je te conseille donc de désinstaller tout ce qu’elle te retourne et dont tu sais que tu pourras le réinstaller plus tard, une fois ton système remis sur pieds.


4. Simulation du retour en arrière

Le retour en arrière étant une opération d’autant plus compliquée qu’il y a de décalage entre la version de départ (Debian Sid) et celle d’arrivée (Debian Bullseye), ce qui est dans notre cas un écart d’un peu plus d’un an et demi, il vaut mieux effectuer des simulations avant le retour en arrière véritable pour anticiper les points de blocage et en corriger un maximum en amont.

La simulation du retour en arrière se lance avec :

apt --simulate full-upgrade


Si cette commande aboutit sur une erreur, partages-en le retour ici pour qu’on te donne un coup de main sur le diagnostic. Si par contre la simulation ne donne aucune erreur tu peux lancer le véritable retour en arrière.


5. Retour en arrière effectif

Le retour en arrière se lance de manière similaire à sa simulation, avec :

apt full-upgrade


Lors de cette étape des erreurs qui n’avaient pas été repérées par la simulation peuvent tout de même avoir lieu, auquel cas n’hésite pas à les partager ici. Il vaut mieux éviter les expérimentations à cette étape pour éviter de se retrouver dans une situation vraiment bancale.


6. Nettoyage

Une fois que tu es réellement de retour sur une Debian Bullseye, le fichier réglant les priorités entre versions de paquets peut être supprimé :

rm /etc/apt/preferences.d/bullseye-downgrade







Suffirait-il de remplacer bullseye par bookworm ?
Cela donnerait :

rm /etc/apt/sources.list /etc/apt/sources.list.d/*



nano /etc/apt/sources.list.d/debian.sources



Types: deb
URIs: http://deb.debian.org/debian
Suites: bookworm bookworm-updates
Architectures: amd64 i386
Components: main contrib non-free

Types: deb
URIs: http://security.debian.org
Suites: bookworm-security
Architectures: amd64 i386
Components: main contrib non-free



apt update



rm /etc/apt/preferences /etc/apt/preferences.d/*




nano /etc/apt/preferences.d/bookworm-downgrade


Package: *
Pin: release o=debian,n=bookworm
Pin-Priority: 1001

Package: *
Pin: release o=debian,n=bookworm-security
Pin-Priority: 1001



apt list '?obsolete'



apt --simulate full-upgrade



apt full-upgrade



rm /etc/apt/preferences.d/bookworm-downgrade



J'attends vos avis avant d'effectuer....

Hors ligne

#3 28-03-2024 18:20:11

mister_g
Membre
Distrib. : debian sid
Noyau : Linux 6.6.13
(G)UI : fluxbox
Inscription : 20-07-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

1 - ton os ne change pas de version tout seul, tu n'est pas sur win****
donc soit tu as tapé une commande pour cela ou un logiciel / utilitaire l'a fait.

2 - je ne sais pas si c'est si simple, les pro des mises à jour te diront cela

3 - quel désagrément ? tu as des versions plus récentes de tes librairies, logiciels.
a part pour les changements de noyau et la bonne version des drivers nvidia qui vont avec, je n'ai jamais de souci et cela depuis plusieurs années.
donc aucun désagrément smile

En ligne

#4 28-03-2024 19:34:57

dezix
Membre
Distrib. : Debian stable
Noyau : Linux amd64 (stable)
(G)UI : XFCE4
Inscription : 19-02-2018

Re : [Abandonné]downgrader trixie/sid vers bookworm

wardidi a écrit :

1/ Pourquoi suis je passé d'une version stable à une version instable?



parce que :

wardidi a écrit :


deb http://ftp.fr.debian.org/debian sid main



et

que les priorités ont été mal (ou pas du tout) configurées.

Que renvoie :

apt policy

Dernière modification par dezix (28-03-2024 19:37:23)

Hors ligne

#5 28-03-2024 19:44:15

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

Merci dezix et mister_g

dezix a écrit :

wardidi a écrit :

1/ Pourquoi suis je passé d'une version stable à une version instable?



parce que :

wardidi a écrit :


deb http://ftp.fr.debian.org/debian sid main



Tu veux dire que sid main était dans mes sourceslist avant la migration? Si oui aucun souvenir de l'avoir ajouter ni pourquoi je l'aurais fait....

apt policy
Fichiers du paquet :
 100 /var/lib/dpkg/status
     release a=now
 500 http://ftp.fr.debian.org/debian sid/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 500 http://ftp.fr.debian.org/debian bookworm/main i386 Packages
     release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=main,b=i386
     origin ftp.fr.debian.org
 500 http://deb.debian.org/debian bookworm-proposed-updates/non-free i386 Packages
     release v=12-updates,o=Debian,a=proposed-updates,n=bookworm-proposed-updates,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 500 http://deb.debian.org/debian bookworm-proposed-updates/main i386 Packages
     release v=12-updates,o=Debian,a=proposed-updates,n=bookworm-proposed-updates,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian bookworm-updates/non-free i386 Packages
     release v=12-updates,o=Debian,a=stable-updates,n=bookworm-updates,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian bookworm-updates/main i386 Packages
     release v=12-updates,o=Debian,a=stable-updates,n=bookworm-updates,l=Debian,c=main,b=i386
     origin deb.debian.org
 500 http://security.debian.org/debian-security bookworm-security/non-free-firmware i386 Packages
     release v=12,o=Debian,a=stable-security,n=bookworm-security,l=Debian-Security,c=non-free-firmware,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security bookworm-security/main i386 Packages
     release v=12,o=Debian,a=stable-security,n=bookworm-security,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 https://deb.debian.org/debian bookworm/non-free-firmware i386 Packages
     release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=non-free-firmware,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian bookworm/non-free i386 Packages
     release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=non-free,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian bookworm/contrib i386 Packages
     release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=contrib,b=i386
     origin deb.debian.org
 500 https://deb.debian.org/debian bookworm/main i386 Packages
     release v=12.5,o=Debian,a=stable,n=bookworm,l=Debian,c=main,b=i386
     origin deb.debian.org
Paquets épinglés :
 



mister_g a écrit :

1 - ton os ne change pas de version tout seul, tu n'est pas sur win****
donc soit tu as tapé une commande pour cela ou un logiciel / utilitaire l'a fait.

2 - je ne sais pas si c'est si simple, les pro des mises à jour te diront cela

3 - quel désagrément ? tu as des versions plus récentes de tes librairies, logiciels.
a part pour les changements de noyau et la bonne version des drivers nvidia qui vont avec, je n'ai jamais de souci et cela depuis plusieurs années.
donc aucun désagrément smile



Ma crainte est d'être sur une version instable d'où ma préférence pour un retour en arrière.

Hors ligne

#6 28-03-2024 19:51:06

dezix
Membre
Distrib. : Debian stable
Noyau : Linux amd64 (stable)
(G)UI : XFCE4
Inscription : 19-02-2018

Re : [Abandonné]downgrader trixie/sid vers bookworm

wardidi a écrit :

Tu veux dire que sid main était dans mes sourceslist avant la migration?



J'ai copié/cité la dernière ligne de ce que tu as posté en #1
tu dois savoir d'où ça sort.

wardidi a écrit :

d'où ma préférence pour un retour en arrière.


Pas de sauvegarde à restaurer ?

Hors ligne

#7 28-03-2024 19:57:13

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

wardidi a écrit :

Pour rétrograder en stable, je suppose que je peux m’inspirer de la réponse de  vv222 https://debian-facile.org/viewtopic.php?id=32149
(…)
Suffirait-il de remplacer bullseye par bookworm ?



Ça me semble correct, tant que tu ne sautes pas des étapes ça devrait bien se passer.

À savoir qu’il existe un guide plus à jour sur le wiki : Rétrograder une Debian. Je peux si tu le souhaites prendre le temps de le mettre à jour pour décrire l’opération Trixie → Bookworm.


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#8 28-03-2024 20:05:10

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

wardidi a écrit :

dezix a écrit :

wardidi a écrit :

Tu veux dire que sid main était dans mes sourceslist avant la migration?



J'ai copié/cité la dernière ligne de ce que tu as posté en #1
tu dois savoir d'où ça sort.


Cela vient bien de /etc/apt/sources.list. Je croyais que l'upgrade  avait ajouté cette ligne, mais si je comprends bien c'est l'inverse. Elle était dans /etc/apt/sources.list et l'upgrade à donc fait migrer vers trixie/sid.


Et non, pas de sauvegarde du système.Erreur de débutant, la prochaine fois j'y penserais avant un upgrade.
Mais tous les documents sont doublés sur mon pc de travail.
Donc au pire une réinstalle est possible.



Mais j'avais galéré avec mpd donc Si un downgrade est possible pour m'éviter la réinstale...

Hors ligne

#9 28-03-2024 20:11:39

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

vv222 a écrit :

wardidi a écrit :

Pour rétrograder en stable, je suppose que je peux m’inspirer de la réponse de  vv222 https://debian-facile.org/viewtopic.php?id=32149
(…)
Suffirait-il de remplacer bullseye par bookworm ?



Ça me semble correct, tant que tu ne sautes pas des étapes ça devrait bien se passer.

À savoir qu’il existe un guide plus à jour sur le wiki : Rétrograder une Debian. Je peux si tu le souhaites prendre le temps de le mettre à jour pour décrire l’opération Trixie → Bookworm.




Merci vv222

Mon dernier message a croisé le tien.
Si tu veux/peux mettre à jour le guide du wiki, je peux attendre. Je le suivrais à la lettre et posterais ici le résultat et https://debian-facile.org/viewtopic.php?id=34252.

Dernière modification par wardidi (28-03-2024 21:33:21)

Hors ligne

#10 29-03-2024 00:25:43

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

wardidi a écrit :

Si tu veux/peux mettre à jour le guide du wiki, je peux attendre. Je le suivrais à la lettre et posterais ici le résultat et https://debian-facile.org/viewtopic.php?id=34252.


C’est fait, je te laisse y jeter un œil et n’hésite surtout pas à demander un coup de main au moindre blocage. C’est une opération où on peut vite s’embourber, alors il vaut mieux jouer la prudence et demander à être guidé si une étape ne se déroule pas comme prévu.


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#11 29-03-2024 13:51:40

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

vv222 a écrit :


C’est fait, je te laisse y jeter un œil et n’hésite surtout pas à demander un coup de main au moindre blocage. C’est une opération où on peut vite s’embourber, alors il vaut mieux jouer la prudence et demander à être guidé si une étape ne se déroule pas comme prévu.



Merci vv222

Avant de faire apt update, voici les premiers résultats:
Précision, tout est fait depuis remmina.

-sources.list n'existe plus.....(présent hier. cf post #1) sources.list.d déjà vide

sudo rm /etc/apt/sources.list /etc/apt/sources.list.d/*
rm: impossible de supprimer '/etc/apt/sources.list': Aucun fichier ou dossier de ce type
rm: impossible de supprimer '/etc/apt/sources.list.d/*': Aucun fichier ou dossier de ce type



J'ai poursuivi:

~$ sudo nano /etc/apt/sources.list.d/debian.sources


Types: deb
URIs: http://deb.debian.org/debian
Suites: bookworm bookworm-updates bookworm-proposed-updates
Architectures: amd64
Components: main
Signed-By: /usr/share/keyrings/debian-archive-keyring.gpg

Types: deb
URIs: http://deb.debian.org/debian-security
Suites: bookworm-security
Architectures: amd64
Components: main
Signed-By: /usr/share/keyrings/debian-archive-keyring.gpg



ctrl+x
o
enter

-preferences n'existe pas et preference.d est  déjà vide

~$ sudo rm /etc/apt/preferences /etc/apt/preferences.d/*
rm: impossible de supprimer '/etc/apt/preferences': Aucun fichier ou dossier de ce type
rm: impossible de supprimer '/etc/apt/preferences.d/*': Aucun fichier ou dossier de ce type




J'ai poursuivi:

~$ sudo nano /etc/apt/preferences.d/downgrade


Package: *
Pin: release o=Debian,n=bookworm
Pin-Priority: 1001
 
Package: *
Pin: release o=Debian,n=bookworm-security
Pin-Priority: 1001



ctrl+x
o
enter

Voilà. J'ai vérifié avec le stp transfer de remmina que les 2 fichiers devant être supprimés le sont bien et ceux crées sont bien seuls présents dans leurs répertoires.
J'attends vos retours avant de continué.

Merci pour le temps passé à me lire.

Dernière modification par wardidi (02-04-2024 12:44:54)

Hors ligne

#12 02-04-2024 12:45:32

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

Je poursuis:

sudo apt update


Atteint :1 http://deb.debian.org/debian bookworm InRelease
Réception de :2 http://deb.debian.org/debian bookworm-updates InRelease [55,4 kB]
Réception de :3 http://deb.debian.org/debian bookworm-proposed-updates InRelease [59,5 kB]
Réception de :4 http://deb.debian.org/debian-security bookworm-security InRelease [48,0 kB]
Réception de :5 http://deb.debian.org/debian bookworm/main amd64 Packages [8786 kB]
Réception de :6 http://deb.debian.org/debian bookworm-updates/main amd64 Packages [12,7 kB]
Réception de :7 http://deb.debian.org/debian bookworm-proposed-updates/main Translation-en.diff/Index [63,3 kB]
Réception de :8 http://deb.debian.org/debian bookworm-proposed-updates/main amd64 Packages [90,2 kB]
Réception de :9 http://deb.debian.org/debian bookworm-proposed-updates/main Translation-en T-2024-04-02-0206.34-F-2024-03-28-2021.46.pdiff [29,3 kB]
Réception de :9 http://deb.debian.org/debian bookworm-proposed-updates/main Translation-en T-2024-04-02-0206.34-F-2024-03-28-2021.46.pdiff [29,3 kB]
Réception de :10 http://deb.debian.org/debian-security bookworm-security/main amd64 Packages [150 kB]
Réception de :11 http://deb.debian.org/debian-security bookworm-security/main Translation-en [90,2 kB]
9384 ko réceptionnés en 5s (1890 ko/s)                    
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.
N: Le dépôt « Debian bookworm » a modifié sa valeur « firmware component » de « non-free » à « non-free-firmware »
N: Plus d'information disponible dans la note de mise à jour ici : https://www.debian.org/releases/bookworm/i386/release-notes/ch-information.html#non-free-split
 



apt list '?obsolete'


g++/now 4:13.2.0-7 i386  [installé, local]
gcc-12-base/now 12.3.0-15 i386  [installé, local]
gcc-12/now 12.3.0-15 i386  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
gcc-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
gcc/now 4:13.2.0-7 i386  [installé, local]
gettext-base/now 0.21-14+b1 i386  [installé, local]
gnupg-utils/now 2.2.40-3 i386  [installé, local]
gpg-agent/now 2.2.40-3 i386  [installé, local]
gpg-wks-client/now 2.2.40-3 i386  [installé, local]
gpg-wks-server/now 2.2.40-3 i386  [installé, local]
gpg/now 2.2.40-3 i386  [installé, local]
gpgconf/now 2.2.40-3 i386  [installé, local]
gpgsm/now 2.2.40-3 i386  [installé, local]
gpgv/now 2.2.40-3 i386  [installé, local]
grep/now 3.11-4 i386  [installé, local]
groff-base/now 1.23.0-3+b1 i386  [installé, local]
grub-common/now 2.12-1+b1 i386  [installé, local]
grub-pc-bin/now 2.12-1+b1 i386  [installé, local]
grub-pc/now 2.12-1+b1 i386  [installé, local]
grub2-common/now 2.12-1+b1 i386  [installé, local]
gzip/now 1.12-1.1 i386  [installé, local]
hostname/now 3.23+nmu2 i386  [installé, local]
i965-va-driver/now 2.4.1+dfsg1-1 i386  [installé, local]
ifrench-gut/now 1:1.0-32.2 i386  [installé, local]
ifupdown/now 0.8.43 i386  [installé, local]
inetutils-telnet/now 2:2.5-3+b2 i386  [installé, local]
init/now 1.66 i386  [installé, local]
intel-media-va-driver/now 24.1.0+dfsg1-1 i386  [installé, local]
iproute2/now 6.8.0-1 i386  [installé, local]
iputils-ping/now 3:20240117-1 i386  [installé, local]
isc-dhcp-client/now 4.4.3-P1-5 i386  [installé, local]
isc-dhcp-common/now 4.4.3-P1-5 i386  [installé, local]
ispell/now 3.4.06-1 i386  [installé, local]
kbd/now 2.6.4-2 i386  [installé, local]
klibc-utils/now 2.0.13-4 i386  [installé, local]
kmod/now 32-1 i386  [installé, local]
less/now 590-2 i386  [installé, local]
libaacs0/now 0.11.1-3+b1 i386  [installé, local]
libabsl20220623t64/now 20220623.1-3.1 i386  [installé, local]
libacl1/now 2.3.2-1 i386  [installé, local]
libadplug-2.3.3-0/now 2.3.3+dfsg-2 i386  [installé, local]
libaio1/now 0.3.113-5 i386  [installé, local]
libalgorithm-diff-xs-perl/now 0.04-8+b3 i386  [installé, local]
libao4/now 1.2.2+20180113-1.1 i386  [installé, local]
libaom3/now 3.8.2-2 i386  [installé, local]
libapparmor1/now 3.0.13-2 i386  [installé, local]
libapt-pkg6.0t64/now 2.7.14 i386  [installé, local]
libargon2-1/now 0~20190702+dfsg-4+b1 i386  [installé, local]
libasan8/now 14-20240315-1 i386  [installé, local]
libasound2t64/now 1.2.11-1+b1 i386  [installé, local]
libaspell15/now 0.60.8.1-1+b1 i386  [installé, local]
libass9/now 1:0.17.1-2 i386  [installé, local]
libassuan0/now 2.5.6-1 i386  [installé, local]
libasyncns0/now 0.8-6+b3 i386  [installé, local]
libatomic1/now 14-20240315-1 i386  [installé, local]
libatopology2t64/now 1.2.11-1+b1 i386  [installé, local]
libattr1/now 1:2.5.2-1 i386  [installé, local]
libaudit1/now 1:3.1.2-2.1 i386  [installé, local]
libavahi-client3/now 0.8-13+b2 i386  [installé, local]
libavahi-common-data/now 0.8-13+b2 i386  [installé, local]
libavahi-common3/now 0.8-13+b2 i386  [installé, local]
libavcodec60/now 7:6.1.1-3 i386  [installé, local]
libavfilter9/now 7:6.1.1-3 i386  [installé, local]
libavformat60/now 7:6.1.1-3 i386  [installé, local]
libavif15/now 0.11.1-1 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libavutil57/now 7:5.1.4-0+deb12u1 i386  [installé, local]
libavutil58/now 7:6.1.1-3 i386  [installé, local]
libbdplus0/now 0.2.0-3 i386  [installé, local]
libbinio1v5/now 1.5+dfsg-0.1 i386  [installé, local]
libbinutils/now 2.42-4 i386  [installé, local]
libblas3/now 3.12.0-3 i386  [installé, local]
libblkid1/now 2.39.3-11 i386  [installé, local]
libbluray2/now 1:1.3.4-1 i386  [installé, local]
libbpf1/now 1:1.3.0-2+b1 i386  [installé, local]
libbrotli1/now 1.1.0-2+b3 i386  [installé, local]
libbs2b0/now 3.1.0+dfsg-8 i386  [installé, local]
libbsd0/now 0.12.2-1 i386  [installé, local]
libbz2-1.0/now 1.0.8-5.1 i386  [installé, local]
libc-bin/now 2.37-15.1 i386  [installé, local]
libc-dev-bin/now 2.37-15.1 i386  [installé, local]
libc-devtools/now 2.37-15.1 i386  [installé, local]
libc6-dev/now 2.37-15.1 i386  [installé, local]
libc6/now 2.37-15.1 i386  [installé, local]
libcairo-gobject2/now 1.18.0-3 i386  [installé, local]
libcairo2/now 1.18.0-3 i386  [installé, local]
libcap-ng0/now 0.8.4-2 i386  [installé, local]
libcap2-bin/now 1:2.66-5 i386  [installé, local]
libcap2/now 1:2.66-5 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcbor0.8/now 0.8.0-2+b1 i386  [installé, local]
libcc1-0/now 14-20240315-1 i386  [installé, local]
libcdio-cdda2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio-paranoia2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio19t64/now 2.1.0-4.1 i386  [installé, local]
libchromaprint1/now 1.5.1-5 i386  [installé, local]
libcjson1/now 1.7.17-2 i386  [installé, local]
libcodec2-1.0/now 1.0.5-1 i386  [installé, local]
libcodec2-1.2/now 1.2.0-2+b1 i386  [installé, local]
libcom-err2/now 1.47.0-2.4 i386  [installé, local]
libcrypt-dev/now 1:4.4.36-4 i386  [installé, local]
libcrypt1/now 1:4.4.36-4 i386  [installé, local]
libcryptsetup12/now 2:2.7.1-1 i386  [installé, local]
libctf-nobfd0/now 2.42-4 i386  [installé, local]
libctf0/now 2.42-4 i386  [installé, local]
libcurl3t64-gnutls/now 8.7.1-1 i386  [installé, local]
libcurl4t64/now 8.7.1-1 i386  [installé, local]
libdatrie1/now 0.2.13-3 i386  [installé, local]
libdav1d6/now 1.0.0-2 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libdb5.3t64/now 5.3.28+dfsg2-6 i386  [installé, local]
libdbus-1-3/now 1.14.10-4+b1 i386  [installé, local]
libde265-0/now 1.0.15-1+b1 i386  [installé, local]
libdebconfclient0/now 0.271+b3 i386  [installé, local]
libdecor-0-0/now 0.2.2-1+b1 i386  [installé, local]
libdecor-0-plugin-1-cairo/now 0.2.2-1+b1 i386  [installé, local]
libdeflate0/now 1.20-1 i386  [installé, local]
libdevmapper-event1.02.1/now 2:1.02.196-1 i386  [installé, local]
libdevmapper1.02.1/now 2:1.02.196-1 i386  [installé, local]
libdiscover2/now 2.1.2-10 i386  [installé, local]
libdrm-amdgpu1/now 2.4.120-2 i386  [installé, local]
libdrm-intel1/now 2.4.120-2 i386  [installé, local]
libdrm-nouveau2/now 2.4.120-2 i386  [installé, local]
libdrm-radeon1/now 2.4.120-2 i386  [installé, local]
libdrm2/now 2.4.120-2 i386  [installé, local]
libebur128-1/now 1.2.6-1+b1 i386  [installé, local]
libedit2/now 3.1-20230828-1 i386  [installé, local]
libefiboot1t64/now 38-3.1 i386  [installé, local]
libefivar1t64/now 38-3.1 i386  [installé, local]
libelf1t64/now 0.191-1 i386  [installé, local]
libexpat1/now 2.6.2-1 i386  [installé, local]
libext2fs2t64/now 1.47.0-2.4 i386  [installé, local]
libfaad2/now 2.11.1-1+b1 i386  [installé, local]
libfakeroot/now 1.34-1 i386  [installé, local]
libfdisk1/now 2.39.3-11 i386  [installé, local]
libffi8/now 3.4.6-1 i386  [installé, local]
libfftw3-double3/now 3.3.10-1+b2 i386  [installé, local]
libfftw3-single3/now 3.3.10-1+b2 i386  [installé, local]
libfido2-1/now 1.14.0-1+b1 i386  [installé, local]
libfile-fcntllock-perl/now 0.22-4+b3 i386  [installé, local]
libflac12t64/now 1.4.3+ds-2.1 i386  [installé, local]
libflite1/now 2.2-6+b2 i386  [installé, local]
libfluidsynth3/now 2.3.4-1+b3 i386  [installé, local]
libfmt9/now 9.1.0+ds1-2 i386  [installé, local]
libfontconfig1/now 2.15.0-1.1 i386  [installé, local]
libfreetype6/now 2.13.2+dfsg-1+b2 i386  [installé, local]
libfribidi0/now 1.0.13-3+b1 i386  [installé, local]
libfstrm0/now 0.6.1-1+b2 i386  [installé, local]
libfuse2/now 2.9.9-8+b1 i386  [installé, local]
libfuse3-3/now 3.14.0-5 i386  [installé, local]
libgav1-1/now 0.18.0-1+b2 i386  [installé, local]
libgbm1/now 24.0.3-1+b1 i386  [installé, local]
libgcc-12-dev/now 12.3.0-15 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libgcc-s1/now 14-20240315-1 i386  [installé, local]
libgcrypt20/now 1.10.3-2 i386  [installé, local]
libgd3/now 2.3.3-9+b2 i386  [installé, local]
libgdbm-compat4t64/now 1.23-5.1+b1 i386  [installé, local]
libgdbm6t64/now 1.23-5.1+b1 i386  [installé, local]
libgdk-pixbuf-2.0-0/now 2.42.10+dfsg-3+b2 i386  [installé, local]
libgdk-pixbuf2.0-bin/now 2.42.10+dfsg-3+b2 i386  [installé, local]
libgfortran5/now 14-20240315-1 i386  [installé, local]
libgl1-mesa-dri/now 24.0.3-1+b1 i386  [installé, local]
libgl1/now 1.7.0-1 i386  [installé, local]
libglapi-mesa/now 24.0.3-1+b1 i386  [installé, local]
libglib2.0-0/now 2.78.4-6 i386  [installé, local]
libglib2.0-0t64/now 2.78.4-6 i386  [installé, local]
libglvnd0/now 1.7.0-1 i386  [installé, local]
libglx-mesa0/now 24.0.3-1+b1 i386  [installé, local]
libglx0/now 1.7.0-1 i386  [installé, local]
libgme0/now 0.6.3-7+b1 i386  [installé, local]
libgmp10/now 2:6.3.0+dfsg-2+b1 i386  [installé, local]
libgnutls30t64/now 3.8.3-1.1+b1 i386  [installé, local]
libgomp1/now 14-20240315-1 i386  [installé, local]
libgpg-error0/now 1.47-3 i386  [installé, local]
libgprofng0/now 2.42-4 i386  [installé, local]
libgraphite2-3/now 1.3.14-2 i386  [installé, local]
libgsm1/now 1.0.22-1 i386  [installé, local]
libgssapi-krb5-2/now 1.20.1-6+b1 i386  [installé, local]
libharfbuzz0b/now 8.3.0-2+b1 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libheif1/now 1.17.6-1+b2 i386  [installé, local]
libhogweed6t64/now 3.9.1-2.2 i386  [installé, local]
libhwy1t64/now 1.0.7-8.1 i386  [installé, local]
libicu72/now 72.1-4+b1 i386  [installé, local]
libid3tag0/now 0.15.1b-14 i386  [installé, local]
libidn2-0/now 2.3.7-2 i386  [installé, local]
libigdgmm12/now 22.3.17+ds1-1 i386  [installé, local]
libinstpatch-1.0-2/now 1.1.6-1+b1 i386  [installé, local]
libip4tc2/now 1.8.10-3 i386  [installé, local]
libisl23/now 0.26-3+b2 i386  [installé, local]
libiso9660-11t64/now 2.1.0-4.1 i386  [installé, local]
libitm1/now 14-20240315-1 i386  [installé, local]
libixml10/now 1:1.8.4-2 i386  [installé, local]
libixml11t64/now 1:1.14.18-1.1 i386  [installé, local]
libjack-jackd2-0/now 1.9.21~dfsg-3+b3 i386  [installé, local]
libjansson4/now 2.14-2+b2 i386  [installé, local]
libjbig0/now 2.1-6.1+b1 i386  [installé, local]
libjemalloc2/now 5.3.0-2+b1 i386  [installé, local]
libjpeg62-turbo/now 1:2.1.5-2+b2 i386  [installé, local]
libjson-c5/now 0.17-1+b1 i386  [installé, local]
libjxl0.7/now 0.7.0-10.2+b2 i386  [installé, local]
libk5crypto3/now 1.20.1-6+b1 i386  [installé, local]
libkeyutils1/now 1.6.3-3 i386  [installé, local]
libklibc/now 2.0.13-4 i386  [installé, local]
libkmod2/now 32-1 i386  [installé, local]
libkrb5-3/now 1.20.1-6+b1 i386  [installé, local]
libkrb5support0/now 1.20.1-6+b1 i386  [installé, local]
libksba8/now 1.6.6-1 i386  [installé, local]
liblapack3/now 3.12.0-3 i386  [installé, local]
liblcms2-2/now 2.14-2+b1 i386  [installé, local]
libldap-2.5-0/now 2.5.16+dfsg-2 i386  [installé, local]
libldb2/now 2:2.8.0+samba4.19.5+dfsg-4+b2 i386  [installé, local]
liblerc4/now 4.0.0+ds-4+b1 i386  [installé, local]
liblilv-0-0/now 0.24.24-2 i386  [installé, local]
libllvm15/now 1:15.0.7-11 i386  [installé, local]
libllvm17t64/now 1:17.0.6-9 i386  [installé, local]
liblmdb0/now 0.9.31-1+b1 i386  [installé, local]
liblocale-gettext-perl/now 1.07-6+b2 i386  [installé, local]
liblockfile-bin/now 1.17-1+b1 i386  [installé, local]
liblvm2cmd2.03/now 2.03.22-1 i386  [installé, local]
liblz4-1/now 1.9.4-1+b2 i386  [installé, local]
liblzma5/now 5.6.1-1 i386  [installé, local]
libmad0/now 0.15.1b-10.1+b1 i386  [installé, local]
libmagic-mgc/now 1:5.45-3 i386  [installé, local]
libmagic1t64/now 1:5.45-3 i386  [installé, local]
libmaxminddb0/now 1.9.1-1 i386  [installé, local]
libmbedcrypto7t64/now 2.28.7-1.1 i386  [installé, local]
libmd0/now 1.1.0-2 i386  [installé, local]
libmikmod3/now 3.3.11.1-7 i386  [installé, local]
libmms0/now 0.6.4-3 i386  [installé, local]
libmnl0/now 1.0.5-2 i386  [installé, local]
libmodplug1/now 1:0.8.9.0-3 i386  [installé, local]
libmount1/now 2.39.3-11 i386  [installé, local]
libmp3lame0/now 3.100-6+b2 i386  [installé, local]
libmpc3/now 1.3.1-1+b2 i386  [installé, local]
libmpcdec6/now 2:0.1~r495-2 i386  [installé, local]
libmpdclient2t64/now 2.22-1.1 i386  [installé, local]
libmpfr6/now 4.2.1-1+b1 i386  [installé, local]
libmpg123-0/now 1.32.5-1+b1 i386  [installé, local]
libmysofa1/now 1.3.2+dfsg-2 i386  [installé, local]
libncursesw6/now 6.4+20240113-1 i386  [installé, local]
libnettle8t64/now 3.9.1-2.2 i386  [installé, local]
libnewt0.52/now 0.52.24-2 i386  [installé, local]
libnfs13/now 4.0.0-1 i386  [installé, local]
libnfs14/now 5.0.2-1 i386  [installé, local]
libnftables1/now 1.0.9-1+b2 i386  [installé, local]
libnftnl11/now 1.2.6-2 i386  [installé, local]
libnghttp2-14/now 1.59.0-1+b1 i386  [installé, local]
libnorm1t64/now 1.5.9+dfsg-3.1 i386  [installé, local]
libnpth0t64/now 1.6-3.1 i386  [installé, local]
libnsl-dev/now 1.3.0-3+b1 i386  [installé, local]
libnsl2/now 1.3.0-3+b1 i386  [installé, local]
libnss-systemd/now 255.4-1+b1 i386  [installé, local]
libnuma1/now 2.0.18-1 i386  [installé, local]
libogg0/now 1.3.5-3 i386  [installé, local]
libopenal1/now 1:1.23.1-4+b1 i386  [installé, local]
libopenjp2-7/now 2.5.0-2+b3 i386  [installé, local]
libopenmpt0t64/now 0.7.3-1.1+b1 i386  [installé, local]
libopus0/now 1.4-1+b1 i386  [installé, local]
libp11-kit0/now 0.25.3-4 i386  [installé, local]
libpam-modules-bin/now 1.5.3-6 i386  [installé, local]
libpam-modules/now 1.5.3-6 i386  [installé, local]
libpam-systemd/now 255.4-1+b1 i386  [installé, local]
libpam0g/now 1.5.3-6 i386  [installé, local]
libpango-1.0-0/now 1.52.1+ds-1 i386  [installé, local]
libpangocairo-1.0-0/now 1.52.1+ds-1 i386  [installé, local]
libpangoft2-1.0-0/now 1.52.1+ds-1 i386  [installé, local]
libpci3/now 1:3.11.1-1 i386  [installé, local]
libpciaccess0/now 0.17-3 i386  [installé, local]
libpcre2-8-0/now 10.42-4+b1 i386  [installé, local]
libperl5.36/now 5.36.0-7+deb12u1 i386  [installé, local]
libperl5.38t64/now 5.38.2-3.2 i386  [installé, local]
libpgm-5.3-0t64/now 5.3.128~dfsg-2.1 i386  [installé, local]
libpipeline1/now 1.5.7-1+b2 i386  [installé, local]
libpipewire-0.3-0t64/now 1.0.4-3 i386  [installé, local]
libpixman-1-0/now 0.42.2-1+b1 i386  [installé, local]
libplacebo338/now 6.338.2-2 i386  [installé, local]
libpng16-16t64/now 1.6.43-3 i386  [installé, local]
libpocketsphinx3/now 0.8+5prealpha+1-15+b3 i386  [installé, local]
libpopt0/now 1.19+dfsg-1+b1 i386  [installé, local]
libpostproc57/now 7:6.1.1-3 i386  [installé, local]
libproc2-0/now 2:4.0.4-4 i386  [installé, local]
libprotobuf-c1/now 1.4.1-1+b2 i386  [installé, local]
libpsl5t64/now 0.21.2-1.1 i386  [installé, local]
libpulse0/now 16.1+dfsg1-3+b1 i386  [installé, local]
libpython3-stdlib/now 3.11.8-1 i386  [installé, local]
libpython3.11-minimal/now 3.11.8-3+b2 i386  [installé, local]
libpython3.11-stdlib/now 3.11.8-3+b2 i386  [installé, local]
libquadmath0/now 14-20240315-1 i386  [installé, local]
librabbitmq4/now 0.11.0-1+b2 i386  [installé, local]
librav1e0/now 0.7.1-2 i386  [installé, local]
libreadline8t64/now 8.2-4 i386  [installé, local]
librist4/now 0.2.10+dfsg-1+b2 i386  [installé, local]
librsvg2-2/now 2.57.92+dfsg-2 i386  [installé, local]
librsvg2-common/now 2.57.92+dfsg-2 i386  [installé, local]
librtmp1/now 2.4+20151223.gitfa8646d.1-2+b3 i386  [installé, local]
librubberband2/now 3.3.0+dfsg-2 i386  [installé, local]
libsamplerate0/now 0.2.2-4 i386  [installé, local]
libsasl2-2/now 2.1.28+dfsg1-6 i386  [installé, local]
libsasl2-modules-db/now 2.1.28+dfsg1-6 i386  [installé, local]
libsasl2-modules/now 2.1.28+dfsg1-6 i386  [installé, local]
libsdl2-2.0-0/now 2.30.1+dfsg-4 i386  [installé, local]
libseccomp2/now 2.5.5-1 i386  [installé, local]
libselinux1/now 3.5-2+b1 i386  [installé, local]
libsemanage2/now 3.5-1+b3 i386  [installé, local]
libsensors5/now 1:3.6.0-9 i386  [installé, local]
libsepol2/now 3.5-2 i386  [installé, local]
libserd-0-0/now 0.32.2-1 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libshine3/now 3.1.1-2+b1 i386  [installé, local]
libshout3/now 2.4.6-1+b2 i386  [installé, local]
libsidplayfp6/now 2.6.0-1 i386  [installé, local]
libslang2/now 2.3.3-4 i386  [installé, local]
libsmartcols1/now 2.39.3-11 i386  [installé, local]
libsmbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libsnappy1v5/now 1.1.10-1+b1 i386  [installé, local]
libsndfile1/now 1.2.2-1+b1 i386  [installé, local]
libsndio7.0/now 1.9.0-0.3+b4 i386  [installé, local]
libsodium23/now 1.0.18-1 i386  [installé, local]
libsord-0-0/now 0.16.16-2+b1 i386  [installé, local]
libsoxr0/now 0.1.3-4 i386  [installé, local]
libspa-0.2-modules/now 1.0.4-3 i386  [installé, local]
libspeex1/now 1.2.1-2+b1 i386  [installé, local]
libsphinxbase3t64/now 0.8+5prealpha+1-17 i386  [installé, local]
libsqlite3-0/now 3.45.2-1 i386  [installé, local]
libsratom-0-0/now 0.6.16-1+b1 i386  [installé, local]
libsrt1.5-gnutls/now 1.5.3-1+b2 i386  [installé, local]
libss2/now 1.47.0-2.4 i386  [installé, local]
libssh-gcrypt-4/now 0.10.6-2+b1 i386  [installé, local]
libssh2-1t64/now 1.11.0-4.1+b1 i386  [installé, local]
libssl3t64/now 3.1.5-1.1 i386  [installé, local]
libstdc++-12-dev/now 12.3.0-15 i386  [installé, local]
libstdc++-13-dev/now 13.2.0-21 i386  [installé, local]
libstdc++6/now 14-20240315-1 i386  [installé, local]
libsvtav1enc1d1/now 1.7.0+dfsg-2+b1 i386  [installé, local]
libswresample4/now 7:6.1.1-3 i386  [installé, local]
libswscale7/now 7:6.1.1-3 i386  [installé, local]
libsystemd-shared/now 255.4-1+b1 i386  [installé, local]
libsystemd0/now 255.4-1+b1 i386  [installé, local]
libtag1v5-vanilla/now 1.13.1-1+b1 i386  [installé, local]
libtag1v5/now 1.13.1-1+b1 i386  [installé, local]
libtalloc2/now 2.4.2-1+b1 i386  [installé, local]
libtasn1-6/now 4.19.0-3+b2 i386  [installé, local]
libtdb1/now 1.4.10-1 i386  [installé, local]
libtevent0t64/now 0.16.1-2 i386  [installé, local]
libtext-charwidth-perl/now 0.04-11+b3 i386  [installé, local]
libtext-iconv-perl/now 1.7-8+b3 i386  [installé, local]
libthai0/now 0.1.29-2 i386  [installé, local]
libtheora0/now 1.1.1+dfsg.1-16.1+b2 i386  [installé, local]
libtiff6/now 4.5.1+git230720-4 i386  [installé, local]
libtinfo6/now 6.4+20240113-1 i386  [installé, local]
libtirpc-dev/now 1.3.4+ds-1.2 i386  [installé, local]
libtirpc3t64/now 1.3.4+ds-1.2 i386  [installé, local]
libtwolame0/now 0.4.0-2+b1 i386  [installé, local]
libubsan1/now 14-20240315-1 i386  [installé, local]
libuchardet0/now 0.0.8-1+b1 i386  [installé, local]
libudev1/now 255.4-1+b1 i386  [installé, local]
libudfread0/now 1.1.2-1 i386  [installé, local]
libunibreak5/now 5.1-2 i386  [installé, local]
libunistring2/now 1.0-2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
libupnp13/now 1:1.8.4-2 i386  [installé, local]
libupnp17t64/now 1:1.14.18-1.1 i386  [installé, local]
liburcu8t64/now 0.14.0-3.1 i386  [installé, local]
liburing2/now 2.5-1 i386  [installé, local]
libusb-1.0-0/now 2:1.0.27-1 i386  [installé, local]
libuuid1/now 2.39.3-11 i386  [installé, local]
libuv1t64/now 1.48.0-1.1 i386  [installé, local]
libva-drm2/now 2.20.0-2 i386  [installé, local]
libva-x11-2/now 2.20.0-2 i386  [installé, local]
libva2/now 2.20.0-2 i386  [installé, local]
libvdpau-va-gl1/now 0.4.2-1+b1 i386  [installé, local]
libvdpau1/now 1.5-2 i386  [installé, local]
libvidstab1.1/now 1.1.0-2+b1 i386  [installé, local]
libvorbis0a/now 1.3.7-2 i386  [installé, local]
libvorbisenc2/now 1.3.7-2 i386  [installé, local]
libvorbisfile3/now 1.3.7-2 i386  [installé, local]
libvpx7/now 1.12.0-1+deb12u2 i386  [installé, local]
libvpx8/now 1.13.1-2 i386  [installé, local]
libvulkan1/now 1.3.275.0-1 i386  [installé, local]
libwavpack1/now 5.7.0-1 i386  [installé, local]
libwayland-client0/now 1.22.0-2.1+b1 i386  [installé, local]
libwayland-cursor0/now 1.22.0-2.1+b1 i386  [installé, local]
libwayland-egl1/now 1.22.0-2.1+b1 i386  [installé, local]
libwayland-server0/now 1.22.0-2.1+b1 i386  [installé, local]
libwbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libwebp7/now 1.3.2-0.4+b1 i386  [installé, local]
libwebpmux3/now 1.3.2-0.4+b1 i386  [installé, local]
libwebrtc-audio-processing1/now 0.3-1+b1 i386  [installé, local]
libwildmidi2/now 0.4.3-1+b2 i386  [installé, local]
libwrap0/now 7.6.q-32+b1 i386  [installé, local]
libx11-6/now 2:1.8.7-1 i386  [installé, local]
libx11-xcb1/now 2:1.8.7-1 i386  [installé, local]
libx264-164/now 2:0.164.3108+git31e19f9-1 i386  [installé, local]
libx265-199/now 3.5-2+b1 i386  [installé, local]
libxau6/now 1:1.0.9-1 i386  [installé, local]
libxcb-dri2-0/now 1.15-1 i386  [installé, local]
libxcb-dri3-0/now 1.15-1 i386  [installé, local]
libxcb-glx0/now 1.15-1 i386  [installé, local]
libxcb-present0/now 1.15-1 i386  [installé, local]
libxcb-randr0/now 1.15-1 i386  [installé, local]
libxcb-render0/now 1.15-1 i386  [installé, local]
libxcb-shm0/now 1.15-1 i386  [installé, local]
libxcb-sync1/now 1.15-1 i386  [installé, local]
libxcb-xfixes0/now 1.15-1 i386  [installé, local]
libxcb1/now 1.15-1 i386  [installé, local]
libxcursor1/now 1:1.2.1-1 i386  [installé, local]
libxdmcp6/now 1:1.1.2-3 i386  [installé, local]
libxext6/now 2:1.3.4-1+b1 i386  [installé, local]
libxfixes3/now 1:6.0.0-2 i386  [installé, local]
libxi6/now 2:1.8.1-1 i386  [installé, local]
libxkbcommon0/now 1.6.0-1 i386  [installé, local]
libxml2/now 2.9.14+dfsg-1.3+b2 i386  [installé, local]
libxmuu1/now 2:1.1.3-3+b1 i386  [installé, local]
libxpm4/now 1:3.5.17-1+b1 i386  [installé, local]
libxrandr2/now 2:1.5.4-1 i386  [installé, local]
libxrender1/now 1:0.9.10-1.1 i386  [installé, local]
libxshmfence1/now 1.3-1 i386  [installé, local]
libxss1/now 1:1.2.3-1 i386  [installé, local]
libxtables12/now 1.8.10-3 i386  [installé, local]
libxvidcore4/now 2:1.3.7-1+b1 i386  [installé, local]
libxxf86vm1/now 1:1.1.4-1+b2 i386  [installé, local]
libxxhash0/now 0.8.2-2+b1 i386  [installé, local]
libyajl2/now 2.1.0-5+b1 i386  [installé, local]
libyuv0/now 0.0~git202401110.af6ac82-1 i386  [installé, local]
libz3-4/now 4.8.12-3.1+b2 i386  [installé, local]
libzimg2/now 3.0.5+ds1-1+b1 i386  [installé, local]
libzix-0-0/now 0.4.2-2+b1 i386  [installé, local]
libzmq5/now 4.3.5-1+b2 i386  [installé, local]
libzstd1/now 1.5.5+dfsg2-2 i386  [installé, local]
libzvbi0t64/now 0.2.42-2 i386  [installé, local]
libzzip-0-13t64/now 0.13.72+dfsg.1-1.2 i386  [installé, local]
linux-image-6.1.0-10-686-pae/now 6.1.38-2 i386  [installé, local]
linux-image-6.1.0-13-686-pae/now 6.1.55-1 i386  [installé, local]
linux-image-6.7.9-686-pae/now 6.7.9-2 i386  [installé, local]
linux-image-686-pae/now 6.7.9-2 i386  [installé, local]
linux-libc-dev/now 6.7.9-2 all  [installé, local]
login/now 1:4.13+dfsg1-4 i386  [installé, local]
logrotate/now 3.21.0-2 i386  [installé, local]
logsave/now 1.47.0-2.4 i386  [installé, local]
loudgain/now 0.6.8+ds-3+b2 i386  [installé, local]
lsof/now 4.95.0-1.1 i386  [installé, local]
lvm2/now 2.03.22-1 i386  [installé, local]
make/now 4.3-4.1 i386  [installé, local]
man-db/now 2.12.0-3+b1 i386  [installé, local]
mawk/now 1.3.4.20240123-1 i386  [installé, local]
mesa-va-drivers/now 24.0.3-1+b1 i386  [installé, local]
mesa-vdpau-drivers/now 24.0.3-1+b1 i386  [installé, local]
mesa-vulkan-drivers/now 24.0.3-1+b1 i386  [installé, local]
mount/now 2.39.3-11 i386  [installé, local]
mpd/now 0.23.14-2+b1 i386  [installé, local]
nano/now 7.2-2 i386  [installé, local]
ncurses-bin/now 6.4+20240113-1 i386  [installé, local]
netcat-traditional/now 1.10-48 i386  [installé, local]
nftables/now 1.0.9-1+b2 i386  [installé, local]
ocl-icd-libopencl1/now 2.3.2-1 i386  [installé, local]
openssh-client/now 1:9.7p1-2+b1 i386  [installé, local]
openssh-server/now 1:9.7p1-2+b1 i386  [installé, local]
openssh-sftp-server/now 1:9.7p1-2+b1 i386  [installé, local]
openssl/now 3.1.5-1.1 i386  [installé, local]
os-prober/now 1.81 i386  [installé, local]
passwd/now 1:4.13+dfsg1-4 i386  [installé, local]
patch/now 2.7.6-7 i386  [installé, local]
pciutils/now 1:3.11.1-1 i386  [installé, local]
perl-base/now 5.38.2-3.2 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
perl/now 5.38.2-3.2 i386  [installé, local]
pinentry-curses/now 1.2.1-3+b2 i386  [installé, local]
procps/now 2:4.0.4-4 i386  [installé, local]
python3-apt/now 2.7.7 i386  [installé, local]
python3-minimal/now 3.11.8-1 i386  [installé, local]
python3-pycurl/now 7.45.3-2 i386  [installé, local]
python3.11-minimal/now 3.11.8-3+b2 i386  [installé, local]
python3.11/now 3.11.8-3+b2 i386  [installé, local]
python3/now 3.11.8-1 i386  [installé, local]
rpcsvc-proto/now 1.4.3-1 i386  [installé, local]
rsync/now 3.2.7-1+b2 i386  [installé, local]
samba-libs/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
sed/now 4.9-2 i386  [installé, local]
shared-mime-info/now 2.4-3 i386  [installé, local]
sudo/now 1.9.15p5-3+b1 i386  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]
systemd-sysv/now 255.4-1+b1 i386  [installé, local]
systemd-timesyncd/now 255.4-1+b1 i386  [installé, local]
systemd/now 255.4-1+b1 i386  [installé, local]
sysvinit-utils/now 3.08-7 i386  [installé, local]
tar/now 1.35+dfsg-3 i386  [installé, local]
traceroute/now 1:2.1.5-1 i386  [installé, local]
udev/now 255.4-1+b1 i386  [installé, local]
usbutils/now 1:017-3 i386  [installé, local]
util-linux-extra/now 2.39.3-11 i386  [installé, local]
util-linux/now 2.39.3-11 i386  [installé, local]
va-driver-all/now 2.20.0-2 i386  [installé, local]
vdpau-driver-all/now 1.5-2 i386  [installé, local]
vim-tiny/now 2:9.1.0199-1 i386  [installé, local]
wget/now 1.24.5-1 i386  [installé, local]
whiptail/now 0.52.24-2 i386  [installé, local]
xauth/now 1:1.1.2-1 i386  [installé, local]
xdg-user-dirs/now 0.18-1 i386  [installé, local]
xz-utils/now 5.6.1-1 i386  [installé, local]
zlib1g/now 1:1.3.dfsg-3.1 i386  [installé, local]
zstd/now 1.5.5+dfsg2-2 i386  [installé, local]
 



Il me semble étonnant de voir les paquets qu'à partir de g++. je pense que via le terminal de remmina les lignes visible soit comptées.
Bref. Si je dois désinstaller un par un tout ça et réinstaller après, je pense qu'il sera plus rapide de faire une réinstalle propre.

A moins qu'il y ait une méthode pour désintaller/réinstaller en "groupe"?

Dernière modification par wardidi (02-04-2024 12:45:50)

Hors ligne

#13 02-04-2024 14:32:39

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

Tu n’as pas tout ça à désinstaller, ils sont listés parce que le fichier de sources proposé dans mon guide n’inclut pas l’architecture i386.

Pour corriger ça, remplace chaque occurrence de cette ligne :

Architectures: amd64

par celle-ci :

Architectures: amd64 i386



Si ton système est en 32-bit, tu peux la remplacer plutôt par :

Architectures: i386


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#14 02-04-2024 15:34:47

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

vv222 a écrit :


Pour corriger ça, remplace chaque occurrence de cette ligne :

Architectures: amd64

par celle-ci :

Architectures: amd64 i386



Bonjour vv222 et merci pour ton suivi.

Je suis en 64bits. après avoir ajouté i386 dans les sources et fais un update, j'obtiens maintenant:

apt list '?obsolete'



En train de lister... Fait
amd64-microcode/now 3.20230808.1.1~deb12u1 i386  [installé, local]
cpp-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
cpp-13/now 13.2.0-21 i386  [installé, local]
cpp-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
firmware-amd-graphics/now 20230210-5 all  [installé, local]
fonts-dejavu-mono/now 2.37-8 all  [installé, local]
g++-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
g++-13/now 13.2.0-21 i386  [installé, local]
g++-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
gcc-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
libabsl20220623t64/now 20220623.1-3.1 i386  [installé, local]
libapt-pkg6.0t64/now 2.7.14 i386  [installé, local]
libasound2t64/now 1.2.11-1+b1 i386  [installé, local]
libatopology2t64/now 1.2.11-1+b1 i386  [installé, local]
libavcodec60/now 7:6.1.1-3 i386  [installé, local]
libavfilter9/now 7:6.1.1-3 i386  [installé, local]
libavformat60/now 7:6.1.1-3 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libavutil58/now 7:6.1.1-3 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcdio-cdda2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio-paranoia2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio19t64/now 2.1.0-4.1 i386  [installé, local]
libcodec2-1.2/now 1.2.0-2+b1 i386  [installé, local]
libcurl3t64-gnutls/now 8.7.1-1 i386  [installé, local]
libcurl4t64/now 8.7.1-1 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libdb5.3t64/now 5.3.28+dfsg2-6 i386  [installé, local]
libefiboot1t64/now 38-3.1 i386  [installé, local]
libefivar1t64/now 38-3.1 i386  [installé, local]
libelf1t64/now 0.191-1 i386  [installé, local]
libext2fs2t64/now 1.47.0-2.4 i386  [installé, local]
libflac12t64/now 1.4.3+ds-2.1 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libgdbm-compat4t64/now 1.23-5.1+b1 i386  [installé, local]
libgdbm6t64/now 1.23-5.1+b1 i386  [installé, local]
libglib2.0-0t64/now 2.78.4-6 i386  [installé, local]
libgnutls30t64/now 3.8.3-1.1+b1 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libhogweed6t64/now 3.9.1-2.2 i386  [installé, local]
libhwy1t64/now 1.0.7-8.1 i386  [installé, local]
libiso9660-11t64/now 2.1.0-4.1 i386  [installé, local]
libixml11t64/now 1:1.14.18-1.1 i386  [installé, local]
libllvm17t64/now 1:17.0.6-9 i386  [installé, local]
libmagic1t64/now 1:5.45-3 i386  [installé, local]
libmbedcrypto7t64/now 2.28.7-1.1 i386  [installé, local]
libmpdclient2t64/now 2.22-1.1 i386  [installé, local]
libnettle8t64/now 3.9.1-2.2 i386  [installé, local]
libnfs14/now 5.0.2-1 i386  [installé, local]
libnorm1t64/now 1.5.9+dfsg-3.1 i386  [installé, local]
libnpth0t64/now 1.6-3.1 i386  [installé, local]
libopenmpt0t64/now 0.7.3-1.1+b1 i386  [installé, local]
libperl5.38t64/now 5.38.2-3.2 i386  [installé, local]
libpgm-5.3-0t64/now 5.3.128~dfsg-2.1 i386  [installé, local]
libpipewire-0.3-0t64/now 1.0.4-3 i386  [installé, local]
libplacebo338/now 6.338.2-2 i386  [installé, local]
libpng16-16t64/now 1.6.43-3 i386  [installé, local]
libpostproc57/now 7:6.1.1-3 i386  [installé, local]
libpsl5t64/now 0.21.2-1.1 i386  [installé, local]
libreadline8t64/now 8.2-4 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libsmbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libsphinxbase3t64/now 0.8+5prealpha+1-17 i386  [installé, local]
libssh2-1t64/now 1.11.0-4.1+b1 i386  [installé, local]
libssl3t64/now 3.1.5-1.1 i386  [installé, local]
libstdc++-13-dev/now 13.2.0-21 i386  [installé, local]
libsvtav1enc1d1/now 1.7.0+dfsg-2+b1 i386  [installé, local]
libswscale7/now 7:6.1.1-3 i386  [installé, local]
libtevent0t64/now 0.16.1-2 i386  [installé, local]
libtirpc3t64/now 1.3.4+ds-1.2 i386  [installé, local]
libunibreak5/now 5.1-2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
libupnp17t64/now 1:1.14.18-1.1 i386  [installé, local]
liburcu8t64/now 0.14.0-3.1 i386  [installé, local]
libuv1t64/now 1.48.0-1.1 i386  [installé, local]
libvpx8/now 1.13.1-2 i386  [installé, local]
libzix-0-0/now 0.4.2-2+b1 i386  [installé, local]
libzvbi0t64/now 0.2.42-2 i386  [installé, local]
libzzip-0-13t64/now 0.13.72+dfsg.1-1.2 i386  [installé, local]
linux-image-6.1.0-10-686-pae/now 6.1.38-2 i386  [installé, local]
linux-image-6.1.0-13-686-pae/now 6.1.55-1 i386  [installé, local]
linux-image-6.7.9-686-pae/now 6.7.9-2 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]
 



Donc si j'ai bien compris , je fais

sudo apt-get -y autoremove amd64-microcode cpp-13-i686-linux-gnu ET TOUS LES AUTRES PAQUETS



Et je prends soins de sauvegarder cette liste que je devrais réinstaller plus tard avec

sudo apt-get install

.

J'attends ta réponse pour avancer. Merci

Dernière modification par wardidi (02-04-2024 15:45:40)

Hors ligne

#15 02-04-2024 17:16:16

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

Je vois amd64-microcode et firmware-amd-graphics dans la liste, qui peuvent être utiles. Si tu utilises bien un CPU et un GPU AMD, tu peux en avoir besoin.

Dans ce cas il faut remplacer :

Components: main

par

Components: main non-free-firmware


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#16 02-04-2024 18:25:39

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

vv222 a écrit :



Dans ce cas il faut remplacer :

Components: main

par

Components: main non-free-firmware



CPU et GPU sont bien amd.
Ajout des non free fait et update fait.

~$ apt list '?obsolete'
En train de lister... Fait
cpp-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
cpp-13/now 13.2.0-21 i386  [installé, local]
cpp-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
fonts-dejavu-mono/now 2.37-8 all  [installé, local]
g++-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
g++-13/now 13.2.0-21 i386  [installé, local]
g++-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
gcc-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
libabsl20220623t64/now 20220623.1-3.1 i386  [installé, local]
libapt-pkg6.0t64/now 2.7.14 i386  [installé, local]
libasound2t64/now 1.2.11-1+b1 i386  [installé, local]
libatopology2t64/now 1.2.11-1+b1 i386  [installé, local]
libavcodec60/now 7:6.1.1-3 i386  [installé, local]
libavfilter9/now 7:6.1.1-3 i386  [installé, local]
libavformat60/now 7:6.1.1-3 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libavutil58/now 7:6.1.1-3 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcdio-cdda2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio-paranoia2t64/now 10.2+2.0.1-1.1 i386  [installé, local]
libcdio19t64/now 2.1.0-4.1 i386  [installé, local]
libcodec2-1.2/now 1.2.0-2+b1 i386  [installé, local]
libcurl3t64-gnutls/now 8.7.1-1 i386  [installé, local]
libcurl4t64/now 8.7.1-1 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libdb5.3t64/now 5.3.28+dfsg2-6 i386  [installé, local]
libefiboot1t64/now 38-3.1 i386  [installé, local]
libefivar1t64/now 38-3.1 i386  [installé, local]
libelf1t64/now 0.191-1 i386  [installé, local]
libext2fs2t64/now 1.47.0-2.4 i386  [installé, local]
libflac12t64/now 1.4.3+ds-2.1 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libgdbm-compat4t64/now 1.23-5.1+b1 i386  [installé, local]
libgdbm6t64/now 1.23-5.1+b1 i386  [installé, local]
libglib2.0-0t64/now 2.78.4-6 i386  [installé, local]
libgnutls30t64/now 3.8.3-1.1+b1 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libhogweed6t64/now 3.9.1-2.2 i386  [installé, local]
libhwy1t64/now 1.0.7-8.1 i386  [installé, local]
libiso9660-11t64/now 2.1.0-4.1 i386  [installé, local]
libixml11t64/now 1:1.14.18-1.1 i386  [installé, local]
libllvm17t64/now 1:17.0.6-9 i386  [installé, local]
libmagic1t64/now 1:5.45-3 i386  [installé, local]
libmbedcrypto7t64/now 2.28.7-1.1 i386  [installé, local]
libmpdclient2t64/now 2.22-1.1 i386  [installé, local]
libnettle8t64/now 3.9.1-2.2 i386  [installé, local]
libnfs14/now 5.0.2-1 i386  [installé, local]
libnorm1t64/now 1.5.9+dfsg-3.1 i386  [installé, local]
libnpth0t64/now 1.6-3.1 i386  [installé, local]
libopenmpt0t64/now 0.7.3-1.1+b1 i386  [installé, local]
libperl5.38t64/now 5.38.2-3.2 i386  [installé, local]
libpgm-5.3-0t64/now 5.3.128~dfsg-2.1 i386  [installé, local]
libpipewire-0.3-0t64/now 1.0.4-3 i386  [installé, local]
libplacebo338/now 6.338.2-2 i386  [installé, local]
libpng16-16t64/now 1.6.43-3 i386  [installé, local]
libpostproc57/now 7:6.1.1-3 i386  [installé, local]
libpsl5t64/now 0.21.2-1.1 i386  [installé, local]
libreadline8t64/now 8.2-4 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libsmbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libsphinxbase3t64/now 0.8+5prealpha+1-17 i386  [installé, local]
libssh2-1t64/now 1.11.0-4.1+b1 i386  [installé, local]
libssl3t64/now 3.1.5-1.1 i386  [installé, local]
libstdc++-13-dev/now 13.2.0-21 i386  [installé, local]
libsvtav1enc1d1/now 1.7.0+dfsg-2+b1 i386  [installé, local]
libswscale7/now 7:6.1.1-3 i386  [installé, local]
libtevent0t64/now 0.16.1-2 i386  [installé, local]
libtirpc3t64/now 1.3.4+ds-1.2 i386  [installé, local]
libunibreak5/now 5.1-2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
libupnp17t64/now 1:1.14.18-1.1 i386  [installé, local]
liburcu8t64/now 0.14.0-3.1 i386  [installé, local]
libuv1t64/now 1.48.0-1.1 i386  [installé, local]
libvpx8/now 1.13.1-2 i386  [installé, local]
libzix-0-0/now 0.4.2-2+b1 i386  [installé, local]
libzvbi0t64/now 0.2.42-2 i386  [installé, local]
libzzip-0-13t64/now 0.13.72+dfsg.1-1.2 i386  [installé, local]
linux-image-6.1.0-10-686-pae/now 6.1.38-2 i386  [installé, local]
linux-image-6.1.0-13-686-pae/now 6.1.55-1 i386  [installé, local]
linux-image-6.7.9-686-pae/now 6.7.9-2 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]
 

Hors ligne

#17 02-04-2024 19:41:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

Il vaut mieux ignorer tous les paquets avec un nom en "lib*t64", ils devraient être remplacés automatiquement lors des opérations suivantes. Tu peux aussi ignorer les paquet "linux-image-*", qui ne devraient pas gêner le retour en arrière.

Ce qui nous donne une liste un peu plus courte :

cpp-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
cpp-13/now 13.2.0-21 i386  [installé, local]
cpp-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
fonts-dejavu-mono/now 2.37-8 all  [installé, local]
g++-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
g++-13/now 13.2.0-21 i386  [installé, local]
g++-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
gcc-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
libavcodec60/now 7:6.1.1-3 i386  [installé, local]
libavfilter9/now 7:6.1.1-3 i386  [installé, local]
libavformat60/now 7:6.1.1-3 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libavutil58/now 7:6.1.1-3 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcodec2-1.2/now 1.2.0-2+b1 i386  [installé, local]
libcurl3t64-gnutls/now 8.7.1-1 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libnfs14/now 5.0.2-1 i386  [installé, local]
libplacebo338/now 6.338.2-2 i386  [installé, local]
libpostproc57/now 7:6.1.1-3 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libsmbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libstdc++-13-dev/now 13.2.0-21 i386  [installé, local]
libsvtav1enc1d1/now 1.7.0+dfsg-2+b1 i386  [installé, local]
libswscale7/now 7:6.1.1-3 i386  [installé, local]
libunibreak5/now 5.1-2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
libvpx8/now 1.13.1-2 i386  [installé, local]
libzix-0-0/now 0.4.2-2+b1 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]



Pour les paquets que tu ne reconnais pas, aptitude permet de savoir pourquoi un paquet a été installé, par exemple :

aptitude why libavif16

i   php-gd    Dépend php8.2-gd          
i A php8.2-gd Dépend libgd3 (>= 2.3.3)  
i A libgd3    Dépend libavif16 (>= 1.0.4)



Dans ton cas je pense qu’aucun des paquets qui restent ne bloquera le retour en arrière, donc tu peux passer à l’étape suivante "Forcer le rétrogradage du système".


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#18 02-04-2024 20:07:10

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

Merci vv222 mais j'ai un doute

vv222 a écrit :

Dans ton cas je pense qu’aucun des paquets qui restent ne bloquera le retour en arrière, donc tu peux passer à l’étape suivante "Forcer le rétrogradage du système".


je force le retrogradage tout de suite ou je supprime avant les paquets que tu donnes ci-dessous?

vv222 a écrit :



Ce qui nous donne une liste un peu plus courte :

cpp-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
cpp-13/now 13.2.0-21 i386  [installé, local]
cpp-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
fonts-dejavu-mono/now 2.37-8 all  [installé, local]
g++-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
g++-13/now 13.2.0-21 i386  [installé, local]
g++-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
gcc-i686-linux-gnu/now 4:13.2.0-7 i386  [installé, local]
libavcodec60/now 7:6.1.1-3 i386  [installé, local]
libavfilter9/now 7:6.1.1-3 i386  [installé, local]
libavformat60/now 7:6.1.1-3 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libavutil58/now 7:6.1.1-3 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcodec2-1.2/now 1.2.0-2+b1 i386  [installé, local]
libcurl3t64-gnutls/now 8.7.1-1 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libnfs14/now 5.0.2-1 i386  [installé, local]
libplacebo338/now 6.338.2-2 i386  [installé, local]
libpostproc57/now 7:6.1.1-3 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libsmbclient0/now 2:4.19.5+dfsg-4+b2 i386  [installé, local]
libstdc++-13-dev/now 13.2.0-21 i386  [installé, local]
libsvtav1enc1d1/now 1.7.0+dfsg-2+b1 i386  [installé, local]
libswscale7/now 7:6.1.1-3 i386  [installé, local]
libunibreak5/now 5.1-2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
libvpx8/now 1.13.1-2 i386  [installé, local]
libzix-0-0/now 0.4.2-2+b1 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]




Si oui avec

sudo apt-get -y autoremove

?

merci encore pour l'aide

Dernière modification par wardidi (02-04-2024 20:07:42)

Hors ligne

#19 03-04-2024 10:35:29

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

On peut en retirer au moins une partie, ça permettra de passer à la suite de manière plus tranquille.

On a en particulier toute la liste des paquets liés à gcc 13 qui peuvent être retirés au profit de gcc 12. Pour commencer il faut comprendre ce qui a causé leur installation, ce qu’on peut savoir avec :

aptitude why gcc-13



Il y a aussi la liste des bibliothèques liées à ffmpeg (paquets avec des noms en "libav*") qui peuvent probablement être réinstallés dans des versions antérieures. Pour ceux-ci il faut commencer par :

aptitude why libavcodec60



Je pense qu’en se concentrant juste sur ces deux séries de paquets, on devrait pouvoir réduire de moitié la longueur de la liste des paquets introuvables dans les dépôts de Bookworm.


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#20 03-04-2024 11:39:24

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

J'ai installé aptitude qui ne l'était pas.

~$ aptitude why gcc-13


i   build-essential Dépend gcc (>= 4:12.3)      
i A gcc             Dépend gcc-13 (>= 13.2.0-11~)
 



~$ aptitude why libavcodec60



i   loudgain Dépend libavcodec60 (>= 7:6.0)
 



Loudgain avait été installé pour normaliser lecture MPD (solution donnée par toi ou captnfab il me semble).
Je pourrais donc le réinstallé sans problème.
Mpd est ma seule (actuelle) utilisation avec celle de stockage de sauvegarde.

Dernière modification par wardidi (03-04-2024 12:02:33)

Hors ligne

#21 03-04-2024 13:36:38

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

OK, on va donc commencer par ramener ces paquets dans leur version Bookworm :

apt install build-essential/bookworm
apt install --mark-auto gcc/bookworm
apt install loudgain/bookworm


Si ces trois commandes se déroulent sans erreur, à faire suivre de :

apt autoremove



Si les paquets gcc-13 et libavcodec60 sont encore installés après ça, tu peux chercher ce qui les maintient en place avec les commandes utilisées précédemment :

aptitude why gcc-13
aptitude why libavcodec60


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#22 03-04-2024 14:00:52

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : [Abandonné]downgrader trixie/sid vers bookworm

Salut,

wardidi a écrit :

1/ Pourquoi suis je passé d'une version stable à une version instable?


peut-être car tu as installé la version de loudgain de Trixie et Sid, vu que celle de Bookworm dépend de libavcodec59 ?

Hors ligne

#23 03-04-2024 14:32:03

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

~$ sudo apt install build-essential/bookworm



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Version choisie « 12.9 » (Debian:12.5/stable [i386]) pour « build-essential »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  g++-12 libavif15 libavutil57 libcbor0.8 libcodec2-1.0 libdav1d6 libfuse2 libglib2.0-0
  libixml10 libllvm15 libnfs13 libnsl-dev libperl5.36 libstdc++-12-dev libtirpc-dev
  libupnp13 libvpx7 linux-image-6.1.0-10-686-pae perl-modules-5.36
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  build-essential
0 mis à jour, 0 nouvellement installés, 1 remis à une version inférieure, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 7704 o dans les archives.
Après cette opération, 3072 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian bookworm/main i386 build-essential i386 12.9 [7704 B]
7704 o réceptionnés en 0s (29,0 ko/s)
dpkg: avertissement: dégradation (« downgrade ») de build-essential depuis 12.10 vers 12.9
(Lecture de la base de données... 55623 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../build-essential_12.9_i386.deb ...
Dépaquetage de build-essential (12.9) sur (12.10) ...
Paramétrage de build-essential (12.9) …




~$ sudo apt install --mark-auto gcc/bookworm


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Version choisie « 4:12.2.0-3 » (Debian:12.5/stable [i386]) pour « gcc »
Version choisie « 4:12.2.0-3 » (Debian:12.5/stable [i386]) pour « cpp » à cause de « gcc »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cpp-13 g++-12 g++-13 g++-13-i686-linux-gnu libavif15 libavutil57 libcbor0.8
  libcodec2-1.0 libdav1d6 libfuse2 libglib2.0-0 libixml10 libllvm15 libnfs13 libnsl-dev
  libperl5.36 libstdc++-12-dev libstdc++-13-dev libtirpc-dev libupnp13 libvpx7
  linux-image-6.1.0-10-686-pae perl-modules-5.36
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  cpp
Paquets suggérés :
  cpp-doc gcc-multilib autoconf automake libtool flex bison gdb gcc-doc
Les paquets suivants seront ENLEVÉS :
  build-essential cpp-i686-linux-gnu g++ g++-i686-linux-gnu gcc-i686-linux-gnu
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  cpp gcc
0 mis à jour, 0 nouvellement installés, 2 remis à une version inférieure, 5 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 12,1 ko dans les archives.
Après cette opération, 50,2 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian bookworm/main i386 cpp i386 4:12.2.0-3 [6844 B]
Réception de :2 http://deb.debian.org/debian bookworm/main i386 gcc i386 4:12.2.0-3 [5272 B]
12,1 ko réceptionnés en 0s (43,2 ko/s)
(Lecture de la base de données... 55623 fichiers et répertoires déjà installés.)
Suppression de build-essential (12.9) ...
Suppression de g++ (4:13.2.0-7) ...
Suppression de g++-i686-linux-gnu (4:13.2.0-7) ...
dpkg: cpp-i686-linux-gnu : problèmes de dépendance, mais suppression comme demandé :
 gcc-i686-linux-gnu dépend de cpp-i686-linux-gnu (= 4:13.2.0-7).
 gcc dépend de cpp-i686-linux-gnu (= 4:13.2.0-7).
 cpp dépend de cpp-i686-linux-gnu (= 4:13.2.0-7).

Suppression de cpp-i686-linux-gnu (4:13.2.0-7) ...
dpkg: avertissement: dégradation (« downgrade ») de cpp depuis 4:13.2.0-7 vers 4:12.2.0-3
(Lecture de la base de données... 55604 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../cpp_4%3a12.2.0-3_i386.deb ...
Dépaquetage de cpp (4:12.2.0-3) sur (4:13.2.0-7) ...
dpkg: avertissement: dégradation (« downgrade ») de gcc depuis 4:13.2.0-7 vers 4:12.2.0-3
Préparation du dépaquetage de .../gcc_4%3a12.2.0-3_i386.deb ...
Dépaquetage de gcc (4:12.2.0-3) sur (4:13.2.0-7) ...
Remplacés par des fichiers du paquet gcc-i686-linux-gnu (4:13.2.0-7) déjà installé...
dpkg: avertissement: impossible de supprimer l'ancien répertoire  « /usr/share/doc/cpp-i686-
linux-gnu » : Le dossier n'est pas vide
(Lecture de la base de données... 55619 fichiers et répertoires déjà installés.)
Suppression de gcc-i686-linux-gnu (4:13.2.0-7) ...
Paramétrage de cpp (4:12.2.0-3) ...
Paramétrage de gcc (4:12.2.0-3) ...
Traitement des actions différées (« triggers ») pour man-db (2.12.0-3+b1) ...



~$ sudo apt install loudgain/bookworm


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Version choisie « 0.6.8+ds-3+b1 » (Debian:12.5/stable [i386]) pour « loudgain »
Version choisie « 7:5.1.4-0+deb12u1 » (Debian:12.5/stable, Debian-Security:12/stable-security [i386]) pour « libavcodec59 » à cause de « loudgain »
Version choisie « 0.2.41-1 » (Debian:12.5/stable [i386]) pour « libzvbi0 » à cause de « libavcodec59 »
Version choisie « 0.2.41-1 » (Debian:12.5/stable [all]) pour « libzvbi-common » à cause de « libzvbi0 »
Version choisie « 7:5.1.4-0+deb12u1 » (Debian:12.5/stable, Debian-Security:12/stable-security [i386]) pour « libavformat59 » à cause de « loudgain »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  cpp-13 g++-12 g++-13 g++-13-i686-linux-gnu javascript-common libadplug-2.3.3-0
  libao-common libao4 libass9 libasyncns0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavif15 libavutil58 libbinio1v5 libblas3 libbs2b0 libcbor0.8
  libcdio-cdda2t64 libcdio-paranoia2t64 libcdio19t64 libcodec2-1.2 libcurl3t64-gnutls
  libdecor-0-0 libdecor-0-plugin-1-cairo libfaad2 libfftw3-double3 libflac12t64 libflite1
  libfluidsynth3 libfmt9 libfuse2 libgbm1 libgfortran5 libid3tag0 libinstpatch-1.0-2
  libiso9660-11t64 libixml10 libixml11t64 libjack-jackd2-0 libjs-jquery libjs-sphinxdoc
  libjs-underscore liblapack3 libldb2 liblilv-0-0 libllvm15 libmad0 libmikmod3 libmms0
  libmodplug1 libmpcdec6 libmpdclient2t64 libmysofa1 libnfs13 libnfs14 libnsl-dev
  libopenal-data libopenal1 libperl5.36 libpipewire-0.3-0t64 libpipewire-0.3-common
  libplacebo338 libpocketsphinx3 libpostproc57 libpulse0 librubberband2 libsdl2-2.0-0
  libserd-0-0 libshout3 libsidplayfp6 libsmbclient0 libsndfile1 libsndio7.0 libsord-0-0
  libspa-0.2-modules libsphinxbase3t64 libsratom-0-0 libstdc++-12-dev libstdc++-13-dev
  libswscale7 libtalloc2 libtdb1 libtevent0t64 libtirpc-dev libunibreak5 libupnp13
  libupnp17t64 liburing2 libvidstab1.1 libvpx8 libwavpack1 libwayland-cursor0
  libwayland-egl1 libwayland-server0 libwbclient0 libwebrtc-audio-processing1 libwildmidi2
  libxcursor1 libxi6 libxkbcommon0 libxrandr2 libxss1 libyajl2 libzimg2 libzix-0-0
  libzzip-0-13t64 linux-image-6.1.0-10-686-pae perl-modules-5.36 pocketsphinx-en-us
  samba-libs timgm6mb-soundfont x11-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libavcodec59 libavformat59 libsvtav1enc1 libswresample4
Paquets suggérés :
  libcuda1 libnvcuvid1 libnvidia-encode1
Les paquets suivants seront ENLEVÉS :
  libavcodec60 libavfilter9 libavformat60 libsvtav1enc1d1 mpd
Les NOUVEAUX paquets suivants seront installés :
  libavcodec59 libavformat59 libsvtav1enc1
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  libswresample4 loudgain
0 mis à jour, 3 nouvellement installés, 2 remis à une version inférieure, 5 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/7482 ko dans les archives.
Après cette opération, 19,0 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
dpkg: avertissement: dégradation (« downgrade ») de loudgain depuis 0.6.8+ds-3+b2 vers 0.6.8
+ds-3+b1
(Lecture de la base de données... 55606 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../loudgain_0.6.8+ds-3+b1_i386.deb ...
Dépaquetage de loudgain (0.6.8+ds-3+b1) sur (0.6.8+ds-3+b2) ...
(Lecture de la base de données... 55606 fichiers et répertoires déjà installés.)
Suppression de mpd (0.23.14-2+b1) ...
dpkg: libavcodec60:i386 : problèmes de dépendance, mais suppression comme demandé :
 libavformat60:i386 dépend de libavcodec60 (= 7:6.1.1-3).
 libavfilter9:i386 dépend de libavcodec60 (= 7:6.1.1-3).

Suppression de libavcodec60:i386 (7:6.1.1-3) ...
Suppression de libsvtav1enc1d1:i386 (1.7.0+dfsg-2+b1) ...
Sélection du paquet libsvtav1enc1:i386 précédemment désélectionné.
(Lecture de la base de données... 55535 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsvtav1enc1_1.4.1+dfsg-1_i386.deb ...
Dépaquetage de libsvtav1enc1:i386 (1.4.1+dfsg-1) ...
(Lecture de la base de données... 55540 fichiers et répertoires déjà installés.)
Suppression de libavfilter9:i386 (7:6.1.1-3) ...
dpkg: avertissement: dégradation (« downgrade ») de libswresample4:i386 depuis 7:6.1.1-3 ver
s 7:5.1.4-0+deb12u1
(Lecture de la base de données... 55534 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libswresample4_7%3a5.1.4-0+deb12u1_i386.deb ...
Dépaquetage de libswresample4:i386 (7:5.1.4-0+deb12u1) sur (7:6.1.1-3) ...
Sélection du paquet libavcodec59:i386 précédemment désélectionné.
Préparation du dépaquetage de .../libavcodec59_7%3a5.1.4-0+deb12u1_i386.deb ...
Dépaquetage de libavcodec59:i386 (7:5.1.4-0+deb12u1) ...
Sélection du paquet libavformat59:i386 précédemment désélectionné.
Préparation du dépaquetage de .../libavformat59_7%3a5.1.4-0+deb12u1_i386.deb ...
Dépaquetage de libavformat59:i386 (7:5.1.4-0+deb12u1) ...
(Lecture de la base de données... 55546 fichiers et répertoires déjà installés.)
Suppression de libavformat60:i386 (7:6.1.1-3) ...
Paramétrage de libsvtav1enc1:i386 (1.4.1+dfsg-1) ...
Paramétrage de libswresample4:i386 (7:5.1.4-0+deb12u1) ...
Paramétrage de libavcodec59:i386 (7:5.1.4-0+deb12u1) ...
Paramétrage de libavformat59:i386 (7:5.1.4-0+deb12u1) ...
Paramétrage de loudgain (0.6.8+ds-3+b1) ...
Traitement des actions différées (« triggers ») pour man-db (2.12.0-3+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.37-15.1) ...




Comme tout c'est bien passé ,je fais

~$ sudo apt autoremove


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets suivants seront ENLEVÉS :
  cpp-13 g++-12 g++-13 g++-13-i686-linux-gnu javascript-common libadplug-2.3.3-0
  libao-common libao4 libass9 libasyncns0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavif15 libavutil58 libbinio1v5 libblas3 libbs2b0 libcbor0.8
  libcdio-cdda2t64 libcdio-paranoia2t64 libcdio19t64 libcodec2-1.2 libcurl3t64-gnutls
  libdecor-0-0 libdecor-0-plugin-1-cairo libfaad2 libfftw3-double3 libflac12t64 libflite1
  libfluidsynth3 libfmt9 libfuse2 libgbm1 libgfortran5 libid3tag0 libinstpatch-1.0-2
  libiso9660-11t64 libixml10 libixml11t64 libjack-jackd2-0 libjs-jquery libjs-sphinxdoc
  libjs-underscore liblapack3 libldb2 liblilv-0-0 libllvm15 libmad0 libmikmod3 libmms0
  libmodplug1 libmpcdec6 libmpdclient2t64 libmysofa1 libnfs13 libnfs14 libnsl-dev
  libopenal-data libopenal1 libperl5.36 libpipewire-0.3-0t64 libpipewire-0.3-common
  libplacebo338 libpocketsphinx3 libpostproc57 libpulse0 librubberband2 libsdl2-2.0-0
  libserd-0-0 libshout3 libsidplayfp6 libsmbclient0 libsndfile1 libsndio7.0 libsord-0-0
  libspa-0.2-modules libsphinxbase3t64 libsratom-0-0 libstdc++-12-dev libstdc++-13-dev
  libswscale7 libtalloc2 libtdb1 libtevent0t64 libtirpc-dev libunibreak5 libupnp13
  libupnp17t64 liburing2 libvidstab1.1 libvpx8 libwavpack1 libwayland-cursor0
  libwayland-egl1 libwayland-server0 libwbclient0 libwebrtc-audio-processing1 libwildmidi2
  libxcursor1 libxi6 libxkbcommon0 libxrandr2 libxss1 libyajl2 libzimg2 libzix-0-0
  libzzip-0-13t64 linux-image-6.1.0-10-686-pae perl-modules-5.36 pocketsphinx-en-us
  samba-libs timgm6mb-soundfont x11-common
0 mis à jour, 0 nouvellement installés, 114 à enlever et 0 non mis à jour.
Après cette opération, 650 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 55540 fichiers et répertoires déjà installés.)
Suppression de cpp-13 (13.2.0-21) ...
Suppression de g++-12 (12.3.0-15) ...
Suppression de g++-13 (13.2.0-21) ...
Suppression de g++-13-i686-linux-gnu (13.2.0-21) ...
Suppression de javascript-common (11+nmu1) ...
Suppression de libadplug-2.3.3-0 (2.3.3+dfsg-2) ...
Suppression de libao4:i386 (1.2.2+20180113-1.1) ...
Suppression de libao-common (1.2.2+20180113-1.1) ...
Suppression de libass9:i386 (1:0.17.1-2) ...
Suppression de libfluidsynth3:i386 (2.3.4-1+b3) ...
Suppression de libmikmod3:i386 (3.3.11.1-7) ...
Suppression de libsdl2-2.0-0:i386 (2.30.1+dfsg-4) ...
Suppression de libpocketsphinx3:i386 (0.8+5prealpha+1-15+b3) ...
Suppression de libsphinxbase3t64:i386 (0.8+5prealpha+1-17) ...
Suppression de libpulse0:i386 (16.1+dfsg1-3+b1) ...
Suppression de libasyncns0:i386 (0.8-6+b3) ...
Suppression de libsmbclient0:i386 (2:4.19.5+dfsg-4+b2) ...
Suppression de samba-libs:i386 (2:4.19.5+dfsg-4+b2) ...
Suppression de libavahi-client3:i386 (0.8-13+b2) ...
Suppression de libavahi-common3:i386 (0.8-13+b2) ...
Suppression de libavahi-common-data:i386 (0.8-13+b2) ...
Suppression de libavif15:i386 (0.11.1-1) ...
Suppression de libpostproc57:i386 (7:6.1.1-3) ...
Suppression de libswscale7:i386 (7:6.1.1-3) ...
Suppression de libavutil58:i386 (7:6.1.1-3) ...
Suppression de libbinio1v5:i386 (1.5+dfsg-0.1) ...
Suppression de liblapack3:i386 (3.12.0-3) ...
Suppression de libblas3:i386 (3.12.0-3) ...
Suppression de libbs2b0:i386 (3.1.0+dfsg-8) ...
Suppression de libcbor0.8:i386 (0.8.0-2+b1) ...
Suppression de libcdio-paranoia2t64:i386 (10.2+2.0.1-1.1) ...
Suppression de libcdio-cdda2t64:i386 (10.2+2.0.1-1.1) ...
Suppression de libiso9660-11t64:i386 (2.1.0-4.1) ...
Suppression de libcdio19t64:i386 (2.1.0-4.1) ...
Suppression de libcodec2-1.2:i386 (1.2.0-2+b1) ...
Suppression de libcurl3t64-gnutls:i386 (8.7.1-1) ...
Suppression de libdecor-0-plugin-1-cairo:i386 (0.2.2-1+b1) ...
Suppression de libdecor-0-0:i386 (0.2.2-1+b1) ...
Suppression de libfaad2:i386 (2.11.1-1+b1) ...
Suppression de librubberband2:i386 (3.3.0+dfsg-2) ...
Suppression de libfftw3-double3:i386 (3.3.10-1+b2) ...
Suppression de libinstpatch-1.0-2:i386 (1.1.6-1+b1) ...
Suppression de libsndfile1:i386 (1.2.2-1+b1) ...
Suppression de libflac12t64:i386 (1.4.3+ds-2.1) ...
Suppression de libflite1:i386 (2.2-6+b2) ...
Suppression de libfmt9:i386 (9.1.0+ds1-2) ...
Suppression de libfuse2:i386 (2.9.9-8+b1) ...
Suppression de libgbm1:i386 (24.0.3-1+b1) ...
Suppression de libgfortran5:i386 (14-20240315-1) ...
Suppression de libid3tag0:i386 (0.15.1b-14) ...
Suppression de libupnp13:i386 (1:1.8.4-2) ...
Suppression de libixml10:i386 (1:1.8.4-2) ...
Suppression de libupnp17t64:i386 (1:1.14.18-1.1) ...
Suppression de libixml11t64:i386 (1:1.14.18-1.1) ...
Suppression de libjack-jackd2-0:i386 (1.9.21~dfsg-3+b3) ...
Suppression de libjs-sphinxdoc (7.2.6-6) ...
Suppression de libjs-jquery (3.6.1+dfsg+~3.5.14-1) ...
Suppression de libjs-underscore (1.13.4~dfsg+~1.11.4-3) ...
Suppression de libldb2:i386 (2:2.8.0+samba4.19.5+dfsg-4+b2) ...
Suppression de liblilv-0-0:i386 (0.24.24-2) ...
Suppression de libllvm15:i386 (1:15.0.7-11) ...
Suppression de libmad0:i386 (0.15.1b-10.1+b1) ...
Suppression de libmms0:i386 (0.6.4-3) ...
Suppression de libmodplug1:i386 (1:0.8.9.0-3) ...
Suppression de libmpcdec6:i386 (2:0.1~r495-2) ...
Suppression de libmpdclient2t64:i386 (2.22-1.1) ...
Suppression de libmysofa1:i386 (1.3.2+dfsg-2) ...
Suppression de libnfs13:i386 (4.0.0-1) ...
Suppression de libnfs14:i386 (5.0.2-1) ...
Suppression de libnsl-dev:i386 (1.3.0-3+b1) ...
Suppression de libopenal1:i386 (1:1.23.1-4+b1) ...
Suppression de libopenal-data (1:1.23.1-4) ...
Suppression de libperl5.36:i386 (5.36.0-7+deb12u1) ...
Suppression de libpipewire-0.3-0t64:i386 (1.0.4-3) ...
Suppression de libpipewire-0.3-common (1.0.4-3) ...
Suppression de libplacebo338:i386 (6.338.2-2) ...
Suppression de libsratom-0-0:i386 (0.6.16-1+b1) ...
Suppression de libsord-0-0:i386 (0.16.16-2+b1) ...
Suppression de libserd-0-0:i386 (0.32.2-1) ...
Suppression de libshout3:i386 (2.4.6-1+b2) ...
Suppression de libsidplayfp6:i386 (2.6.0-1) ...
Suppression de libsndio7.0:i386 (1.9.0-0.3+b4) ...
Suppression de libspa-0.2-modules:i386 (1.0.4-3) ...
Suppression de libstdc++-12-dev:i386 (12.3.0-15) ...
Suppression de libstdc++-13-dev:i386 (13.2.0-21) ...
Suppression de libtevent0t64:i386 (0.16.1-2) ...
Suppression de libtalloc2:i386 (2.4.2-1+b1) ...
Suppression de libtdb1:i386 (1.4.10-1) ...
Suppression de libtirpc-dev:i386 (1.3.4+ds-1.2) ...
Suppression de libunibreak5:i386 (5.1-2) ...
Suppression de liburing2:i386 (2.5-1) ...
Suppression de libvidstab1.1:i386 (1.1.0-2+b1) ...
Suppression de libvpx8:i386 (1.13.1-2) ...
Suppression de libwavpack1:i386 (5.7.0-1) ...
Suppression de libwayland-cursor0:i386 (1.22.0-2.1+b1) ...
Suppression de libwayland-egl1:i386 (1.22.0-2.1+b1) ...
Suppression de libwayland-server0:i386 (1.22.0-2.1+b1) ...
Suppression de libwbclient0:i386 (2:4.19.5+dfsg-4+b2) ...
Suppression de libwebrtc-audio-processing1:i386 (0.3-1+b1) ...
Suppression de libwildmidi2:i386 (0.4.3-1+b2) ...
Suppression de libxcursor1:i386 (1:1.2.1-1) ...
Suppression de libxi6:i386 (2:1.8.1-1) ...
Suppression de libxkbcommon0:i386 (1.6.0-1) ...
Suppression de libxrandr2:i386 (2:1.5.4-1) ...
Suppression de libxss1:i386 (1:1.2.3-1) ...
Suppression de libyajl2:i386 (2.1.0-5+b1) ...
Suppression de libzimg2:i386 (3.0.5+ds1-1+b1) ...
Suppression de libzix-0-0:i386 (0.4.2-2+b1) ...
Suppression de libzzip-0-13t64:i386 (0.13.72+dfsg.1-1.2) ...
Suppression de linux-image-6.1.0-10-686-pae (6.1.38-2) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-6.1.0-10-686-pae
/etc/kernel/postrm.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-6.7.9-686-pae
Found initrd image: /boot/initrd.img-6.7.9-686-pae
Found linux image: /boot/vmlinuz-6.1.0-13-686-pae
Found initrd image: /boot/initrd.img-6.1.0-13-686-pae
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
done
Suppression de perl-modules-5.36 (5.36.0-7+deb12u1) ...
Suppression de pocketsphinx-en-us (0.8+5prealpha+1-15) ...
Suppression de timgm6mb-soundfont (1.3-5) ...
Suppression de x11-common (1:7.7+23) ...
Traitement des actions différées (« triggers ») pour man-db (2.12.0-3+b1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.37-15.1) ...
 




~$ apt list '?obsolete'


En train de lister... Fait
cpp-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
fonts-dejavu-mono/now 2.37-8 all  [installé, local]
gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]
gcc-14-base/now 14-20240315-1 i386  [installé, local]
libabsl20220623t64/now 20220623.1-3.1 i386  [installé, local]
libapt-pkg6.0t64/now 2.7.14 i386  [installé, local]
libasound2t64/now 1.2.11-1+b1 i386  [installé, local]
libatopology2t64/now 1.2.11-1+b1 i386  [installé, local]
libavif16/now 1.0.4-1+b2 i386  [installé, local]
libcbor0.10/now 0.10.2-1.2 i386  [installé, local]
libcurl4t64/now 8.7.1-1 i386  [installé, local]
libdav1d7/now 1.4.1-1 i386  [installé, local]
libdb5.3t64/now 5.3.28+dfsg2-6 i386  [installé, local]
libefiboot1t64/now 38-3.1 i386  [installé, local]
libefivar1t64/now 38-3.1 i386  [installé, local]
libelf1t64/now 0.191-1 i386  [installé, local]
libext2fs2t64/now 1.47.0-2.4 i386  [installé, local]
libgcc-13-dev/now 13.2.0-21 i386  [installé, local]
libgdbm-compat4t64/now 1.23-5.1+b1 i386  [installé, local]
libgdbm6t64/now 1.23-5.1+b1 i386  [installé, local]
libglib2.0-0t64/now 2.78.4-6 i386  [installé, local]
libgnutls30t64/now 3.8.3-1.1+b1 i386  [installé, local]
libheif-plugin-aomenc/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-dav1d/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-libde265/now 1.17.6-1+b2 i386  [installé, local]
libheif-plugin-x265/now 1.17.6-1+b2 i386  [installé, local]
libhogweed6t64/now 3.9.1-2.2 i386  [installé, local]
libhwy1t64/now 1.0.7-8.1 i386  [installé, local]
libllvm17t64/now 1:17.0.6-9 i386  [installé, local]
libmagic1t64/now 1:5.45-3 i386  [installé, local]
libmbedcrypto7t64/now 2.28.7-1.1 i386  [installé, local]
libnettle8t64/now 3.9.1-2.2 i386  [installé, local]
libnorm1t64/now 1.5.9+dfsg-3.1 i386  [installé, local]
libnpth0t64/now 1.6-3.1 i386  [installé, local]
libopenmpt0t64/now 0.7.3-1.1+b1 i386  [installé, local]
libperl5.38t64/now 5.38.2-3.2 i386  [installé, local]
libpgm-5.3-0t64/now 5.3.128~dfsg-2.1 i386  [installé, local]
libpng16-16t64/now 1.6.43-3 i386  [installé, local]
libpsl5t64/now 0.21.2-1.1 i386  [installé, local]
libreadline8t64/now 8.2-4 i386  [installé, local]
libsframe1/now 2.42-4 i386  [installé, local]
libsharpyuv0/now 1.3.2-0.4+b1 i386  [installé, local]
libssh2-1t64/now 1.11.0-4.1+b1 i386  [installé, local]
libssl3t64/now 3.1.5-1.1 i386  [installé, local]
libtirpc3t64/now 1.3.4+ds-1.2 i386  [installé, local]
libunistring5/now 1.2-1 i386  [installé, local]
liburcu8t64/now 0.14.0-3.1 i386  [installé, local]
libuv1t64/now 1.48.0-1.1 i386  [installé, local]
libzvbi0t64/now 0.2.42-2 i386  [installé, local]
linux-image-6.1.0-13-686-pae/now 6.1.55-1 i386  [installé, local]
linux-image-6.7.9-686-pae/now 6.7.9-2 i386  [installé, local]
perl-modules-5.38/now 5.38.2-3.2 all  [installé, local]
systemd-dev/now 255.4-1 all  [installé, local]
 



Donc si je ne me trompe pas il reste

gcc-13-base/now 13.2.0-21 i386  [installé, local]
gcc-13-i686-linux-gnu/now 13.2.0-21 i386  [installé, local]
gcc-13/now 13.2.0-21 i386  [installé, local]


et

libavif16/now 1.0.4-1+b2 i386  [installé, local]



donc je fais

~$ aptitude why gcc-13


i   aptitude     Recommande libdpkg-perl    
i A libdpkg-perl Suggère    gcc | c-compiler
i A gcc-13       Fournit    c-compiler  



$ aptitude why libavif16



i   aptitude      Recommande libdpkg-perl              
i A libdpkg-perl  Suggère    gcc | c-compiler          
i A gcc           Recommande libc6-dev | libc-dev      
i A libc6-dev     Dépend     libc-dev-bin (= 2.37-15.1)
i A libc-dev-bin  Recommande libc-devtools (> 2.37)    
i A libc-devtools Dépend     libgd3 (>= 2.1.0~alpha~)  
i A libgd3        Dépend     libavif16 (>= 1.0.4)  



EDIT:
Si j'interprète bien les résultats des 2 commandes, c'est aptitude qui a "besoin" via les dépendances de gcc-13 et libavif16???

Dernière modification par wardidi (03-04-2024 16:22:33)

Hors ligne

#24 03-04-2024 17:28:42

vv222
Administrateur
Lieu : Bretagne
Distrib. : Debian Sid
(G)UI : sway
Inscription : 18-11-2013
Site Web

Re : [Abandonné]downgrader trixie/sid vers bookworm

À noter pour plus tard : mpd a été désinstallé, il faudra penser à le réinstaller une fois le retour en arrière terminé.

---

Je pense que la plupart des paquets liés à gcc 13 peuvent être maintenant retirés sans conséquence indésirable :

apt remove cpp-13-i686-linux-gnu gcc-13-i686-linux-gnu gcc-13


J’ai un doute par contre pour les variantes "gcc-*-base" :

aptitude why gcc-13-base
aptitude why gcc-14-base



---

Le paquet libavif16 est installé en dépendance à libgd3, remettre celui-ci dans la version de Bookworm devrait permettre de retirer libavif16 ensuite :

apt install --mark-auto libgd3/bookworm


Jouer sous Debian ? Facile !

Ceterum censeo Barum esse delendam

Hors ligne

#25 03-04-2024 17:49:58

wardidi
Membre
Lieu : Bretagne
Distrib. : DF 12.4
Noyau : 6.1.0-13-amd64
Inscription : 28-11-2022

Re : [Abandonné]downgrader trixie/sid vers bookworm

Un grand merci vv222 pour tout le temps passé avec moi.

vv222 a écrit :

À noter pour plus tard : mpd a été désinstallé, il faudra penser à le réinstaller une fois le retour en arrière terminé.



Il tourne encore...

~$ sudo apt remove cpp-13-i686-linux-gnu gcc-13-i686-linux-gnu gcc-13


 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gcc-13-base libgcc-13-dev
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  cpp-13-i686-linux-gnu gcc-13 gcc-13-i686-linux-gnu
0 mis à jour, 0 nouvellement installés, 3 à enlever et 0 non mis à jour.
Après cette opération, 118 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 45620 fichiers et répertoires déjà installés.)
Suppression de gcc-13 (13.2.0-21) ...
Suppression de gcc-13-i686-linux-gnu (13.2.0-21) ...
Suppression de cpp-13-i686-linux-gnu (13.2.0-21) ...
Traitement des actions différées (« triggers ») pour man-db (2.12.0-3+b1) ...



~$ aptitude why gcc-13-base


Automatically installed, current version 13.2.0-21, priority optionnel
No dependencies require to install gcc-13-base
 



~$ aptitude why gcc-14-base


i   libstdc++6 Dépend gcc-14-base (= 14-20240315-1



~$ sudo apt install --mark-auto libgd3/bookworm


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Version choisie « 2.3.3-9 » (Debian:12.5/stable [i386]) pour « libgd3 »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gcc-13-base libavif16 libgcc-13-dev
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libavif15
Paquets suggérés :
  libgd-tools
Les NOUVEAUX paquets suivants seront installés :
  libavif15
Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  libgd3
0 mis à jour, 1 nouvellement installés, 1 remis à une version inférieure, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 229 ko dans les archives.
Après cette opération, 226 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian bookworm/main i386 libavif15 i386 0.11.1-1 [101 kB]
Réception de :2 http://deb.debian.org/debian bookworm/main i386 libgd3 i386 2.3.3-9 [129 kB]
229 ko réceptionnés en 0s (593 ko/s)
Sélection du paquet libavif15:i386 précédemment désélectionné.
(Lecture de la base de données... 45559 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libavif15_0.11.1-1_i386.deb ...
Dépaquetage de libavif15:i386 (0.11.1-1) ...
dpkg: avertissement: dégradation (« downgrade ») de libgd3:i386 depuis 2.3.3-9+b2 vers 2.3.3
-9
Préparation du dépaquetage de .../libgd3_2.3.3-9_i386.deb ...
Dépaquetage de libgd3:i386 (2.3.3-9) sur (2.3.3-9+b2) ...
Paramétrage de libavif15:i386 (0.11.1-1) ...
Paramétrage de libgd3:i386 (2.3.3-9) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.37-15.1) ...



Je pense devoir mais n'ose pas faire

sudo apt autoremove

pour supprimer gcc-13-base libavif16 libgcc-13-dev?

Hors ligne

Pied de page des forums