Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#2 Re : Réseau » Bullseye - connexion internet via mon téléphone portable HS » 04-09-2022 13:55:00

Bjr,

Pas de raison que ça ne fonctionne pas, hors matériel défectueux (câble, prise usb, rallonge, etc...)
Un simple /etc/network/interfaces avec ces lignes:

# The loopback network interface
auto lo
iface lo inet loopback
## avec cable usb
auto usb0
iface usb0 inet dhcp
 

devrait suffire.
Peut être voir si network-manager doit être désactivé (ou purgé quitte à le réinstaller plus tard)

#3 Re : Installation de Debian » Passer de Debian 9 à Debian 11 directement c'est possible ? [RéSOLU] » 08-08-2022 16:44:28

Bjr,

Sinon pour le boot sur usb il existe Plop Boot Manager qui fournit différentes méthodes dont une qui consiste à ajouter un fichier .bin dans /boot  puis à créer une entrée dans Grub. Fonctionne très bien pour un boot sur dd externe par exemple.

#4 Re : Matériel » Tour Dell XPS : bips au démarrage et aucun affichage » 19-07-2022 12:05:48

Bjr,

Est-ce qu'il y a une série de diodes à l'arrière de la tour ? si oui quelles en sont les couleurs (de gauche à droite ou ABCD) ?

#5 Re : Multimédia » ffmpeg : Conversion de videos mp4-mkv-avi vers le format DVD PAL mpeg2 » 01-07-2022 13:46:54

Bjr,

D'accord pour comprendre au lieu de copier bêtement, mais encore faut-il avoir reçu des bases de manière compréhensible par le pékin lambda; il me semble que c'est le cas ici.
Merci pour ce "tuto", ça manquait.

#6 Re : Installation de Debian » [ Abandonné ] Micro code manquant pour détecter le réseau » 09-06-2022 12:43:14

Si on se base sur ce que tu as écris dans ton premier post

grep firmware debian-facile-11.3_amd64.pkgs

alsa-firmware-loaders 1.2.2-1
atmel-firmware  1.3-4.1
bluez-firmware  1.2-4
dahdi-firmware-nonfree  2.11.1.0.20170917-1
firmware-amd-graphics 20210315-3
firmware-ath9k-htc  1.4.0-106-gc583009+dfsg1-1
firmware-atheros  20210315-3
firmware-b43-installer  1:019-7
firmware-b43legacy-installer  1:019-7
firmware-bnx2 20210315-3
firmware-bnx2x  20210315-3
firmware-brcm80211  20210315-3
firmware-cavium 20210315-3
firmware-intel-sound  20210315-3
firmware-intelwimax 20210315-3
firmware-ipw2x00  20210315-3
firmware-ivtv 20210315-3
firmware-iwlwifi  20210315-3
firmware-libertas 20210315-3
firmware-linux  20210315-3
firmware-linux-free 20200122-1
firmware-linux-nonfree  20210315-3
firmware-misc-nonfree 20210315-3
firmware-myricom  20210315-3
firmware-netronome  20210315-3
firmware-netxen 20210315-3
firmware-qcom-soc 20210315-3
firmware-qlogic 20210315-3
firmware-realtek  20210315-3
firmware-samsung  20210315-3
firmware-siano  20210315-3
firmware-sof-signed 1.7-1
firmware-ti-connectivity  20210315-3
firmware-zd1211 1:1.5-7
hdmi2usb-fx2-firmware 0.0.0~git20151225-3

#7 Re : Installation de Debian » [ Abandonné ] Micro code manquant pour détecter le réseau » 08-06-2022 09:42:10

Bjr,

Est-ce qu'il y a quelque part de la doc sur la procédure d'installation de l'iso DF ?

#8 Re : Système » [Clos] Disque dur non présent dans le BIOS » 04-06-2022 13:15:41

Bjr,

Au cas où, pas sur que la version du grub2 de wheezy soit compatible avec celle de buster. De mémoire il faut ajouter une option

grub-install --recheck /dev/sdx

#9 Re : Système » démarrage lent » 28-05-2022 18:14:26

Bjr,

Sauf si les règles ont changé, le fichier "preferences" me semble inutile sous sid

#10 Re : Système » [Résolu] Problème après copie partition : DD vers SSD » 22-05-2022 17:12:09

Merci tout de même, bien que wine ne soit, à mon avis, pas en cause. Il suffit de copier les 2 répertoires cxoffice et .cxoffice et ça fonctionne sur plusieurs partitions de dd autres que celles du ssd en cause.
C'est soit lvm, soit le ssd, soit un problème de copie de la partition.
Pareil pour Rox-filer jamais je n'ai rencontré une telle erreur, c'est pourquoi j'ai commencé par ça.

#11 Re : Système » [Résolu] Problème après copie partition : DD vers SSD » 22-05-2022 16:32:44

Non, le chroot n'est pas le lien entre l'original du dd et sa copie sur le ssd.
Si je boote sur la partition phssd tout semble fonctionner correctement, comme sur l'original, sauf les applis microsoft office que je lance à travers wine/crossover. Par exemple si je lance une base *.mdb, msaccess se lance seul; si j'indique le chemin de la base depuis access, il ne se passe rien, access ne trouve pas la base. Pour un classeur *.xls, excel ne trouve pas la macrolib EUROTOOL.XLA, ni le classeur lancé. Pour word c'est encore autre chose. Sur certains essais j'ai un message comme quoi le fichier, ou la base, sont déjà ouverts par un autre utilisateur.
Donc du coup tu dois comprendre la corrélation entre le mauvais affichage renvoyé par rox dans le chroot et les chemins inconnus des applis vers les fichiers. D'ailleurs si je lance ces mêmes applis depuis le chroot il y a le même comportement.

#12 Re : Système » [Résolu] Problème après copie partition : DD vers SSD » 22-05-2022 15:33:08

Je suis d'accord, il n'y a apparemment pas de rapport. C'est juste qu'à force de chercher d'où vient le problème, j'explore les pistes que je trouve.
Lancer "rox" n'a aucune importance, ça montre juste que quelque chose est mal configuré; il y a d'autres partitions sur le même ssd, en lvm ou en primaire, et le problème de ne se pose pas.
Il y un lien entre l'original du dd et sa copie sur le ssd; ce n'est ni une UUID clonée, ni quoique soit dans initramfs. Pour le moment le seul rapport est l'identifiant similaire dans grub.

#13 Re : Système » [Résolu] Problème après copie partition : DD vers SSD » 22-05-2022 13:51:59

Après avoir passé cette commande pas de changement; le /dev/disk/by-id/ reste le même sur les 2 partitions et toujours le même problème de lancement d'une appli graphique dans le chroot.
Pour préciser ce problème, en lançant "rox" (mon filer de prédilection) il affiche non pas le contenu du répertoire (/home/ph/) du chroot mais celui de l'hôte; dans ce cas inutile de booter sur la partition du ssd je sais qu'il y aura d'autres soucis.

Bref, peut être plutôt réinstaller grub dans le chroot ?

#14 Système » [Résolu] Problème après copie partition : DD vers SSD » 22-05-2022 12:22:57

phlinux
Réponses : 8
Bonjour,
Est-ce que le même identifiant, /dev/disk/by-id/ata-ST380215A_9QZ2MLS2, sur 2 partitions, l'une étant la copie de l'autre (DD= original, SSD=copie), peut être la source de problèmes, par exemple lors d'un lancement d'une appli graphique dans un chroot ?

[12:08]phDD:~$ debconf-show grub-pc


grub-pc/install_devices_empty: false
  grub-pc/kopt_extracted: false
  grub-pc/chainload_from_menu.lst: true
  grub-pc/install_devices_failed_upgrade: true
  grub-pc/mixed_legacy_and_grub2: true
  grub2/update_nvram: true
  grub2/kfreebsd_cmdline:
  grub2/device_map_regenerated:
* grub-pc/install_devices: /dev/disk/by-id/ata-ST380215A_9QZ2MLS2
  grub-pc/install_devices_disks_changed:
  grub-pc/postrm_purge_boot_grub: false
  grub2/kfreebsd_cmdline_default: quiet
  grub2/force_efi_extra_removable: false
  grub-pc/install_devices_failed: false
* grub2/linux_cmdline_default: quiet
  grub-pc/disk_description:
  grub-pc/hidden_timeout: false
  grub-pc/timeout: 5
  grub-pc/partition_description:
* grub2/linux_cmdline:

(phssd)ph@phlinux:~$ debconf-show grub-pc


grub-pc/mixed_legacy_and_grub2: true
  grub-pc/disk_description:
* grub2/linux_cmdline_default: quiet
  grub-pc/install_devices_failed: false
  grub2/kfreebsd_cmdline_default: quiet
* grub2/linux_cmdline:
  grub-pc/install_devices_failed_upgrade: true
  grub-pc/timeout: 5
* grub-pc/install_devices: /dev/disk/by-id/ata-ST380215A_9QZ2MLS2
  grub2/force_efi_extra_removable: false
  grub2/device_map_regenerated:
  grub-pc/install_devices_empty: false
  grub-pc/kopt_extracted: false
  grub-pc/partition_description:
  grub2/update_nvram: true
  grub2/kfreebsd_cmdline:
  grub-pc/chainload_from_menu.lst: true
  grub-pc/postrm_purge_boot_grub: false
  grub-pc/install_devices_disks_changed:
  grub-pc/hidden_timeout: false

Merci d'avance

#15 Re : Autres » openshot » 07-05-2022 11:24:44

Bjr,

Si on est pas renseigné c'est que tu ne donnes aucun renseignements. On ne sait pas qui tu es, tu ne t'es pas présenté, et surtout on ne connaît pas ta config matériel.

#16 Re : Gestion des paquets Debian » [RESOLU]Dependances non trouvées » 06-05-2022 11:30:35

Tu peux aussi tenter d'installer la clé

apt-get install --reinstall debian-archive-keyring

#17 Re : Gestion des paquets Debian » [RESOLU]Dependances non trouvées » 05-05-2022 10:22:21

Bjr,

Le sources.list est-il à jour ? Disons avec l'adresse des archives ? J'avais ça pour wheezy regarde si ça fonctionne pour Lenny

deb http://archive.debian.org/debian/ lenny main

deb http://archive.debian.org/debian-archive/debian-security/ lenny updates/main

#18 Re : Réseau » Transformer un vieux PC en Routeur internet » 02-05-2022 12:45:21

Ah oui bien sur.
Juste un peu embrouillé avec le usb0; curieux que ça existe encore sur debian 11

#19 Re : Réseau » Transformer un vieux PC en Routeur internet » 02-05-2022 11:12:38

Et la gateway n'est pas utile ?
Pour faciliter les retours, au lieu de les recopier, il faudrait sans doute commencer par connecter le routeur au réseau/web en établissant un fichier interfaces fonctionnel

#20 Re : Multimédia » Conversion mp4 en mpg » 27-04-2022 11:53:33

Ok, merci pour ton aide.

Pour le "-target pal-dvd" s'il ne "preset" que ces 2 valeurs ça va. J'avais trouvé sur la conversion mp4>avi qu'il est assez efficace de calculer le ratio de l'original, surtout quand il est exotique, et de le paramétrer avec par exemple "-vf scale=720x404,setsar=1:1". Je ne ferai pas des tonnes de conversions, donc quelques petits calculs c'est que dalle. Au pire un petit script fera le boulot.
Par contre il faut que je m'instruise sur les autres options pour voir si on peut gagner en "poids"; si je pouvais mettre au moins 2 films sur 1 dvd ce serait un bon résultat.

#21 Re : Multimédia » Conversion mp4 en mpg » 26-04-2022 12:24:07

Bjr,

Effectivement tu arrives à un bon ratio sur la conversion avi > mpeg : environ x4,6

Sur les mp4 j'ai eu des résultats nettement moins bon: entre x7 et x15 suivant la video. Je pense que c'est en fonction du format de l'original, parfois "exotique". A noter aussi que c'est nettement plus lent que le script en 2 passes plus haut. Mais c'est sans doute à cause de la qualité demandée en sortie, "-b:v 5000k" ce qui semble logique pour graver sur un support fixe.

Oui "-target pal-dvd" c'est à placer. Par contre tu dis "plutôt que des options personnalisées"; elles le sont toutes plus ou moins, non ?

#22 Re : Multimédia » Conversion mp4 en mpg » 25-04-2022 12:13:52

Comme je l'ai écrit j'ai essayé un certain nombre de ldc, des plus simples à des plus complexes; celle que j'ai postée est un des exemples "complexes".
Mais le plus important c'est que tous ces essais mènent à un résultat catastrophique en terme de poids.
Tout de suite je fais des essais avec winff pour voir; bien sur, comme d'hab, ça ne fonctionne jamais du premier coup, et il faut modifier les paramètres.

#23 Re : Multimédia » Conversion mp4 en mpg » 25-04-2022 10:43:28

Pour le moment je cherche à comprendre un minimum comment ça se passe en ldc. En général ce n'est pas une perte de temps. Merci pour ta réponse

#24 Multimédia » Conversion mp4 en mpg » 24-04-2022 10:38:42

phlinux
Réponses : 11
Bjr,

Dans ma série conversion en tous genres, je souhaiterais convertir quelques mp4 vers du mpg afin de les graver ensuite sur dvd; donc structure en VIDEO-TS etc...

J'ai essayé quelques lignes de commandes mais le poids de la video mp4 est multiplié par 11 ou 12 pour du mpg. Donc c'est pas possible, on imagine ce que ça donne pour un fichier mp4 qui fait 700M...

J'avais bien réussi auparavant mais j'ai oublié, et pas noté, la manip; dans ce cas là c'était un fichier .avi qui avait grossi d'environ x 3 avec une qualité proche de l'original mp4. Donc là on est dans le raisonnable.

Dans les commandes essayées voici un script en double passe qui grossit d'environ x 11:

#!/bin/bash

ffmpeg -i mon.mp4 -f mpeg2video -c:v:0 mpeg2video -b_strategy 2 -brd_scale 2 -profile:v 4 -intra_matrix "8,8,9,9,10,10,11,11,8,9,9,10,10,11,11,12,9,9,10,10,11,11,12,12,9,10,10,11,11,12,13,13,10,10,11,11,12,13,13,14,10,11,11,12,13,13,14,15,11,11,12,13,13,14,15,15,11,12,12,13,14,15,15,16" -inter_matrix "8,8,9,9,10,10,11,11,8,9,9,10,10,11,11,12,9,9,10,10,11,11,12,12,9,10,10,11,11,12,13,13,10,10,11,11,12,13,13,14,10,11,11,12,13,13,14,15,11,11,12,13,13,14,15,15,11,12,12,13,14,15,15,16" -aspect 16:9 -s 640x358 -r 24000/1001 -g 12 -pix_fmt yuv420p -b:v:0 7990000 -maxrate:v:0 8000000 -dc 10 -bf 2 -q:v 2 -bufsize:v:0 1835008 -packetsize 2048 -muxrate 10080000 -vf scale=852:480,pad=854:480:1:0 -map 0:v:0 -an -passlogfile "ffmpeg.log" -pass 1 -y "NUL.avi"

ffmpeg -i mon.mp4 -f mpeg2video -c:v:0 mpeg2video -pre_dia_size 5 -dia_size 5 -qcomp 0.7 -qblur 0 -preme 2 -me_method dia -sc_threshold 0 -bidir_refine 4 -profile:v 4 -mbd rd -mbcmp satd -precmp satd -cmp satd -subcmp satd -skipcmp satd -intra_matrix "8,8,9,9,10,10,11,11,8,9,9,10,10,11,11,12,9,9,10,10,11,11,12,12,9,10,10,11,11,12,13,13,10,10,11,11,12,13,13,14,10,11,11,12,13,13,14,15,11,11,12,13,13,14,15,15,11,12,12,13,14,15,15,16" -inter_matrix "8,8,9,9,10,10,11,11,8,9,9,10,10,11,11,12,9,9,10,10,11,11,12,12,9,10,10,11,11,12,13,13,10,10,11,11,12,13,13,14,10,11,11,12,13,13,14,15,11,11,12,13,13,14,15,15,11,12,12,13,14,15,15,16" -aspect 16:9 -s 640x358 -r 24000/1001 -g 12 -pix_fmt yuv420p -b:v:0 7990000 -maxrate:v:0 8000000 -dc 10 -bf 2 -lmin 0.75 -mblmin 50 -qmin 1 -bufsize:v:0 1835008 -packetsize 2048 -muxrate 10080000 -vf scale=638:358,pad=640:358:1:0 -map 0:v:0 -passlogfile "ffmpeg.log" -pass 2 "test.m2v" -f ac3 -b:a 192000 -ar 48000 -c:a:0 ac3 -map 0:a:0 "test.ac3"

Des conseils, des idées ?
Merci d'avance

Pied de page des forums

Propulsé par FluxBB