Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 21-11-2019 18:43:13

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Herbert West  a écrit :

t'as pas bien lu ou je m'exprime mal


oui , je suis sans doute un peu dur de la feuille ...   lol

Herbert West  a écrit :

mon souhait est d'etre a tout prix sous wayland


oui , çà , j'ai compris .  big_smile

Herbert West  a écrit :

je n'ai jamais installé de pilote proprio


ben si , justement , que tu l'installes depuis le site de Nvidia ou depuis les dépôts ,
que ce soit , un ".run" ou un ".deb" (nvidia) voire un paquet depuis les backports (nvidia-driver) ,
çà reste un pilote proprio .  tongue
seul est considéré comme libre le pilote "nouveau" , souvent installé par défaut sous debian avec Nvidia . cool

Herbert West  a écrit :

le pilote proprio ne marche que sous x11, pas sous wayland


oui , je sais . je te l'ai déjà précisé . smile

Herbert West  a écrit :

je vais essayer de me faire echanger cette merde de nvidia et prendre une amd rx5xx qui elles sont bcp mieux supportées


j'espère que tu vas y arriver . toutes les boutiques ne le permettent pas  toujours .
par contre tu te trompes , Nvidia ne sont pas des merdes .
elles sont compliquées , c'est vrai , mais , chez AMD , je connais pas de remplaçant à Cuda .
si , OpenGL (je crois) , mais je sais pas  m'en servir . ops.gif

Herbert West  a écrit :

bref , je deteste nvidia


je te comprends . guantas.png

Herbert West  a écrit :

je vais essayer de me faire echanger cette merde de nvidia et prendre une amd rx5xx qui elles sont bcp mieux supportées


-- AMD RX 550 -- (la mienne)  et -- AMD RX 560 --

ce sont là des petites cartes mais  qui fonctionnent très bien et sont les concurrentes directes  de la  GTX1050

-- installation type cartes AMD récentes --

-- installation type cartes Nvidia récentes --

Dernière modification par Debian Alain (21-11-2019 21:15:04)

Hors ligne

#27 25-11-2019 00:26:28

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

mon dealer me l'echange contre la rx 560
merci alain

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#28 25-11-2019 10:38:24

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

oui , je crois que les  RX550 et RX540 sont en fin de  stock .

Hors ligne

#29 25-11-2019 19:52:09

seb95
Membre
Distrib. : openSUSE Leap et Tumbleweed
(G)UI : GNOME, Xfce et KDE
Inscription : 19-02-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

nvidia gtx 1050 ti n'est pas une merde, ni nvidia, par contre galère sous debian et securboot pour les pilotes nonlibres de nvidia... Ça c'est un fait. Ma carte fonctionne parfaitement avec les deux pilotes apres avoir creusé la question et demandé de l'aide ici même quand je n'y comprenais plus rien.

https://debian-facile.org/viewtopic.php?id=25742

Hors ligne

#30 25-11-2019 20:37:08

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

seb95 a écrit :

nvidia gtx 1050 ti n'est pas une merde, ni nvidia, par contre galère sous debian et securboot pour les pilotes nonlibres de nvidia... Ça c'est un fait. Ma carte fonctionne parfaitement avec les deux pilotes apres avoir creusé la question et demandé de l'aide ici même quand je n'y comprenais plus rien.

https://debian-facile.org/viewtopic.php?id=25742



salut
oui oui on est deja au courant


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#31 25-11-2019 20:47:11

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Debian Alain a écrit :

ben , Herbert West , je comprends pas trop .

tu installes debian par défaut , donc en legacy et avec nouveau .

et , par dessus , tu installes le pilote proprio  ...  https://debian-facile.org/img/smilies/x … chhead.gif

surtout que , à première vue , çà avait l'air de bien fonctionner avec nouveau , non ? https://debian-facile.org/img/smilies/x … kPowaa.gif

non , vraiment , comprends pas ... roll

tongue

p.s. : si tu installes le pilote proprio , tu as pensé à installer les headers , avant ?
que donne :

dpkg -l | grep -iE "linux-image|linux-headers"



moi non plus
j'ai essayé nouveau seul, et nouveau efi
nouveau me fait grave ramer
la premiere install ou vous m'avez dit que j'avais installé le proprio ;ça marchait nickel sauf que j'etais en uefi donc sous x11 :mais je n'ai jamais installé nvidia-driver(ou alors je suis debile; j'en suis a 95%sur)

je pense que l'uefi fait un peu de la loterie et perturbe les microcodes..cependant je reviens sur ce que j'ai dit, il est primordial pour la sécurité du bios.


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#32 25-11-2019 20:53:59

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

j'y ai pas pensé (je savais pas) mais d'aucuns ont dénoncé l'influence du "sécure boot" sur les pilotes Nvidia ...

p ê ...

Hors ligne

#33 26-11-2019 11:09:57

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

çà donne quoi avec ta nouvelle carte , Herbert West ???

Hors ligne

#34 26-11-2019 11:50:44

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

j'ai enlevé la nvidia
j'ai mis la rx560, le pilote (xserver-xorg-video-amdgpu) etait deja installé. ça tourne nickel
apres j'ai pas vu l'acceleration materielle, y a un soucis benin sur le fait que c'est une polaris 21 et pas 11 .

apres j'ai pas trop eu le temps si il fallait mettre des firmware ou installer le pilote proprio
et je suis sous wayland

comme un con j'ai oublié la cle usb d'installation . demain je reinstallerai en efi proprement

tu l'as installé comment la tienne alain?

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#35 26-11-2019 11:57:33

Debian Alain
Adhérent(e)
Lieu : Bretagne
Distrib. : stable / testing
Noyau : Linux 5.9.0-2-amd64
(G)UI : Gnome X.org (X11) / GDM3
Inscription : 11-03-2017
Site Web

Re : debian 10 nvidia-detect pas de wayland [non résolu]

moi , je suis en legacy (dos) , pas en U.E.F.I.

Hors ligne

#36 26-11-2019 16:59:38

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

je suis pas sur ,mais si ton bios et nouveau ,tu as enlevé sécure boot, donc une protection pour ton bios

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#37 26-11-2019 21:57:26

Grompf
Membre
Distrib. : Debian Buster Gnome
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.30.2
Inscription : 08-06-2016

Re : debian 10 nvidia-detect pas de wayland [non résolu]

...Bonsoir,

Je vais vérifier mais...
J'ai installé il y a peu Debian Gnome sur mon Thinkpad T510, doté d'une Nvidia et j'ai mis le pilote proprio.
Mais je n'ai pas revérifié ensuite s'il avait viré Wayland au profit de Xorg.
En tous cas le PC fonctionne sans soucis.

CONFIGURATION :
1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Gnome (stable)
2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Debian Gnome (stable)
3. Lenovo Thinkpad X230 i5 - carte graphique Intel Corporation - Debian Gnome (stable)

Hors ligne

#38 27-11-2019 14:14:10

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Grompf a écrit :

...Bonsoir,

Je vais vérifier mais...
J'ai installé il y a peu Debian Gnome sur mon Thinkpad T510, doté d'une Nvidia et j'ai mis le pilote proprio.
Mais je n'ai pas revérifié ensuite s'il avait viré Wayland au profit de Xorg.
En tous cas le PC fonctionne sans soucis.


oui mais je te paries ta retraite que t'es pas sous wayland:D


[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#39 01-12-2019 20:34:45

Grompf
Membre
Distrib. : Debian Buster Gnome
Noyau : Linux 4.19.0-6-amd64
(G)UI : Gnome 3.30.2
Inscription : 08-06-2016

Re : debian 10 nvidia-detect pas de wayland [non résolu]

Herbert west a écrit :

Grompf a écrit :

...Bonsoir,

Je vais vérifier mais...
J'ai installé il y a peu Debian Gnome sur mon Thinkpad T510, doté d'une Nvidia et j'ai mis le pilote proprio.
Mais je n'ai pas revérifié ensuite s'il avait viré Wayland au profit de Xorg.
En tous cas le PC fonctionne sans soucis.


oui mais je te paries ta retraite que t'es pas sous wayland:D



J'ai bien fait de ne pas prendre le pari.

echo $XDG_SESSION_TYPE


x11


CONFIGURATION :
1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - Debian Gnome (stable)
2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Debian Gnome (stable)
3. Lenovo Thinkpad X230 i5 - carte graphique Intel Corporation - Debian Gnome (stable)

Hors ligne

#40 02-12-2019 10:57:14

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : mise a jour toutes les semaines :amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : debian 10 nvidia-detect pas de wayland [non résolu]

est ce qu'un jour ils vont abandonner x11? surement; j'ai pas envie de refaire une install avec wayland dans 2ans
merci pour votre aide
bonne journée

[I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport ]
[ hp spectre x360 i5 ] / [ raspbery pi 1.2 ] / [ 2 fixes core 2duo de recup ]
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

Pied de page des forums